ネットワーク構成

junper-cisco_lag01.png

図 ネットワーク構成(物理)

設定条件

  • SRX210 ge-0/0/0とge-0/0/1およびCat3750 fa1/0/13とfa1/0/14でリンクアグリゲーションを構成します。
  • LACPによってリンクアグリゲーションのネゴシエーションを行います。
  • リンクアグリゲーションでリンクをまとめたインタフェースはVLAN100のアクセスポートとします。
  • それぞれの機器でVLAN100用のレイヤ3インタフェースを作成し、IPアドレスを次のように設定します。
    SRX210:192.168.100.1/24
    Cat3750:192.168.100.2/24

SRX210の設定

【Step1:VLANの作成】

SRX210でVLAN100を作成します。

SRX210

--------------------------------------
set vlans VLAN100 vlan-id 100
commit
--------------------------------------

【Step2:AE(Aggregated Ethernet)インタフェースの作成】

SRX210でリンクアグリゲーションによってリンクをまとめたAE(Aggregated Ethernet)インタフェース(ae0)を作成します。

SRX210

--------------------------------------
set chassis aggregated-devices ethernet device-count 1
--------------------------------------

【Step3:AEインタフェースの確認】

Step2で作成したAEインタフェースを確認します。AEインタフェースを確認するために、show interfaces ters | match aeコマンドを利用します。

SRX210

--------------------------------------
[edit]
root@SRX1# run show interfaces terse | match ae
ae0                     up    down
--------------------------------------

ae0に対して、まだメンバーインタフェースを割り当てていないので、リンクがdown状態です。

【Step4:AEインタフェースにメンバーインタフェースを割り当て】

ae0でLACP activeモードを有効化します。また、レイヤ2のイーサネットポート(ae0.0)としてVLAN100のアクセスポートにします。そして、fe-0/0/2.0とfe-0/0/3.0をae0.0のメンバーインタフェースとして設定します。

SRX210

--------------------------------------
set interfaces ae0 unit 0 family ethernet-switching vlan members VLAN100
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ge-0/0/0 gigether-options 802.3ad ae0
set interfaces ge-0/0/1 gigether-options 802.3ad ae0
commit
--------------------------------------

【Step5:VLANとアクセスポートの確認】

ae0.0がVLAN100のアクセスポートとなっていることを確認します。VLANとアクセスポートの確認のために、show vlansコマンドを利用します。

SRX210

--------------------------------------
[edit]
root@SRX1# run show vlans
Name           Tag     Interfaces
VLAN100        100
ae0.0*
default        1
None
vlan-trust     3
fe-0/0/4.0, fe-0/0/5.0, fe-0/0/6.0, fe-0/0/7.0
--------------------------------------

【Step6:AEインタフェースの確認】

ae0のメンバーインタフェースを設定したあと、再びAEインタフェースを確認します。show interfaces terse | match aeコマンドを利用します。

SRX210

--------------------------------------
[edit]
root@SRX1# run show interfaces terse | match ae
ge-0/0/0.0              up    up   aenet    --> ae0.0
ge-0/0/1.0              up    up   aenet    --> ae0.0
ae0                     up    down
ae0.0                   up    down eth-switch
--------------------------------------

ge-0/0/0.0とge-0/0/1.0がae0.0のメンバーインタフェースとなっていることがわかります。しかし、ae0.0はまだdownです。これは、対向のCat3750側でリンクアグリゲーションの設定をしていないからです。

【Step7:レイヤ3インタフェースの設定】

SRX210のVLAN100に対応するレイヤ3インタフェースとしてvlan.100を作成します。また、vlan.100に192.168.100.1/24のIPアドレスを設定します。

SRX210

--------------------------------------
set interfaces vlan unit 100 family inet address 192.168.100.1/24
set vlans VLAN100 l3-interface vlan.100
commit
--------------------------------------

Cat3750の設定

【Step1:VLANの作成】

Cat3750でVLAN100を作成します。

Cat3750

--------------------------------------
vlan 100
--------------------------------------

【Step2:Port-channelインタフェースの作成】

Cat3750でインタフェースをまとめるPort-channelインタフェースを作成し、VLAN100のアクセスポートとして設定します。

Cat3750

--------------------------------------
interface Port-channel1
switchport access vlan 100
switchport mode access
--------------------------------------

【Step3:Port-channelインタフェースにメンバーインタフェースの割り当て】

Port-channelインタフェースのメンバーインタフェースとしてFa1/0/13とFa1/0/14を設定します。メンバーインタフェースとしての設定は、channel-groupコマンドを利用します。

Cat3750

--------------------------------------
interface FastEthernet1/0/13
switchport access vlan 100
switchport mode access
channel-group 1 mode active
!
interface FastEthernet1/0/14
switchport access vlan 100
switchport mode access
channel-group 1 mode active
--------------------------------------

【Step4:Port-channelインタフェースの確認】

show etherchennel summaryコマンドでPort-channelインタフェースを確認します。

Cat3750

--------------------------------------
Switch#show etherchannel summary
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3      S - Layer2
U - in use      f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa1/0/13(P) Fa1/0/14(P)
--------------------------------------

Cat3750でもリンクアグリゲーションの設定が完了したので、LACPでSRX210とCat3750間のネゴシエーションができるようになります。その結果、SRX210のae0.0がupになります。

SRX210

--------------------------------------
[edit]
root@SRX1# run show interfaces terse | match ae
ge-0/0/0.0              up    up   aenet    --> ae0.0
ge-0/0/1.0              up    up   aenet    --> ae0.0
ae0                     up    up
ae0.0                   up    up   eth-switch
--------------------------------------

【Step5:VLANとアクセスポートの確認】

show vlan briefコマンドでPort-channel1がVLAN100のアクセスポートとなっていることを確認します。

Cat3750

--------------------------------------
Switch#show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
Fa1/0/4, Fa1/0/5, Fa1/0/6
Fa1/0/7, Fa1/0/8, Fa1/0/9
Fa1/0/10, Fa1/0/11, Fa1/0/12
Fa1/0/15, Fa1/0/16, Fa1/0/17
Fa1/0/18, Fa1/0/19, Fa1/0/20
Fa1/0/21, Fa1/0/22, Fa1/0/23
Fa1/0/24, Gi1/0/1, Gi1/0/2
2    VLAN0002                         active
3    VLAN0003                         active
10   VLAN0010                         active
20   VLAN0020                         active
30   VLAN0030                         active
100  VLAN0100                         active    Po1
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
--------------------------------------

【Step5:レイヤ3インタフェースの作成】

Cat3750でVLAN100のレイヤ3インタフェースを作成し、192.168.100.2/24のIPアドレスを設定します。

Cat3750

--------------------------------------
interface Vlan100
ip address 192.168.100.2 255.255.255.0
--------------------------------------

ここまででSRX210とCat3750の設定はすべて完了です。SRX210、Cat3750の

  • 物理的なインタフェース
  • リンクアグリゲーションのインタフェース
  • VLAN
  • レイヤ3インタフェース

の関連をまとめると、次の図のようになります。

junper-cisco_lag02.png
図 インタフェースの関連

【Step6:通信確認】

SRX210とCat3750間で正常に通信ができることを確認します。

Cat3750

--------------------------------------
Switch#ping 192.168.100.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
--------------------------------------