ネットワーク構成

junper-cisco_lag01.png

図 ネットワーク構成(物理)

設定条件(レイヤ3リンクアグリゲーション)

  • SRX210 ge-0/0/0とge-0/0/1およびCat3750 fa1/0/13とfa1/0/14でリンクアグリゲーションを構成します。
  • LACPによってリンクアグリゲーションのネゴシエーションを行います。
  • リンクアグリゲーションでリンクをまとめたインタフェースにIPアドレスを次のように設定します。
    SRX210:192.168.100.1/24
    Cat3750:192.168.100.2/24

SRX210の設定

【Step1:AE(Aggregated Ethernet)インタフェースの作成】

SRX210でリンクアグリゲーションによってリンクをまとめたAE(Aggregated Ethernet)インタフェース(ae0)を作成します。

SRX210

--------------------------------------
set chassis aggregated-devices ethernet device-count 1
--------------------------------------

【Step2:AEインタフェースにメンバーインタフェースを割り当て】

ae0でLACP activeモードを有効化します。また、レイヤ3のインタフェース(ae0.0)としてIPアドレス192.168.100.1/24を設定します。そして、ge-0/0/0とge-0/0/1をae0のメンバーインタフェースとして設定します。

SRX210

--------------------------------------
set interfaces ae0 unit 0 family inet address 192.168.100.1/24
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ge-0/0/0 gigether-options 802.3ad ae0
set interfaces ge-0/0/1 gigether-options 802.3ad ae0
commit
--------------------------------------

【Step3:AEインタフェースの確認】

ae0のメンバーインタフェースを設定したあと、再びAEインタフェースを確認します。show interfaces terse | match aeコマンドを利用します。

SRX210

--------------------------------------
[edit]
root@SRX1# run show interfaces terse | match ae
ge-0/0/0.0              up    up   aenet    --> ae0.0
ge-0/0/1.0              up    up   aenet    --> ae0.0
ae0                     up    down
ae0.0                   up    down inet     192.168.100.1/24
--------------------------------------

ge-0/0/0.0とge-0/0/1.0がae0.0のメンバーインタフェースとなっていることがわかります。しかし、ae0.0はまだdownです。これは、対向のCat3750側でリンクアグリゲーションの設定をしていないからです。

Cat3750の設定

【Step1:Port-channelインタフェースの作成】

Cat3750でインタフェースをまとめるPort-channelインタフェースを作成し、ルーテッドポートとして192.168.100.2/24のIPアドレスを設定します。

Cat3750

--------------------------------------
interface Port-channel1
no switchport
ip address 192.168.100.2 255255.255.0
--------------------------------------

【Step2:Port-channelインタフェースにメンバーインタフェースの割り当て】

Port-channelインタフェースのメンバーインタフェースとしてFa1/0/13とFa1/0/14を設定します。ルーテッドポートのPort-channelなので、Fa1/0/13とFa1/0/14でもno switchportが必要です。また、メンバーインタフェースとしての設定は、channel-groupコマンドを利用します。

Cat3750

--------------------------------------
interface FastEthernet1/0/13
no switchport
channel-group 1 mode active
!
interface FastEthernet1/0/14
no switchport
channel-group 1 mode active
--------------------------------------

【Step3:Port-channelインタフェースの確認】

show etherchennel summaryコマンドでPort-channelインタフェースを確認します。

Cat3750

--------------------------------------
Switch#show etherchannel summary
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3      S - Layer2
U - in use      f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)         LACP      Fa1/0/13(P) Fa1/0/14(P)
Switch#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
~省略~
FastEthernet1/0/13     unassigned      YES unset  up                    up
FastEthernet1/0/14     unassigned      YES unset  up                    up
~省略~
Port-channel1          192.168.100.2   YES manual up                    up
--------------------------------------

Cat3750でもリンクアグリゲーションの設定が完了したので、LACPでSRX210とCat3750間のネゴシエーションができるようになります。その結果、SRX210のae0.0がupになります。

SRX210

--------------------------------------
[edit]
root@SRX1# run show interfaces terse | match ae
ge-0/0/0.0              up    up   aenet    --> ae0.0
ge-0/0/1.0              up    up   aenet    --> ae0.0
ae0                     up    up
ae0.0                   up    up   inet     192.168.100.1/24
--------------------------------------

ここまででSRX210とCat3750の設定はすべて完了です。SRX210、Cat3750の

  • 物理的なインタフェース
  • リンクアグリゲーションのインタフェース

の関連をまとめると、次の図のようになります。

junper-cisco_lag03.png
図 インタフェースの関連(レイヤ3リンクアグリゲーション)

【Step4:通信確認】

SRX210とCat3750間で正常に通信ができることを確認します。

Cat3750

--------------------------------------
Switch#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
--------------------------------------