この部分の広告を募集しています。 詳しくはこちら

CCIE Routing & Switching Trouble Shooting 攻略 Part1 TT01 (v4向け)

(所属カテゴリー:IPルーティング | シスコ---投稿日時:2015年6月 5日)

※ ネットワーク構成は↓よりご覧ください。
http://www.n-study.com/network/2015/05/ccie_routing_switching_trouble_1.html

問題

R1とLDPネイバーを確立できません。R1とLDPネイバーを確立できるようにしてください。

トラブルの解決

R1
----
mpls ldp router-id Loopback0 force
----

R1
----
router ospf 1
 network 200.200.1.1 0.0.0.0 area 0
----

R2
----
no ip access-list extended NO_LDP
----

R3
----
interface serial1/0
 mpls ip
----

R4
----
interface serial1/0
 no shutdown
----

トラブルの症状と原因、切り分け

表 トラブルの症状と原因、切り分け(No.1)
CCIE_TS_Part1_01.png

【R1のLDPルータIDへのIP接続性がない】

LDPネイバーを確立するためには、LDPルータIDに対してIP接続性がなければいけません。R1はLoopback1の200.200.1.1をLDPルータIDとして利用しています。Loopback1のルートをOSPFでアドバタイズしていないために、R2~R4で200.200.1.1に対するIP接続性がありません。R2~R4でR1のLDPルータIDへのIP接続性を確保するためには、

  • R1のLDPルータIDをLoopback0のIPアドレスにする
  • R1のLoopback1をOSPFでアドバタイズする
のいずれかの設定を行います。

R1
----
mpls ldp router-id Loopback0 force
----

R1
----
router ospf 1
 network 200.200.1.1 0.0.0.0 area 0
----

【R2でLDPがフィルタされている】

LDPでは、LDP Helloによってネイバーを発見します。LDP Helloは送信先IPアドレス224.0.0.2でUDPポート646を利用します。R2でLDP Helloがアクセスリストでdenyされているので、R2はR1とLDPネイバーを確立できません。解決するためには、R2のアクセスリストを修正します。

R2
----
no ip access-list extended NO_LDP
----

【R3 Serial1/0でLDPが有効化されていない】

インタフェースでLDPが有効化されていなければ、ネイバーを確立することができません。R3 Serial1/0でmpls ipコマンドでLDPを有効化します。

R3
----
interface serial1/0
 mpls ip
----

【R4 Serial1/0がShutdownされている】

インタフェースがShutdownされていれば、ネイバーを確立することができません。R4 Serial1/0をno shutdownで有効化します。

R4
----
interface serial1/0
 no shutdown
----

CCIE_TS_Part1_02.png
図 トラブルの症状と原因、切り分け(No.1)

トラブル仕込み

R1
----
no mpls ldp router-id Loopback0 force
----

R2
----
interface serial1/0
 ip access-group NO_LDP in
!
ip access-list extended NO_LDP
 deny udp any any eq 646
 permit ip any any
----

R3
----
interface serial1/0
 no mpls ip
----

R4
----
interface serial1/0
 shutdown
----

Google
Web n-study.com

各コンテンツの最新記事

有料コンテンツライブラリ(ITエンジニア教育資料)

ネットワーク技術雑誌レビュー

ベンダ資格受験記

オススメ!ネットワーク技術雑誌・書籍

MindMapでおべんきょ

結果を出せるコーチング

Geneのつぶやき

The Power of Words

スポンサードリンク

スポンサードリンク