この部分の広告を募集しています。 詳しくはこちら

CCIE Routing & Switching Trouble Shooting 攻略 Part1 TT03 (v4向け)

(所属カテゴリー:IPルーティング | シスコ---投稿日時:2015年6月12日)

※ ネットワーク構成は↓よりご覧ください。
http://www.n-study.com/network/2015/05/ccie_routing_switching_trouble_1.html

問題

3.Host1とHost3の通信ができません。Host1とHost3の通信ができるようにして ください。

トラブルの解決

R4
----
interface Ethernet0/0
 ip vrf forwarding VPN
 ip address 10.4.12.4 255.255.255.0
!
router bgp 100
 address-family ipv4 vrf VPN
  redistribute ospf 25 vrf VPN match internal external 1 external 2
----

R13
----
router ospf 1
 redistribute eigrp 1 subnets
----

トラブルの症状と原因、切り分け

表 トラブルの症状と原因、切り分け(No.3)
CCIE_TS_Part1_05.png

【R4 E0/0がVRFに割り当てられていない】

PEルータは、接続するCEルータに応じてインタフェースをVRFに割り当てます。適切なVRFの割り当てが行われていなければ、PEルータとCEルータの通信ができません。PEルータであるR4はEthernet0/0を介してCEルータであるR12と接続しています。R4のEthernet0/0をVRF VPNへ割り当てる必要があります。

R4
----
interface Ethernet0/0
 ip vrf forwarding VPN
 ip address 10.4.12.4 255.255.255.0
----

【R13でEIGRPからOSPFへの再配送が行われていない】

Host3はEIGRPドメインに含まれています。そして、R4-R12-R13はOSPFドメインです。EIGRPドメインのHost3のルートを、OSPFを通じてPEルータのR4までアドバタイズするには、再配送が必要です。EIGRPとOSPFドメインの境界となるR13でEIGRPからOSPFの再配送を行います。

R13
----
router ospf 1
 redistribute eigrp 1 subnets
----

【R4でOSPF外部ルートがMP-BGPへの再配送対象になっていない】

R4でOSPFによって学習したルートをMP-BGPに再配送して、他のPEルータにアドバタイズします。VRFのOSPFではループ防止のために、デフォルトでは外部ルートをMP-BGPへ再配送しません。VRFのOSPF外部ルートをMP-BGPへ再配送するには、明示的に指定します。

R4
----
router bgp 100
 address-family ipv4 vrf VPN
  redistribute ospf 25 vrf VPN match internal external 1 external 2
----

CCIE_TS_Part1_06.png
図 トラブルの症状と原因、切り分け(No.3)

トラブル仕込み

R4
----
interface Ethernet0/0
 no ip vrf forwarding
 ip address 10.4.12.4 255.255.255.0
!
router bgp 100
 !
 address-family ipv4 vrf VPN
  no redistribute ospf 25 vrf VPN match internal external 1 external 2
  redistribute ospf 25
----

R13
----
router ospf 1
 no redistribute eigrp 1 subnets
----

Google
Web n-study.com

各コンテンツの最新記事

有料コンテンツライブラリ(ITエンジニア教育資料)

ネットワーク技術雑誌レビュー

ベンダ資格受験記

オススメ!ネットワーク技術雑誌・書籍

MindMapでおべんきょ

結果を出せるコーチング

Geneのつぶやき

The Power of Words

スポンサードリンク

スポンサードリンク