この部分の広告を募集しています。 詳しくはこちら

CCIE Routing & Switching Trouble Shooting 攻略 Part1 TT05 (v4向け)

(所属カテゴリー:IPルーティング | シスコ---投稿日時:2015年6月17日)

※ ネットワーク構成は↓よりご覧ください。
http://www.n-study.com/network/2015/05/ccie_routing_switching_trouble_1.html

問題

5.Host1とHost4の通信ができません。Host1とHost4の通信ができるようにしてください。

トラブルの解決

R6
----
interface Ethernet0/0
 ip address 10.2.6.6 255.255.255.0
!
router bgp 65006
 redistribute ospf 1
 neighbor 10.2.6.2 password cisco
----

R7
----
router ospf 1
 network 172.31.4.0 0.0.0.255 area 0
----

トラブルの症状と原因、切り分け

表 トラブルの症状と原因、切り分け(No.5)
CCIE_TS_Part1_09.png

【R6 E0/0のIPアドレスが間違っている】

R2-R6間のネットワークアドレスは10.2.6.0/24です。しかし、R6 E0/0のIPアドレスとして10.6.6.6/24が設定されています。IPアドレスが間違っていては、IP通信ができずBGPネイバーも確立できません。R6 E0/0のIPアドレスとして10.2.6.6/24を設定します。

R6
----
interface Ethernet0/0
 ip address 10.2.6.6 255.255.255.0
----

【R6でBGPネイバー認証の設定が行われていない】

R2ではR6のBGPネイバーに対してネイバー認証を行っています。R6側でBGPネイバー認証の設定が行われていないので、R2-R6間のBGPネイバーを確立することができません。R6でもBGPネイバー認証の設定を行います。

R6
----
router bgp 65006
 neighbor 10.2.6.2 password cisco
----

【R7でnetworkコマンドが抜けている】

Host4はOSPFドメインに含まれています。Host4はR7のLoopback0なので、Loopback0をOSPFでアドバタイズしなければいけません。しかし、R7でLoopback0に対するOSPF networkコマンドが抜けています。Host4のルートをアドバタイズするために、R7でnetworkコマンドを追加します。

R7
----
router ospf 1
 network 172.31.4.0 0.0.0.255 area 0
----

【R6でOSPFからBGPへの再配送が行われていない】

Host4はOSPFドメインに含まれています。また、R2-R6間はBGPによってルートを交換しています。OSPFドメインのHost4のルートをBGPでR2までアドバタイズするためにはOSPFからBGPへの再配送が必要です。R6でOSPFのルートをBGPに再配送して、BGPルートとして生成します。そのルートがR2→R5と伝わり、Host1、Host4間で通信が可能になります。

R6
----
router bgp 65006
 redistribute ospf 1
----

CCIE_TS_Part1_10.png
図 トラブルの症状と原因、切り分け(No.5)

トラブル仕込み

R6
----
interface Ethernet0/0
 ip address 10.6.6.6 255.255.255.0
!
router bgp 65006
 no redistribute ospf 1
 no neighbor 10.2.6.2 password cisco
----

R7
----
router ospf 1
 no network 172.31.4.0 0.0.0.255 area 0
----

Google
Web n-study.com

各コンテンツの最新記事

有料コンテンツライブラリ(ITエンジニア教育資料)

ネットワーク技術雑誌レビュー

ベンダ資格受験記

オススメ!ネットワーク技術雑誌・書籍

MindMapでおべんきょ

結果を出せるコーチング

Geneのつぶやき

The Power of Words

スポンサードリンク

スポンサードリンク