この部分の広告を募集しています。 詳しくはこちら

CCIE Routing & Switching Trouble Shooting 攻略 Part2 TT03 (v4向け)

(所属カテゴリー:IPルーティング | シスコ---投稿日時:2015年8月28日)

※ ネットワーク構成は↓よりご覧ください。
CCIE Routing & Switching Trouble Shooting 攻略 Part2 問題 (v4向け)

問題

3.EIGRP AS15ドメインでのルーティングが正しく行われていません。EIGRP AS15ドメインのルーティングができるようにしてください。なお、R5ではAAAのPPP認証やマルチリンクPPPの設定を削除しないでください。また、不必要なフィルタがかかっている場合は削除しても構いません。

トラブルの解決

R1
----
router eigrp 15
 no passive-interface serial2/1
----

R3
----
interface Multilink1
 ip address 15.15.15.249 255.255.255.252
!
interface serial2/0
 ppp multilink
 ppp multilink group 1
----

R5
----
aaa authentication ppp R3_PPP group tacacs+ local
----

SW4
----
interface Vlan45
 no service-policy input EIGRP
----

トラブルの症状と原因、切り分け

表 トラブルの症状と原因、切り分け(No.3)
CCIE_TS_Part2_12.png

【R3でマルチリンクPPPのメンバーインタフェースが指定されていない】

R3-R5間ではPPPリンクが1本しかありませんが、マルチリンクPPPの設定をしてフラグメントとインターリーブを行っています。R3でのマルチリンクの設定で、マルチリンクPPPのメンバーインタフェースの設定が抜けています。そのため、R3-R5間のマルチリンクPPPを確立できません。
R3 Serial2/0をマルチリンクPPPのメンバーインタフェースとして設定します。

R3
----
interface serial2/0
 ppp multilink
 ppp multilink group 1
----

【R5のPPPで利用するAAA認証メソッドの定義が間違っている】

R5ではマルチリンクPPP上でAAAを利用した認証を行っています。認証メソッドリストとして「R3_PPP」が定義されていますが、メソッドとしてTACACS+しか指定されていません。実際にはTACACSサーバが存在しないので、認証は失敗します。
R5でPPP認証をAAAで行うためには、認証メソッドリスト「R3_PPP」にlocalも追加します。

R5
----
aaa authentication ppp R3_PPP group tacacs+ local
----

【R3 Multilink1のIPアドレスが間違っている】

論理構成図よりR3 Multilink1のIPアドレスは15.15.15.249/30のはずですが、15.15.15.250/30でR5 Multilink1のIPアドレスと同じになっています。これではEIGRPネイバーを確立することはできません。R3 Multilink1のIPアドレスを15.15.15.249/30にします。

R3
----
interface Multilink1
 ip address 15.15.15.249 255.255.255.252
----

【R1でSerial2/1がPassive-interfaceになっている】

R1でEIGRPのnetworkコマンドは間違っていないのに、show ip eigrp interfaceでSerial2/1が表示されません。EIGRPの場合、Passive-interfaceの指定がされているインタフェースはshow ip eigrp interfaceでは表示されなくなります。Passive-interface上ではネイバーを確立できないので、R1 Serial2/1のPassive-interfaceを解除します。

R1
----
router eigrp 15
 no passive-interface serial2/1
----

【SW4のMQCによってEIGRPパケットがフィルタされている】

R5とSW4では、EIGRP networkコマンドも正しく設定されています。passive-interface の指定もありません。それにも関わらず、R5とSW4のネイバーを確立できません。R5のログを見ると、SW4をネイバーとして認識してしばらくするとネイバーがダウンすることを繰り返しています。R5はSW4からのEIGRP Helloパケットを正常に受信できています。ですが、SW4はR5からのEIGRP Helloパケットを受信できていないことが考えられます。つまり、SW4でEIGRPパケットのフィルタが行われている可能性が考えられます。そこで、SW4を確認するとMQCによってEIGRPパケットがドロップされています。
MQCによるEIGRPパケットのフィルタを削除すると、R5とSW4間でEIGRPネイバーを確立することができます。

SW4
----
interface Vlan45
 no service-policy input EIGRP
----

CCIE_TS_Part2_13.png
図 トラブルの症状と原因、切り分け(No.3)

トラブルの仕込み

R1
----
router eigrp 15
 passive-interface serial2/1
----

R3
----
interface Multilink1
 ip address 15.15.15.250 255.255.255.252
!
interface serial2/0
 no ppp multilink
----

R5
----
no aaa authentication ppp R3_PPP group tacacs+ local
aaa authentication ppp R3_PPP group tacacs+
----

SW4
----
class-map match-all EIGRP
 match access-group name EIGRP
!
policy-map EIGRP
 class EIGRP
   drop
!
interface Vlan45
 service-policy input EIGRP
!
ip access-list extended EIGRP
 permit eigrp any any
----

Google
Web n-study.com

各コンテンツの最新記事

有料コンテンツライブラリ(ITエンジニア教育資料)

ネットワーク技術雑誌レビュー

ベンダ資格受験記

オススメ!ネットワーク技術雑誌・書籍

MindMapでおべんきょ

結果を出せるコーチング

Geneのつぶやき

The Power of Words

スポンサードリンク

スポンサードリンク