再配送のトラブル その5

ネットワーク構成

redistribute04-01.png

図 再配送のトラブル その5 ネットワーク構成

上記のネットワーク構成でRIPドメインとOSPFドメインのR1、R2で双方向の再配送を行なっています。

設定概要

R1 初期設定抜粋

-----------------------------------------------
interface Ethernet0/0
ip address 192.168.13.1 255.255.255.0
!
interface Ethernet0/1
ip address 192.168.15.1 255.255.255.0
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
redistribute rip subnets
network 192.168.13.0 0.0.0.255 area 0
!
router rip
version 2
redistribute ospf 1 metric 10
network 192.168.15.0
no auto-summary
-----------------------------------------------

R2 初期設定抜粋

-----------------------------------------------
interface Ethernet0/0
ip address 192.168.23.2 255.255.255.0
!
interface Ethernet0/1
ip address 192.168.25.2 255.255.255.0
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
redistribute rip subnets
network 192.168.23.0 0.0.0.255 area 0
!
router rip
version 2
redistribute ospf 1 metric 10
network 192.168.25.0
no auto-summary
-----------------------------------------------

R3 初期設定抜粋

-----------------------------------------------
interface Ethernet0/0
ip address 192.168.13.3 255.255.255.0
!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
!
interface Ethernet0/2
ip address 192.168.34.3 255.255.255.0
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
-----------------------------------------------

R4 初期設定抜粋

-----------------------------------------------
interface Loopback0
ip address 10.1.1.4 255.255.255.0
!
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 0
-----------------------------------------------

R5 初期設定抜粋

-----------------------------------------------
interface Ethernet0/0
ip address 192.168.15.5 255.255.255.0
!
interface Ethernet0/1
ip address 192.168.25.5 255.255.255.0
!
interface Ethernet0/2
ip address 192.168.56.5 255.255.255.0
!
router rip
version 2
network 192.168.15.0
network 192.168.25.0
network 192.168.56.0
no auto-summary
-----------------------------------------------

R6 初期設定抜粋

-----------------------------------------------
interface Loopback0
ip address 172.16.1.6 255.255.255.0
!
interface Ethernet0/0
ip address 192.168.56.6 255.255.255.0
!
router rip
version 2
offset-list 0 out 3
network 172.16.0.0
network 192.168.56.0
no auto-summary
-----------------------------------------------

トラブルの症状

現在の設定では、インタフェースがダウンして、その後、復旧したなどのネットワーク構成の変化にともなって最適ではないルーティングになってしまうことがわかりました。
例として、R2のルーティングテーブルを確認します。現在のR2のルーティングテーブルは次のようになっています。

R2

-----------------------------------------------
R2#show ip route
~省略~
Gateway of last resort is not set
O    192.168.13.0/24 [110/20] via 192.168.23.3, 00:41:45, Ethernet0/0
O E2 192.168.15.0/24 [110/20] via 192.168.23.3, 00:41:45, Ethernet0/0
C    192.168.25.0/24 is directly connected, Ethernet0/1
172.16.0.0/24 is subnetted, 1 subnets
R       172.16.1.0 [120/5] via 192.168.25.5, 00:00:14, Ethernet0/1
R    192.168.56.0/24 [120/1] via 192.168.25.5, 00:00:14, Ethernet0/1
10.0.0.0/32 is subnetted, 1 subnets
O       10.1.1.4 [110/21] via 192.168.23.3, 00:41:45, Ethernet0/0
C    192.168.23.0/24 is directly connected, Ethernet0/0
O    192.168.34.0/24 [110/20] via 192.168.23.3, 00:41:45, Ethernet0/0
-----------------------------------------------

R2ではRIPドメインのルートである172.16.1.0/24、192.168.56.0/24はRIPルートとしてR5から学習しています。この状態からR2のE0/1をシャットダウンします。R2 E0/1 シャットダウン時のルーティングテーブルは以下のようになります。

R2(E0/1 シャットダウン時)

-----------------------------------------------
R2#show ip route
~省略~
Gateway of last resort is not set
O    192.168.13.0/24 [110/20] via 192.168.23.3, 00:42:44, Ethernet0/0
O E2 192.168.15.0/24 [110/20] via 192.168.23.3, 00:42:44, Ethernet0/0
O E2 192.168.25.0/24 [110/20] via 192.168.23.3, 00:00:07, Ethernet0/0
172.16.0.0/24 is subnetted, 1 subnets
O E2    172.16.1.0 [110/20] via 192.168.23.3, 00:00:07, Ethernet0/0
O E2 192.168.56.0/24 [110/20] via 192.168.23.3, 00:00:07, Ethernet0/0
10.0.0.0/32 is subnetted, 1 subnets
O       10.1.1.4 [110/21] via 192.168.23.3, 00:42:44, Ethernet0/0
C    192.168.23.0/24 is directly connected, Ethernet0/0
O    192.168.34.0/24 [110/20] via 192.168.23.3, 00:42:44, Ethernet0/0
-----------------------------------------------

R2 E0/1がシャットダウンされているときには、OSPFドメインを経由してRIPドメインへパケットをルーティングすることができます。ただし、その後、R2 E0/1のインタフェースがUpになってもRIPドメインあてのパケットのルーティングの経路が元に戻りません。R2 E0/1のシャットダウンを解除したあとのルーティングテーブルは、以下のようになり、シャットダウン時と同じです。

R2(E0/1 シャットダウンを解除したあと)

-----------------------------------------------
R2#show ip route
~省略~
Gateway of last resort is not set
O    192.168.13.0/24 [110/20] via 192.168.23.3, 00:42:44, Ethernet0/0
O E2 192.168.15.0/24 [110/20] via 192.168.23.3, 00:42:44, Ethernet0/0
O E2 192.168.25.0/24 [110/20] via 192.168.23.3, 00:00:07, Ethernet0/0
172.16.0.0/24 is subnetted, 1 subnets
O E2    172.16.1.0 [110/20] via 192.168.23.3, 00:00:07, Ethernet0/0
O E2 192.168.56.0/24 [110/20] via 192.168.23.3, 00:00:07, Ethernet0/0
10.0.0.0/32 is subnetted, 1 subnets
O       10.1.1.4 [110/21] via 192.168.23.3, 00:42:44, Ethernet0/0
C    192.168.23.0/24 is directly connected, Ethernet0/0
O    192.168.34.0/24 [110/20] via 192.168.23.3, 00:42:44, Ethernet0/0
-----------------------------------------------

その結果、R2からRIPドメインへのパケットの転送経路は最適ではありません。R2から172.16.1.0/24へTracerouteを実行すると、次のようになります。

R2

-----------------------------------------------
R2#traceroute 172.16.1.6
Type escape sequence to abort.
Tracing the route to 172.16.1.6
1 192.168.23.3 28 msec 24 msec 44 msec
2 192.168.13.1 8 msec 32 msec 52 msec
3 192.168.15.5 12 msec 44 msec 52 msec
4 192.168.56.6 8 msec 32 msec *
-----------------------------------------------

R2からRIPドメインのネットワークへは、通信自体はできていますが最適ではないパケットの転送経路になってしまっていることがわかります。

問題

  • なぜR2からRIPドメインのネットワークへの転送経路は最適ではなくなってしまっているのですか。
  • ネットワーク構成が変化しても、パケットの転送経路を最適にするためにはどのような設定を行えばよいですか。

解答

  • なぜR2からRIPドメインのネットワークへの転送経路は最適ではなくなってしまっているのですか。

OSPFの方がRIPよりアドミニストレイティブディスタンスのデフォルト値が小さい。そのため、R5から学習するRIPルートよりもR1でOSPFに再配送されてR2までアドバタイズされたルートのほうが優先される。

  • ネットワーク構成が変化しても、パケットの転送経路を最適にするためにはどのような設定を行えばよいですか。

R1/R2

----------------------------------------------------------------------
router rip
distance 105 0.0.0.0 255.255.255.255 1
!
access-list 1 permit 192.168.56.0
access-list 1 permit 172.16.1.0
----------------------------------------------------------------------

※R1とR2が入れ替わることがあるので、R2だけではなくR1にも設定が必要です。

ワンポイント

  • アドミニストレティブディスタンスは、異なるルーティングプロトコルのメ トリックを比較できるようにするためのパラメータ
  • アドミニストレティブディスタンスは小さいほうが優先される
  • アドミニストレティブディスタンスをルートごとに細かく変更できる

解答

R2のE0/1がシャットダウンされた、その後、元に戻すとOSPFドメインからRIPドメインへのパケットのルーティングの経路が最適ではなくなってしまいます。その理由は、アドミニストレティブディスタンスによってルーティングテーブルに載せられるルートが決まってくるからです。

話を簡単にするために、RIPドメインの172.16.1.0/24だけを考えます。R2 E0/1をシャットダウンして、その後、シャットダウンを解除すると、RIPドメインのルートをR3(OSPF)とR5(RIP)の両方から受信します。同じネットワークアドレスのルートをOSPFとRIPの両方で学習した場合は、アドミニストレイティブディスタンスによりOSPFの方が優先されます。つまり、R2ではRIPドメインのルートであるにもかかわらず最適ルートはOSPFドメインのR3経由だと認識します。

redistribute04-03.png
図 R2 E0/1のシャットダウン解除後のRIPルートの流れ

その結果、R2からRIPドメインへのパケットの転送経路は最適ではありません。R2から172.16.1.0/24へTracerouteを実行すると、次のようになります。

R2

----------------------------------------------------------------------
R2#traceroute 172.16.1.6
Type escape sequence to abort.
Tracing the route to 172.16.1.6
1 192.168.23.3 28 msec 24 msec 44 msec
2 192.168.13.1 8 msec 32 msec 52 msec
3 192.168.15.5 12 msec 44 msec 52 msec
4 192.168.56.6 8 msec 32 msec *
----------------------------------------------------------------------

R2からRIPドメインのネットワークへは、通信自体はできていますが最適ではないパケットの転送経路になってしまっていることがわかります。

※ルータの起動順序などによって、R1とR2が入れ替わることがあります。

ネットワーク構成が変化し、その後、元の状態に戻ったときも最適なルーティングになるようにします。そのためには、アドミニストレイティブディスタンスを変更し、境界ルータにおいて元々RIPドメインのルートはRIPルートとしてルーティングテーブルに登録されるようにします。

R1/R2

----------------------------------------------------------------------
router rip
distance 105 0.0.0.0 255.255.255.255 1
!
access-list 1 permit 192.168.56.0
access-list 1 permit 172.16.1.0
----------------------------------------------------------------------

※他にも何通りかの設定が考えられます。OSPFの外部ルートのアドミニストレティブディスタンスを大きくする設定でも可能です。

このように、境界ルータでアドミニストレイティブディスタンスを適切に設定することで、ネットワークが正常な状態であれば、RIPドメインのルートは必ずRIPルートとして扱われるようになります。

設定後、R2のルーティングテーブルは次のようになります。

R2

----------------------------------------------------------------------
R2#show ip route
~省略~
Gateway of last resort is not set
O    192.168.13.0/24 [110/20] via 192.168.23.3, 00:03:57, Ethernet0/0
O E2 192.168.15.0/24 [110/20] via 192.168.23.3, 00:03:57, Ethernet0/0
C    192.168.25.0/24 is directly connected, Ethernet0/1
172.16.0.0/24 is subnetted, 1 subnets
R       172.16.1.0 [105/5] via 192.168.25.5, 00:00:11, Ethernet0/1
R    192.168.56.0/24 [105/1] via 192.168.25.5, 00:00:11, Ethernet0/1
10.0.0.0/32 is subnetted, 1 subnets
O       10.1.1.4 [110/21] via 192.168.23.3, 00:03:57, Ethernet0/0
C    192.168.23.0/24 is directly connected, Ethernet0/0
O    192.168.34.0/24 [110/20] via 192.168.23.3, 00:03:57, Ethernet0/0
----------------------------------------------------------------------

RIPドメインの172.16.1.0/24と192.168.56.0/24のアドミニストレティブディスタンスが105となり、OSPFよりも小さくなっています。R2 E0/1をシャットダウンして、その後、シャットダウンを解除すると172.16.1.0/24、192.168.56.0/24はRIPルートとしてルーティングテーブルに登録されます。

Follow me!