CCIE R&S Configuration Part1 2.1 IPaddressing

2.1.IPアドレッシング

  • 論理構成図の通りに各機器のインタフェースにIPアドレスを設定してください。
  • PPPおよびフレームリレーのリンクには直接IPアドレスを設定してはいけません。

 

【設定】

R1

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.0.130 255.255.255.224
!
interface FastEthernet1/0
 ip address 192.168.254.1 255.255.255.0
---------------------------------------------------------------------------------

 

R2

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2 native
 ip address 192.168.0.65 255.255.255.224
!
interface FastEthernet0/0.26
 encapsulation dot1Q 26
 ip address 192.168.0.97 255.255.255.224
!
interface Virtual-Template1
 ip unnumbered Loopback0
---------------------------------------------------------------------------------

 

R3

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.0.33 255.255.255.224
!
interface Serial2/1
 ip unnumbered Loopback0
!
interface Virtual-Template1
 ip unnumbered Loopback0
---------------------------------------------------------------------------------

 

R4

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.128.130 255.255.255.224
!
interface FastEthernet1/0
 ip address 192.168.254.4 255.255.255.0
---------------------------------------------------------------------------------

 

R5

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.128.193 255.255.255.224
!
interface FastEthernet1/0
 ip address 192.168.128.225 255.255.255.224
!
interface Serial2/0
 ip unnumbered Loopback0
---------------------------------------------------------------------------------

 

SW1

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.6.6 255.255.255.255
!
interface FastEthernet0/9
 no switchport
 ip address 150.1.1.1 255.255.255.0
!
interface Vlan16
 ip address 192.168.0.129 255.255.255.224
!
interface Vlan26
 ip address 192.168.0.98 255.255.255.224
---------------------------------------------------------------------------------

 

SW2

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.7.7 255.255.255.255
!
interface FastEthernet0/9
 no switchport
 ip address 150.2.2.1 255.255.255.0
!
interface Vlan47
 ip address 192.168.128.129 255.255.255.224
!
interface Vlan234
 ip address 192.168.128.161 255.255.255.224
---------------------------------------------------------------------------------

 

SW3

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.8.8 255.255.255.255
!
interface Vlan34
 ip address 192.168.128.194 255.255.255.224
!
interface Vlan234
 ip address 192.168.128.162 255.255.255.224
---------------------------------------------------------------------------------

 

SW4

---------------------------------------------------------------------------------
interface Loopback0
 ip address 192.168.9.9 255.255.255.255
!
interface Vlan34
 ip address 192.168.128.195 255.255.255.224
!
interface Vlan234
 ip address 192.168.128.163 255.255.255.224
---------------------------------------------------------------------------------

 

 

【確認のポイント】

  • show ip interfaces brief
    各インタフェースに正しくIPアドレスが設定されていることを確認します。

 

【解説】

基本的なIPアドレスの設定です。以下の3点に注意が必要です。

  • R2 サブインタフェース
  • IP unnumberedの設定
  • SW1/SW2のルーテッドポート

【R2サブインタフェース】

R2では、Fa0/0をサブインタフェースに分割します。VL2がネイティブVLANとなるので、R2 F0/0.2をVL2に対応づける際に、ネイティブVLANの指定を忘れずに行います。

R2 Fa0/02.のネイティブVLAN指定

---------------------------------------------------------------------------------
interface FastEthernet0/0.2
 encapsulation dot1Q 2 native
 ip address 192.168.0.65 255.255.255.224
---------------------------------------------------------------------------------

 

【IP unnumbered】

R2-R3間のPPPoFRおよびR3-R5間のPPPリンクでは、IPアドレスを直接設定してはいけません。そのため、これらのインタフェースでは、IP unnumberedの設定を行います。

 

R2 ip unnumbered

---------------------------------------------------------------------------------
interface Virtual-Template1
 ip unnumbered Loopback0
---------------------------------------------------------------------------------

 

R3 ip unnumbered

---------------------------------------------------------------------------------
interface Serial2/1
 ip unnumbered Loopback0
!
interface Virtual-Template1
 ip unnumbered Loopback0
---------------------------------------------------------------------------------

 

R5 ip unnumbered

---------------------------------------------------------------------------------
interface Serial2/0
 ip unnumbered Loopback0
---------------------------------------------------------------------------------

 

【ルーテッドポート】

BB1/BB2と接続されるSW1/SW2のF0/9には、直接IPアドレスを設定する必要があります。そのため、SW1/SW2 F0/9はルーテッドポートとして、IPアドレスの設定を行います。

SW1 ルーテッドポート

---------------------------------------------------------------------------------
interface FastEthernet0/9
 no switchport
 ip address 150.1.1.1 255.255.255.0
---------------------------------------------------------------------------------

 

SW2 ルーテッドポート

---------------------------------------------------------------------------------
interface FastEthernet0/9
 no switchport
 ip address 150.2.2.1 255.255.255.0
---------------------------------------------------------------------------------

 

Follow me!