CCIE R&S Configuration Part1 2.2 OSPF

2.2.OSPF

  • IGP構成のようにOSPFの設定を行ってください。各機器のLoopbackインタフェースは適切なエリアに含めてください。
  • フレームリレー上ではネイバーの障害検出を4秒以内にできるようにしてください。
  • 将来的なギガビットイーサネット環境に対応できるようにしてください。
  • R2-SW1間でOSPFネイバー認証を行ってください。認証方式はパスワードを直接送信しない方式を利用します。
  • VLAN34上にSW3、SW4、R5以外のOSPFルータが追加されても、ネイバーを確立しないようにしてください。ただし、認証を利用してはいけません。
  • SW1、SW2でデフォルトルートを生成してください。
  • 不要なインタフェースにはOSPFパケットを送信しないでください。

 

【設定】

R1

---------------------------------------------------------------------------------
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 network 192.168.0.130 0.0.0.0 area 16
---------------------------------------------------------------------------------

 

R2

---------------------------------------------------------------------------------
interface FastEthernet0/0.26
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0.2
 network 192.168.0.65 0.0.0.0 area 0
 network 192.168.0.97 0.0.0.0 area 0
 network 192.168.2.2 0.0.0.0 area 0
---------------------------------------------------------------------------------

 

R3

---------------------------------------------------------------------------------
interface Virtual-Template1
 ip ospf 1 area 0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 network 192.168.0.33 0.0.0.0 area 1
 network 192.168.3.3 0.0.0.0 area 1
---------------------------------------------------------------------------------

 

R4

---------------------------------------------------------------------------------
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 network 192.168.128.130 0.0.0.0 area 1
---------------------------------------------------------------------------------

 

R5

---------------------------------------------------------------------------------
interface FastEthernet0/0
 ip access-group OSPF in
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet1/0
 network 192.168.5.5 0.0.0.0 area 1
 network 192.168.128.193 0.0.0.0 area 1
 network 192.168.128.225 0.0.0.0 area 1
!
ip access-list extended OSPF
 permit ospf host 192.168.128.194 any
 permit ospf host 192.168.128.195 any
 deny   ospf any any
 permit ip any any
---------------------------------------------------------------------------------

 

SW1

---------------------------------------------------------------------------------
interface Vlan26
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
!
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 network 192.168.0.98 0.0.0.0 area 0
 network 192.168.0.129 0.0.0.0 area 16
 network 192.168.6.6 0.0.0.0 area 0
 default-information originate always
---------------------------------------------------------------------------------

 

SW2

---------------------------------------------------------------------------------
router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 network 192.168.7.7 0.0.0.0 area 1
 network 192.168.128.129 0.0.0.0 area 1
 network 192.168.128.161 0.0.0.0 area 1
 default-information originate always
---------------------------------------------------------------------------------

 

SW3

---------------------------------------------------------------------------------
interface Vlan34
ip access-group OSPF in
!
router ospf 1
router-id 8.8.8.8
log-adjacency-changes
auto-cost reference-bandwidth 3000
network 192.168.8.8 0.0.0.0 area 1
network 192.168.128.162 0.0.0.0 area 1
network 192.168.128.194 0.0.0.0 area 1
!
ip access-list extended OSPF
permit ospf host 192.168.128.193 any
permit ospf host 192.168.128.195 any
deny   ospf any any
permit ip any any
---------------------------------------------------------------------------------

 

SW4

---------------------------------------------------------------------------------
interface Vlan34
 ip access-group OSPF in
!
router ospf 1
 router-id 9.9.9.9
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 network 192.168.9.9 0.0.0.0 area 1
 network 192.168.128.163 0.0.0.0 area 1
 network 192.168.128.195 0.0.0.0 area 1
!
ip access-list extended OSPF
 permit ospf host 192.168.128.193 any
 permit ospf host 192.168.128.194 any
 deny   ospf any any
---------------------------------------------------------------------------------

 

 

【確認のポイント】

  • show ip ospf interface
    OSPFが有効になっているインタフェースが正しいことを確認します。
  • show ip ospf neighbor
    OSPFネイバーを正常に確立できていることを確認します。
  • show ip route ospf
    OSPFで学習しているルートを確認します。

 

【解説】

基本的なOSPFの設定です。以下の点に注意が必要です。

  • ギガビットイーサネットへの対応
  • R3 Loopback0の所属エリア
  • VL34上のネイバーの限定

 

【ギガビットイーサネットへの対応】

OSPFはメトリックとしてコストを利用します。コストはインタフェースの帯域幅から次のように計算されます。

OSPFコスト=100/帯域幅 (Mbps単位)

OSPFコストでは小数点以下は考慮しないので、100Mbps以上のインタフェースのコストはすべて1となります。ギガビットイーサネットに対応するためには、次のコマンドでOSPFコストの計算式を変更します。

(config-router)#auto-cost reference-bandwidth <value>

コストの計算式を変更するのは、1台のルータだけではダメです。コスト計算の整合性がとれるように、すべてのルータでOSPFコストの計算式を変更します。

 

【R3 Loopback0の所属エリア】

R3 Loopback0の所属エリアは、あとのIP SLAの条件に関わってきます。SW2からR3 Loopback0へパケットをルーティングするとき、R3-R5間のPPPリンクを経由するようにエリア1に所属させます。

SW2とR3 Loopback0が同じエリア1に所属すれば、エリア間のルートよりも優先されます。その結果、SW2からR3 Loopback0へパケットをルーティングするときには、R3-R5間のPPPリンクを経由するようになります。

ただし、R3 Loopback0のIPアドレスはIP Unnumberedの設定でPPPoFRのVirtual Templete1とS2/1でも利用していることに注意が必要です。R3 Loopback0をエリア1に所属されると、このIPアドレスを利用しているVirtual Templete1とS2/1もエリア1に所属します。S2/1はエリア1のインタフェースとして問題ありませんが、PPPoFRのVirtual Templete1はエリア0のインタフェースです。そこで、Virtual Templete1がエリア0のインタフェースになるようにインタフェースでのOSPFの設定を行います。

 

R3 Virtual Templete1をエリア0にする

---------------------------------------------------------------------------------
interface Virtual-Template1
 ip ospf 1 area 0
---------------------------------------------------------------------------------
CCIE_CFG_Part1_10

図 R3 Loopback0の所属エリア

 

【VL34上のネイバーの限定】

OSPFでは、Helloパケットによってネイバーを自動的に検出します。そのため、たとえ不正なルータであっても、ネイバーの条件を満たしていればネイバーを確立してLSDBの同期を取ります。不正なルータとネイバーにならないようにするためには、通常、認証を行います。しかし、条件から認証を行うことができません。

そこで、不正なルータとネイバーにならないようにするために、アクセスリストによるパケットフィルタリングを行います。R5、SW3、SW4はそれぞれのIPアドレスが送信元になっているOSPFパケットのみをpermitして、それ以外のOSPFパケットをdenyします。

 

Follow me!