CCIE R&S Configuration Part1 2.3 EIGRP

2.3.EIGRP

  • R1-R4間でEIGRP AS300を構成します。R1-R4間では、MD5認証を行ってください。
  • SW2-BB2間でEIGRP AS100を構成します。SW2はEIGRP Queryを受信しないようにしてください。

 

【設定】

R1

---------------------------------------------------------------------------------
key chain cisco
 key 1
 key-string cisco
!
interface FastEthernet1/0
 ip authentication mode eigrp 300 md5
 ip authentication key-chain eigrp 300 cisco
!
router eigrp 300
 network 192.168.1.1 0.0.0.0
 network 192.168.254.0
 no auto-summary
---------------------------------------------------------------------------------

 

R4

---------------------------------------------------------------------------------
key chain cisco
 key 1
 key-string cisco
!
interface FastEthernet1/0
 ip authentication mode eigrp 300 md5
 ip authentication key-chain eigrp 300 cisco
!
router eigrp 300
 network 192.168.4.4 0.0.0.0
 network 192.168.254.0
 no auto-summary
---------------------------------------------------------------------------------

 

SW2

---------------------------------------------------------------------------------
router eigrp 100
 network 150.2.2.0 0.0.0.255
 no auto-summary
 eigrp stub summary
---------------------------------------------------------------------------------

 

【確認のポイント】

  • show ip eigrp neighbor
    EIGRPネイバーを正常に確立できていることを確認します。
  • show ip route eigrp
    EIGRPで学習しているルートを確認します。

 

【解説】

【R1-R4間】

R1-R4間のEIGRP AS300では、あとのMPLS-VPNの条件と関わってきます。MPLS-VPNのバックボーンとして、MP-BGPネイバーをそれぞれのLoopback0のIPアドレスで確立します。そのため、R1、R4のLoopback0はEIGRP AS300のルートとして扱います。また、R1-R4間ではMD5認証を行います。EIGRPネイバーの認証は、次のようにRIPの認証とよく似た設定を行います。

  1. Key Chainの作成
    (config)#key chain <name>
    (config-keychain)#key <id>
    (config-keychain-key)#key-string <password>
  2. 認証の有効化
    (config-if)#ip authentication mode eigrp <as> md5
  3. Key Chainの指定
    (config-if)#ip authentication key-chain eigrp <as> <name>

 

【SW2-BB2間】

SW2-BB2間のEIGRP AS100では、SW2がEIGRP Queryを受信しないようにEIGRPスタブの設定を行うことがポイントです。あとの条件から、SW2がBB2へ集約ルートを送信することになります。そのため、スタブのオプションとしてsummaryを指定します。

SW2がEIGRPスタブであることは、BB2でshow ip eigrp neighbor detailを見ると、確認できます。

 

BB2 show ip eigrp neighbor detail

---------------------------------------------------------------------------------
BB2#show ip eigrp neighbors detail
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   150.2.2.1               Fa0/0             13 13:46:52  140   840  0  3
Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 1
Stub Peer Advertising ( SUMMARY ) Routes
Suppressing queries
---------------------------------------------------------------------------------

 

Follow me!