CCIE R&S Configuration Part1 2.4 再配送

2.4.再配送

  • SW2でOSPFとEIGRP間の再配送を行ってください。
  • EIGRPからOSPFへ再配送するときには、Tag200が付加されているルートのみとします。また、再配送したルートを集約してOSPFドメインへアドバタイズしてください。集約ルートにもtag200を付加します。
  • OSPFからEIGRPへ再配送するときには、「168」ではじまるルートのみとします。また、再配送したルートを集約してEIGRP AS100ドメインへアドバタイズしてください。

 

【設定】

SW2

---------------------------------------------------------------------------------
interface FastEthernet0/9
 ip summary-address eigrp 100 192.168.0.0 255.255.0.0 5
!
router eigrp 100
 redistribute ospf 1 metric 100000 10 255 1 1500
 distribute-list prefix 192.168 out ospf 1
!
router ospf 1
 summary-address 198.1.0.0 255.255.0.0 tag 200
 redistribute eigrp 100 subnets route-map TAG200
!
ip prefix-list 192.168 seq 5 permit 192.168.0.0/16 ge 24
!
route-map TAG200 permit 10
 match tag 200
---------------------------------------------------------------------------------

【確認のポイント】

  • show ip ospf database external
    OSPFのLSDBにタイプ5のLSAとして、1.0.0/16が存在していることを確認します。
  • show ip eigrp topology
    BB2でEIGRPのルートとして168.0.0/16を受信していることを確認します。

 

【解説】

【OSPFからEIGRPへの再配送】

OSPFからEIGRPへの再配送は、「192.168」ではじまるルートのみにするために、プレフィクスリストで次のようにフィルタしています。

 

SW2 OSPFからEIGRPへの再配送時のフィルタ

---------------------------------------------------------------------------------
router eigrp 100
 redistribute ospf 1 metric 100000 10 255 1 1500
 distribute-list prefix 192.168 out ospf 1
!
ip prefix-list 192.168 seq 5 permit 192.168.0.0/16 ge 24
---------------------------------------------------------------------------------

 

  • プレフィクスリスト以外でもディストリビュートリストやルートマップのフィルタでも問題ありません。

 

そして、次の設定でOSPFから再配送したEIGRPのルートをBB2へ送信するときに集約しています。

SW2 BB2へ送信する集約ルートの設定

---------------------------------------------------------------------------------
interface FastEthernet0/9
 ip summary-address eigrp 100 192.168.0.0 255.255.0.0 5
---------------------------------------------------------------------------------

その結果、BB2のEIGRPのトポロジテーブルは次のようになります。

BB2 show ip eigrp topology

---------------------------------------------------------------------------------
BB2#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(197.68.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
 
P 192.168.0.0/16, 0 successors, FD is Inaccessible
via 150.2.2.1 (30720/28160), FastEthernet0/0
P 150.2.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 198.1.5.0/24, 1 successors, FD is 256
via Rstatic (256/0)
P 198.1.4.0/24, 1 successors, FD is 256
via Rstatic (256/0)
P 198.1.3.0/24, 1 successors, FD is 256, tag is 200
via Rstatic (256/0)
P 198.1.2.0/24, 1 successors, FD is 256, tag is 200
via Rstatic (256/0)
P 198.1.1.0/24, 1 successors, FD is 256, tag is 200
via Rstatic (256/0)
---------------------------------------------------------------------------------

 

CCIE_CFG_Part1_11

OSPFからEIGRPへの再配送

 

【EIGRPからOSPFへの再配送】

BB2からSW2へ送信されるルートのうち、198.1.1.0/24、198.1.2.0/24、198.1.3.0/24にタグ200が付加されています。

SW2 タグ200が付加されているEIGRPルートの確認

---------------------------------------------------------------------------------
SW2#show ip eigrp topology | include tag is 200
P 198.1.3.0/24, 1 successors, FD is 28160, tag is 200
P 198.1.2.0/24, 1 successors, FD is 28160, tag is 200
P 198.1.1.0/24, 1 successors, FD is 28160, tag is 200
---------------------------------------------------------------------------------

OSPFへ再配送する際にはルートマップを利用して、上記のタグ200が付加されているルートのみを再配送します。そして、OSPFドメインには集約してアドバタイズできるようにします。集約ルートにもタグ200が付加されるように設定しています。

SW2 EIGRPからOSPFへの再配送の設定

---------------------------------------------------------------------------------
router ospf 1
 summary-address 198.1.0.0 255.255.0.0 tag 200
 redistribute eigrp 100 subnets route-map TAG200
!
route-map TAG200 permit 10
 match tag 200
---------------------------------------------------------------------------------

SW2のOSPF LSDBを見ると、EIGRP AS100ドメインのルートを集約したLSAタイプ5が存在していることがわかります。

SW2 show ip ospf database external

---------------------------------------------------------------------------------
SW2#show ip ospf database external 198.1.0.0
 
OSPF Router with ID (7.7.7.7) (Process ID 1)
 
Type-5 AS External Link States
 
LS age: 230
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 198.1.0.0 (External Network Number )
Advertising Router: 7.7.7.7
LS Seq Number: 8000001B
Checksum: 0xDAFE
Length: 36
Network Mask: /16
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 0.0.0.0
External Route Tag: 200
---------------------------------------------------------------------------------
CCIE_CFG_Part1_12

EIGRPからOSPFへの再配送

 

Follow me!