CCNP BSCI 旧バージョン(640-901J)の模擬問題 No.76~No.80

Table of Contents

問題

No.76

BGPで利用するメッセージについて当てはまるものをすべて選択してください。

1)OPEN
2)HELLO
3)KEEP ALIVE
4)UPDATE
5)NOTIFICATION
6)ACK
7)QUERY
8)BPDU


No.77

図のルータAがIBGPピアのルータBへアドバタイズするルートのNEXT_HOPアトリビュートは次のうちのどれですか。ただし、ルータAの設定は以下の通りとします。

「ルータAの設定」

interface serial 0/0
ip address 100.100.1.1 255.255.255.0
interface serial 0/1
ip address 192.168.1.1 255.255.255.0
interface loopback 0
ip address 1.1.1.1 255.255.255.255
router bgp 100
neighbor 100.100.1.2 remote-as 10
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source loopback 0
neighbor 2.2.2.2 next-hop-self

1)1.1.1.1
2)100.100.1.1
3)100.100.1.2
4)192.168.1.1


No.78

図のルータAがIBGPピアのルータBへアドバタイズするルートのNEXT_HOPアトリビュートは次のうちのどれですか。ただし、ルータAの設定は以下の通りとします。

「ルータAの設定」

interface serial 0/0
ip address 100.100.1.1 255.255.255.0
interface serial 0/1
ip address 192.168.1.1 255.255.255.0
interface loopback 0
ip address 1.1.1.1 255.255.255.255
router bgp 100
neighbor 100.100.1.2 remote-as 10
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source loopback 0

1)1.1.1.1
2)100.100.1.1
3)100.100.1.2
4)192.168.1.1


No.79

同じASのBGPスピーカとIBGPピアを設定したいと思っています。物理的なリンクのUp/Downによってピアがダウンしないようにするためには、どのようにすればよいですか。最も適切なものをひとつ選択してください。

1)お互いのループバックアドレスを利用してピアを設定する
2)お互いのルータのメモリをたくさん積む
3)お互いのルータのIOSを最新にアップデートする
4)IDS(Intrusion Detection System)により、侵入検知を行う


No.80

フルメッシュIBGPによるスケーラビリティの問題を解決するための方法として正しいものを選択してください。

1)ルートリフレクタの導入
2)境界ルータでのみBGPを動作させる
3)ルータのメモリのアップグレード
4)ルータのCPUのアップグレード


解答と解説


No.76

【解答】1、3、4、5

【解説】
BGPスピーカがやり取りするメッセージは次の4つです。

『OPEN』
TCPコネクションを確立して、BGPピアのセッションを開始するために最初にやり取りされるメッセージです。OPENメッセージには、バージョン番号、AS番号、BGPルータの識別子などの情報が含まれています。
OPENメッセージを受け取ったBGPピアは、メッセージの内容が正しければ確認応答として、KEEPALIVEメッセージを返します。

『KEEPALIVE』
BGPピアが正常であるかどうかを確認するために、KEEPALIVEメッセージを利用します。BGPピアから定期的にKEEPALIVEメッセージを受け取ることができれば、BGPピアが正常に維持できるということになります。もしも、ホールドダウン時間内にBGPピアからKEEPALIVEを受け取ることができなければ、BGPピアはダウンしたとみなします。

『NOTIFICATION』
NOTIFICATIONメッセージは、BGPピアの間で何らかのエラーが発生したときに、そのエラーを通知するために使われます。NOTIFICATIONメッセージを受け取ると、直ちにBGPピアが切断されます。
NOTIFICATIONメッセージを調べることによって、BGPピア間のトラブルの原因を切り分けることができるようになります。

『UPDATE』
BGPピアが確立するとUPDATEメッセージによってルーティング情報が交換されます。


No.77

【解答】1

【解説】
BGPでは、UPDATEメッセージの中にルートの情報とそれに付随するアトリビュートを入れて、ピアにアドバタイズしています。
アトリビュートの中のNEXT_HOPアトリビュートは、AS単位で考えるのでIBGPピアに送信するときには、変更されません。
しかし、この場合設定に

neighbor 2.2.2.2 next-hop-self

が入っているので、図のルータAからルータBへとアドバタイズするルートのNEXT_HOPアトリビュートはルータAのアドレスとなります。
ルータAは、BGPの送信元アドレスとして、次の設定により

neighbor 2.2.2.2 update-source loopback 0

loopback 0 のアドレスを利用しているので、NEXT_HOPアトリビュートは、ルータAのloopback 0 のIPアドレスである1.1.1.1に変更されて、ルータBにアドバタイズします。


No.78

【解答】3

【解説】
No.77ととてもよく似ていますが、ルータAのBGPの設定の中に、

neighbor 2.2.2.2 next-hop-self

がありません。
ですから、ルータAからIBGPピアのルータBにアドバタイズするときにはNEXT_HOPアトリビュートは変化せずに、ルータCの物理インタフェースのアドレス100.100.100.2となります。


No.79

【解答】1

【解説】
AS内でBGPピアの信頼性を高めたいというときの鉄則です。

信頼性を高めるために、次の条件が必要です。

?AS内のネットワークを冗長構成にする
?AS内でIGPを用いて、障害発生時にも経路を切り替えることができるようにする。このときコンバージェンスが早いルーティングプロトコルを選択することが重要
?BGPピアをループバックインタフェースで構成する

ループバックインタフェースは、ルータの物理インタフェースの状態に関係なく常にUpしているインタフェースです。
BGPピアをループバックインタフェースで構成すると、ループバックインタフェースに対するIP接続性がある限り、ピアは維持されるので信頼性が高まります。そのためには、障害発生時にもループバックインタフェースへの接続性を確保するための冗長構成のネットワークが必要で、コンバージェンスが早いに越したことがないことは言うまでもありませんね。

メモリやCPUをアップグレードするのは、信頼性が高いこととは直接関係しません。


No.80

【解答】1

【解説】
AS内できちんとBGPのルート情報を行き渡らせるためには、IBGPのフルメッシュが必要です。
ですが、AS内のBGPスピーカの数が増えてくるとIBGPピアの数が膨大になってしまうためスケーラビリティ(拡張性)に乏しくなってしまいます。

このBGPスケーラビリティの問題を解決するために、「ルートリフレクタ」や「コンフェデレーション」があります。コンフェデレーションは技術的に古いので、今では一般的にルートリフレクタを利用します。

また、MPLSを使うことによってもIBGPフルメッシュの問題を解決できないことはないのですが、他にいろいろと条件が必要になってくるので、ルートリフレクタの利用がいいでしょう。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA