CCNP BSCI 旧バージョン(640-901J)の模擬問題 No.91~No.95

Table of Contents

問題

No.91

以下の条件に基づいて、図のルータAの設定をしてください。

・S0/0(DTE)はPPPリンクで、IPアドレス192.168.1.1/30
・E0/0は、IPアドレスは、192.168.2.1/27
・ルータAでは、RIPを利用する。E0/0はRIPv1、S0/0はRIPv2
・自動集約は行わない


No.92

以下の図のルータAで、Ethernet0/0でのみIGRPでルートをアドバタイズするように設定してください。


No.93

Ethernet0/0の向こうにいるルータから、RIPで192.168.Z.0のルートを受け取っています。(Zは1~9)このルートの中から偶数のルートのみを受け取るように設定してください。


No.94

図のルータAですべてのインタフェースをOSPFエリア0に設定してください。ただし、ワイルドカードマスクはサブネットマスクを反映した設定を行ってください。


No.95

R1、R2、R3でAS100を構成しています。R1で、BGPのピアノ設定を行ってください。ピアのアドレスは、アクティブなルートが存在する限りピアが維持されるようにループバックインタフェースのアドレスを利用してください。

解答と解説

No.91

【解答】

interface serial 0/0
encapsulation ppp
ip address 192.168.1.1 255.255.255.252
ip rip send version 2
ip rip receieve version 2
interface ethernet 0/0
ip address 192.168.2.1 255.255.255.224
ip rip send version 1
ip rip receieve version 1
router rip
version 2
network 192.168.1.0
network 192.168.2.0
no auto-summary

【解説】
まず、S0/0とE0/0に普通にIPアドレスを設定しましょう。インタフェースの下で入れている「ip rip ・・・」というコマンドは、そのインタフェースで送受信するRIPパケットのバージョンを指定するためのものです。条件からS0/0はRIPv2をE0/0はRIPv1のパケットをやり取りするように設定しています。

「router rip」コマンドによりRIPのプロセスを動かすことができます。RIPのプロセスの中で、「network」コマンドにより、RIPを有効にするインタフェースを指定します。
ただし、このインタフェースの指定は、RIPはもともとクラスフルルーティングプロトコルであるため、クラスフルなメジャーネットで指定します。192.168.1.0のサブネットすべてでRIPが有効になります。つまり、S0/0(192.168.1.0/30)とE0/0(192.168.2.0/27)のインタフェースでRIPが有効になるわけです。

また、RIPはメジャーネット境界でデフォルトで自動集約が有効になっているので、自動集約を無効にするために「no auto-summary」が必要です。


No.92

【解答】

router igrp 100
network 150.100.0.0
passive-interface serial 0/0

【解説】
IGPRを有効にするには、「router igrp 」コマンドを使います。AS番号は、BGPで使うものとは意味が違います。適当な値でいいです。ただし、IGRPでルーティング情報を交換したいルータ同士で同じAS番号を使うようにしてください。

IGRPのルーティングプロセスの中で、有効にするインタフェースを指定します。これには、「netowrk」コマンドを使いますが、RIPと同じくIGRPはクラスフルルーティングプロトコルなので、メジャーネット単位でしか指定できません。そのため、Ethenet0/0でIGRPでルートをアドバタイズ、すなわち有効にするために、「network 150.100.0.0」と設定します。

でも、これだとSerial0/0でもIGRPが有効になってしまい、90秒に1回、Serial0/0からルーティングテーブルをブロードキャストしてしまいます。これを防ぐために、「passive-interface」コマンドを設定すればいいです。passive-interfaceに指定したインタフェースからは、ルーティングアップデートを送信しなくなります。


No.93

【解答】

router rip
distribute-list 1 in ethernet 0/0
access-list 1 permit 192.168.0.0 0.0.254.255

【解説】
ルーティングアップデートから特定のルートだけを受け入れたり、送信したりする、いわゆるルートフィルタリングについての問題ですね。ルートフィルタリングは、通常、「distribute-list」によって行います。

distribute-listの後の数字は、アクセスリスト番号で、受け入れたり、拒否するルートを指定するために使います。

distribute-listの適用は「in」「out」の2種類あります。「in」は、ルーティングプロセスからルーティングテーブルに載せるときにフィルタします。「out」は、ルーティングプロセスがインタフェースからルーティングアップデートを送信するときにフィルタします。

今回は、Ethernet0/0から受け取ったルートをフィルタするので、「in」でかけています。

問題は、ルートの3バイト目が偶数のルートをどのように指定するかが難しいところですね。
ここでアクセスリストで使うワイルドカードビットを思い出しましょう。ビット「0」がcareビットで一致している必要があります。ビット「1」は、Don’t careビットは一致する必要がないビットです。

1~9の中の偶数である2、4、6、8を全部2進数に変換してみます。

2   0000 0010
4   0000 0100
6   0000 0110
8   0000 1000

すると最後のビットがすべて「0」であることがわかります。これをうまくワイルドカードビットを決めてあげればいいですね。

access-list 1 permit 192.168.0.0 0.0.254.255

のアクセスリストで、192.168.Z.0のうちZが偶数のルートを指定することができます。
同じように考えれば、

access-list 1 permit 192.168.1.0 0.0.254.255

とすれば、192.168.Z.0のうちZが奇数のルートを指定することができます。


No.94

【解答】

router ospf 100
network 150.100.2.0 0.0.0.3
network 150.100.1.0 0.0.0.15

【解説】
OSPFは「router ospf <プロセス番号>」というコマンドによって有効になります。プロセス番号は、ルータ単位で勝手に指定してあげればいいです。
そのあとで、他のルーティングプロトコルと同様に「network」コマンドで有効にするインタフェースを指定します。
OSPF、あとはEIGRPもそうですが、「network」コマンドはワイルドカードビットを使って、サブネットの指定もすることができます。
図のルータのインタフェースは、S0/0が/30というサブネットマスクなので、このサブネットマスクに対応するワイルドカードビットは、「0.0.0.3」です。
E0/0の/28というサブネットマスクに対応するワイルドカードビットは、「0.0.0.15」となります。


No.95

【解答】

router bgp 100
neighbor 135.1.2.2 remote-as 100
neighbor 135.1.2.2 update-source loopback0
neighbor 135.1.3.3 remote-as 100
neighbor 135.1.3.3 update-source loopback0

【解説】
BGPは、「router bgp 」で有効になります。このAS番号は、IANAなどに割り当てられるグローバルなAS番号かもしくはプライベートAS番号を設定します。

BGPはまずピアの設定をしなければ始まりません。ピアを設定するためには、「neighbor x.x.x.x remote-as」コマンドを使います。相手のASが同じであればIBGPピア、相手のASが異なればEBGPピアとなります。

ピアを確立するときのアドレスは、何もしなければ、出力するインタフェースのアドレスを使いますが、「neighbor x.x.x.x update-source」コマンドで、特定のインタフェースのアドレスを使って、ピアを確立することができます。

ループバックインタフェースは、ダウンしない論理的なインタフェースです。ですから、ループバックインタフェースでピアを確立すると、ループバックインタフェースに到達できる限り、ピアを維持することができます。信頼性を高めるために、ループバックインタフェースでピアを確立することは非常によく行われる方法です。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA