GLBP その4

ネットワーク構成

glbp09.png
図 GLBP ネットワーク構成

設定条件

  • GLBPによってR1/R2でデフォルトゲートウェイの負荷分散を行います。デフォルトゲートウェイの負荷分散はラウンドロビンとします。
  • HOST1/HOST2のデフォルトゲートウェイのIPアドレスとして192.168.12.254を設定します。
  • R1をAVGとして動作させます。
  • ルータの障害は3秒以内に検出できるようにしてください。

初期設定

  • IPアドレス
  • ルーティングプロトコル
    OSPF エリア0

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.123.1 255.255.255.0
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.123.2 255.255.255.0
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
ip address 10.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 192.168.123.3 255.255.255.0
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 10.3.3.3 0.0.0.0 area 0
network 192.168.0.0 0.0.255.255 area 0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

HOST1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface FastEthernet0/0
ip address 192.168.12.101 255.255.255.0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

HOST2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface FastEthernet0/0
ip address 192.168.12.102 255.255.255.0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

GNS3プロジェクトダウンロード

設定

【Step1:GLBPの有効化】

R1とR2のFa0/0でGLBPを有効化します。GLBPグループ番号を12、仮想ルータのIPアドレスを192.168.12.254とします。R1とR2でグループ番号と仮想ルータのIPアドレスとして同じ値を設定しなければいけないことに注意してください。また、R1をAVGとするためにプライオリティを120とします。負荷分散方式はデフォルトでラウンドロビンなので、特に設定は不要です。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface FastEthernet0/0
glbp 12 ip 192.168.12.254
glbp 12 priority 120
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface FastEthernet0/0
glbp 12 ip 192.168.12.254
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

【Step2:GLBPタイマの設定】

ルータの障害を3秒以内に検出するためには、ホールドタイマを3秒にします。それに合わせてHelloタイマを1秒に変更します。

R1/R2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface FastEthernet0/0
glbp 12 timers 1 3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

【Step3:GLBPの確認】

show glbpコマンドでGLBPの状態を確認します。R1では、次のような表示です。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show glbp
FastEthernet0/0 - Group 12
State is Active
2 state changes, last state change 00:03:42
Virtual IP address is 192.168.12.254
Hello time 1 sec, hold time 3 sec
Next hello sent in 0.212 secs
Redirect time 600 sec, forwarder time-out 14400 sec
Preemption disabled
Active is local
Standby is 192.168.12.2, priority 100 (expires in 2.488 sec)
Priority 120 (configured)
Weighting 100 (default 100), thresholds: lower 1, upper 100
Load balancing: round-robin
Group members:
cc00.8290.0000 (192.168.12.1) local
cc01.8290.0000 (192.168.12.2)
There are 2 forwarders (1 active)
Forwarder 1
State is Active
1 state change, last state change 00:03:32
MAC address is 0007.b400.0c01 (default)
Owner ID is cc00.8290.0000
Redirection enabled
Preemption enabled, min delay 30 sec
Active is local, weighting 100
Forwarder 2
State is Listen
MAC address is 0007.b400.0c02 (learnt)
Owner ID is cc01.8290.0000
Redirection enabled, 599.088 sec remaining (maximum 600 sec)
Time to live: 14399.088 sec (maximum 14400 sec)
Preemption enabled, min delay 30 sec
Active is 192.168.12.2 (primary), weighting 100 (expires in 2.088 sec)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R1はAVGとして動作していることがわかります。仮想ルータのIPアドレスは192.168.12.254でAVF1とAVF2がこのIPアドレスを共有します。AVF1はR1で仮想MACアドレスは「0007.b400.0c01」です。AVF2はR2(192.168.12.2)で仮想MACアドレスは「0007.b400.0c02」です。
ここまでのGLBPの状態をまとめたものが次の図です。

glbp10.png
図 GLBPの状態

【Step4:ホストのデフォルトゲートウェイ設定】

HOST1/HOST2にデフォルトゲートウェイのIPアドレスとしてGLBP仮想ルータのIPアドレス192.168.12.254を設定します。

HOST1/HOST2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
ip default-gateway 192.168.12.254
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

【Step5:通信経路の確認】

HOST1/HOST2から10.3.3.3へトレースルートを実行して、経由するルータを確認します。

HOST1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
HOST1#traceroute 10.3.3.3
Type escape sequence to abort.
Tracing the route to 10.3.3.3
1 192.168.12.1 24 msec 8 msec 16 msec
2 192.168.123.3 20 msec *  40 msec
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

HOST2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
HOST2#traceroute 10.3.3.3
Type escape sequence to abort.
Tracing the route to 10.3.3.3
1 192.168.12.2 24 msec 20 msec 12 msec
2 192.168.123.3 4 msec *  28 msec
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

トレースルートの結果から、HOST1から10.3.3.3への通信はR1を経由し、HOST2から10.3.3.3への通信はR2を経由しています。
また、HOST1/HOST2の192.168.12.254に対するARPキャッシュを確認するとAVF1とAVF2の仮想MACアドレスをキャッシュしていることがわかります。

HOST1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
HOST1#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.12.101          -   cc03.7f64.0000  ARPA   FastEthernet0/0
Internet  192.168.12.102          2   cc06.6aec.0000  ARPA   FastEthernet0/0
Internet  192.168.12.254          7   0007.b400.0c01  ARPA   FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

HOST2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
HOST2#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.12.102          -   cc06.6aec.0000  ARPA   FastEthernet0/0
Internet  192.168.12.254          2   0007.b400.0c02  ARPA   FastEthernet0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

HOST1/HOST2から他のネットワーク宛ての通信経路をまとめたものが次の図です。

glbp11.png
図 HOSTから他のネットワーク宛ての通信経路

【Step6:デフォルトゲートウェイの切り替えの確認】

HOST2から他のネットワーク宛ての通信はR2を経由します。そこで、HOST2から継続的に10.3.3.3にPingを実行しながら、R2を再起動します。

HOST2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
HOST2#ping 10.3.3.3 repeat 500
Type escape sequence to abort.
Sending 500, 100-byte ICMP Echos to 10.3.3.3, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!..!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
.....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!
Success rate is 98 percent (493/500), round-trip min/avg/max = 12/19/48 ms
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2を再起動すると、HOST2から10.3.3.3へのPingの応答は2回分返ってきませんが、すぐに応答が返ってくるようになります。これは、R1(AVF1)がR2(AVF2)の仮想MACアドレス0007.b400.0c02を引き継いだからです。

glbp12.png
図 AVFの切り替え(R2再起動中)

R2の再起動が完了すると、HOST2から10.3.3.3へのPingの応答が再び返ってこなくなるところがあります。これは、R2が再びAVF2として動作しようとしている間です。R2の再起動が完了すると、HOST2から10.3.3.3へのPingは再びR2を経由します。

glbp13.png
図 AVFの切り替え(R2再起動完了後)

GNS3プロジェクトダウンロード