概要

パッシブインタフェースおよびネイバー認証について、設定ミスの切り分けと修正を行います。

ネットワーク構成

下記のネットワーク構成でRIPv2を利用したダイナミックルーティングを行います。

図 RIP 設定ミスの切り分けと修正 Part4 ネットワーク構成
図 RIP 設定ミスの切り分けと修正 Part4 ネットワーク構成

設定概要

各ルータのRIPに関連する設定概要は次の通りです。これらの設定には、一部設定ミスがあります。

R1

key chain cisco
 key 1
   key-string cisco
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip rip advertise 2
 ip rip authentication mode md5
 ip rip authentication key-chain cisco
!
interface FastEthernet1/0
 ip address 192.168.13.1 255.255.255.0
 ip rip advertise 2
!
router rip
 version 2
 passive-interface FastEthernet1/0
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary

R2

key chain cisco
 key 2
   key-string cisco
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain cisco
!
interface FastEthernet1/0
 ip address 10.2.2.2 255.255.255.0
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.12.0
 no auto-summary

R3

interface FastEthernet0/0
 ip address 192.168.13.3 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.3.3.3 255.255.255.0
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.13.0
 no auto-summary

トラブルの症状

各ルータのルーティングテーブルをみると、すべてのルートが正常に登録されておらず不完全です。

R1 show ip route

R1#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
R       10.3.3.0 [120/1] via 192.168.13.3, 00:00:00, FastEthernet1/0

R2 show ip route

R2#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
R    192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:00, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/2] via 192.168.12.1, 00:00:00, FastEthernet0/0
C       10.2.2.0 is directly connected, FastEthernet1/0

R3 show ip route

R3#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0

このトラブルの原因を調べるために、各ルータでshowコマンドを実行しました。

R1 showコマンド

R1#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 0 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2                    cisco
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.12.0
    192.168.13.0
  Passive Interface(s):
    FastEthernet1/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.12.2         120      00:24:43
    192.168.13.3         120      00:00:09
  Distance: (default is 120)
 
R1#show key chain
Key-chain cisco:
    key 1 -- text "cisco"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]

R2 showコマンド

R2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 26 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2                    cisco
    FastEthernet1/0       2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.12.1         120      00:00:01
  Distance: (default is 120)
 
R2#show key chain
Key-chain cisco:
    key 2 -- text "cisco"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]

R3 showコマンド

R3#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 1 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    FastEthernet1/0       2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.13.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.13.1         120      00:26:13
  Distance: (default is 120)
 

問題

  • なぜすべてのルータのルーティングテーブルに正しくルート情報が登録されていないのですか?
  • すべてのルータのルーティングテーブルに正しくルート情報を登録するためには、どのように設定を修正すればよいですか?なお、設定を修正するルータはできる限り少なくするものとします。

解答

なぜすべてのルータのルーティングテーブルに正しくルート情報が登録されていないのですか?

【R1-R3間】

R1 F1/0がパッシブインタフェースになっているため、R1からR3へRIPルート情報が送信されていないから

【R1-R2間】

認証のキーIDが不一致なので、認証に失敗しているため

すべてのルータのルーティングテーブルに正しくルート情報を登録するためには、どのように設定を修正すればよいですか?なお、設定を修正するルータはできる限り少なくするものとします。

R1

router rip
 no passive-interface FastEthernet1/0
!
key chain cisco
 no key 1
key chain cisco
 key 2
  key-string cisco

ワンポイント

  • パッシブインタフェースからはRIPアップデートを送信しない
  • MD5認証はキーIDとパスワードが一致していなければいけない

解説

パッシブインタフェースの設定ミスと認証の設定ミスについての問題です。パッシブインタフェースの設定ミスはR1-R3間です。そして、認証の設定ミスはR1-R2間です。

【R1-R3間】

R1は、R3からRIPのルート情報を受け取っています。しかし、R3ではR1からRIPルート情報を受け取っていません。片方向でしかルートを交換できていないのは、フィルタがかかっているかパッシブインタフェースの設定が間違っていることなどが考えられます。R3の設定には、ルートフィルタの設定はないようなので、パッシブインタフェースの設定が間違っている可能性が高いです。そこで、R1のshow ip protocolsを確認すると、R1 F1/0がパッシブインタフェースになっていることがわかります。

R1 show ip protocols

R1#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 1 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2                    cisco
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.12.0
    192.168.13.0
  Passive Interface(s):
    FastEthernet1/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.13.3         120      00:00:14
  Distance: (default is 120)
 

R1 F1/0をパッシブインタフェースにしてはいけません。R1からR3にRIPルート情報を送信できるように、F1/0のパッシブインタフェースを解除します。

R1 パッシブインタフェースの解除

router rip
 no passive-interface FastEthernet1/0

R1 F1/0のパッシブインタフェースを解除すると、R3のルーティングテーブルにRIPのルートが登録されるようになります。

R3 show ip route

R3#show ip route
~省略~
 
Gateway of last resort is not set
 
R    192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:01, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0

【R1-R2間】

R1とR2の設定を確認すると、ともにRIP認証の設定がされていることがわかります。認証方式はMD5です。MD5では、キーIDとパスワードの文字列が一致している必要があります。R1とR2で設定されているMD5認証の情報(Key chain)を確認すると、キーIDが一致していません。

R1 show key chain

R1#show key chain
Key-chain cisco:
    key 1 -- text "cisco"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]

R2 show key chain

R2#show key chain
Key-chain cisco:
    key 2 -- text "cisco"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]

show key chainの出力から、R1、R2のキーIDとパスワードは次の通りです。

R1
キーID:1 パスワード:cisco

R2
キーID:2 パスワード:cisco

パスワードの文字列は一致していますが、キーIDが一致していないために認証が正常に行われていません。R1とR2でキーIDも一致するように設定を修正します。設定修正するルータの台数が少なくないようにするために、R1で設定を修正します。

R1 キーIDの修正

key chain cisco
 no key 1
key chain cisco
 key 2
  key-string cisco

キーIDをR2と合わせれば、R1-R2間でのRIPルート情報の交換が正常に行われるようになります。

以上のR1-R3間、R1-R2間の設定を修正したあとの最終的な各ルータのルーティングテーブルは次の通りです。

R1 show ip route

R1#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/1] via 192.168.13.3, 00:00:04, FastEthernet1/0
R       10.2.2.0 [120/1] via 192.168.12.2, 00:00:00, FastEthernet0/0

R2 show ip route

R2#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
R    192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:01, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/2] via 192.168.12.1, 00:00:01, FastEthernet0/0
C       10.2.2.0 is directly connected, FastEthernet1/0

R3 show ip route

R3#show ip route
~省略~
 
Gateway of last resort is not set
 
R    192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:01, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0
R       10.2.2.0 [120/2] via 192.168.13.1, 00:00:01, FastEthernet0/0

【まとめ】

R1-R2間、R1-R3間の設定ミスについてまとめたものが次の図です。

図 RIP 設定ミスの切り分けと修正 Part4 設定ミスのまとめ
図 RIP 設定ミスの切り分けと修正 Part4 設定ミスのまとめ


関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索

IPルーティングのキホン