2005年01月29日

WANあれこれ その1

どうも!会社の帰りにバナナの皮を踏みそうになったKyoです!
なんであんなところにバナナの皮なんて落ちてんだよ・・・

さて、今日はCCNA&CCDAには避けて通れない、WANの話をちょろっとします。
本当にすこしだけなので詳しくはないです(笑

WANといってもいろいろありますけど、レイヤ3はもうIPでほぼ決まりなので、WANといったらレイヤ1と2の話になります。
まずはWAN回線の種類を見ていきましょう

・専用線
いわゆるポイントツーポイントで2点間をつなぎます。日本ではDA64などが有名ですね。
値段も高いですがセキュアです。結構使われてます。

・ISDN
回線交換方式といえばコレ。2回線分使うことができます(2B+D)。一本64kですが、
束ねて使えば128kに。(バルク転送モード)
これはBRIですが、1.5MつかえるPRIというのもあります。こちらは光ファイバになってます。
従量課金なので、使った時間に応じてお金がかかります。

・DSL
上はデジタル電話回線ですが、こっちはアナログ電話回線のADSLで有名、
ほかにもIDSLやらVDSLなんかもあります。ケーブルテレビはVDSLかな?
速度は出ますが、いわゆるベストエフォート型なので、速度の保証はされません。

・フレームリレー
こいつはX.25といわれるやつのシンプル版。X25はエラー訂正機能を持たせていたのですが、こいつはもっていません。回線品質も昔よりあがったし、レイヤー3以上に訂正させればいいよねー。という発想。というわけでレイヤ2までの規格。数MBpsぐらいでます。値段もそこそこ高い。
CCNA受験者を苦しめることで有名。
今はあまり使ってないかも?

・メトロイーサ、LRE
メトロイーサっつっている以上L2もはいっちゃってるけど。スイッチに直接させるので便利。
速度も結構出ます。

・ATM
53バイトの固定長セルを使います。高い。ものによっては数Gbpsでるかも。
こっちはCCIE受験者を苦しめるためにあります。

LANではいわゆるイーサネットがレイヤ2としてはおなじみですが、WANではSDLC、HDLCなどがあります。HDLCはベンダーごとに実装が異なったりするので、標準仕様のPPPを今では多く使いますね。

さて、以上を踏まえて以下の問題を考えてみましょう

【問題】
拠点Aと拠点BをWANで結ぼうと思います。データ量はそれほど多くないですが、常にデータのやりとりをしています。万が一のために、バックアップ回線も確保しようと思います。拠点Aはシスコのルータであり、拠点Bはヤマハのルータです。

Q1 メインの回線として適切なものを選べ。
 A DA64
 B フレームリレー
 C ATM
 D ISDN-PRI

Q2 バックアップ回線として適切なものを選べ。
 A ISDN-BRI
 B フレームリレー
 C ATM
 D メトロイーサ

Q3 レイヤ2プロトコルとして適切なものを選べ。
 A PPP
 B HDLC
 C フレームリレー
 D Ethernet

さて、それでは順番に各プロトコルを見ていきましょう。


・・てカンジでいちいち全部書いていくから更新遅くなるんだよな(笑)
と、いうわけで心の師匠、Geneさんのページへリンク
(そういえば、ブログ書かせていただいてるのにお会いしたことないですね・・・
次回オフはぜひお呼びを・・げふw)

こちらを一読してみましょう!

とりあえず、PPPとフレームリレーいってみましょう♪
構成はRT03とRT04をシリアルでつないであります。
以前のCCNAラボの残りのルータの電源を落とした状態です。

RT03(config)# interface s0
RT03(config-if)# encapsulation ppp
00:06:24: %DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 10.2.2.2 (Serial0) is down: interface down
00:06:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

PPPを入れた時点でEIGRPネイバーとレイヤ2がダウンしました(爆)
つまり、対向ルータはPPPではないからつならがないよーん、ってことです。
さて、ちなみに対向のルータは何を使ってるんでしょう??正解は後ほどっ。
さて、もくもくと設定を入れていきます。

RT03(config-if)#ppp authentication chap
RT03(config-if)#username RT04 password ccie

認証はPAPではなくCHAPを使います。
usernameは相手方の名前をいれます、パスワードはお互いそろえます。
ではRT04を見てみましょう、まずはinterfaceの状態を・・・
RT04# show interface s0
Serial0 is up, line protocol is down
 Hardware is HD64570
 Internet address is 10.2.2.2/30
 MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
  reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation HDLC, loopback not set

デフォルトはHDLCだったんですねー。ではこっちにもPPPの設定をいれてみましょう。
RT04(config)#interface s0
RT04(config-if)#encap ppp
RT04(config-if)#ppp authentication chap
RT04(config-if)#username RT03 password ccna

あれれ?つながりませんねー。ではdebug ppp authenticationをみてみましょう。
00:14:15: Se0 CHAP: O CHALLENGE id 36 len 25 from "RT04"
00:14:15: Se0 CHAP: I CHALLENGE id 39 len 25 from "RT03"
00:14:15: Se0 CHAP: O RESPONSE id 39 len 25 from "RT04"
00:14:15: Se0 CHAP: I RESPONSE id 36 len 25 from "RT03"
00:14:15: Se0 CHAP: O FAILURE id 36 len 25 msg is "MD/DES compare failed"

3Wayハンドシェイクをしていますが、パスワードで失敗しているようです。よく見ると、パスワードが違ってますね。では正しく直して見ましょう。
RT04(config)#username RT03 password ccie
RT04(config)#
00:16:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
00:16:59: %DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 10.2.2.1 (Serial0) is up: new adjacency

どうやらうまくつながったようです。

ではフレームリレーいってみましょう。
フレームリレーの設定を行い場合、フレームリレースイッチが必要です。
ですが便利なことに、シスコのルータはフレームリレースイッチになれるのです!
ではこちらを参考に設定してみましょう。

FRSW(config)# frame-relay switching
FRSW(config)#int serial 0
FRSW(config-if)#encap frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 100 interface Serial1 200
FRSW(config)#int serial 1
FRSW(config-if)#encap frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 200 interface Serial0 100

こんなカンジで。
で、ルータのインターフェイスはこんな風に。
ルータA
interface Serial0
ip address 10.2.2.1 255.255.255.252
encapsulation frame-relay
no fair-queue
frame-relay interface-dlci 100
!
ルータB
interface Serial0
bandwidth 64
ip address 10.2.2.2 255.255.255.252
encapsulation frame-relay
frame-relay interface-dlci 200
!
デフォルトでinverse arpが有効になっているので、以上の設定でPingが疎通するはずです。ではinverse arpが無効になっているとどうでしょう?
その場合、IPアドレスとDLCIをマッピングさせてあげなくてはいけません。手動的に。
たとえばルータ1がルータ2とルータ3につながっている場合。(かつルータ2とルータ3が直接つながってない)
ルータ1にサブインターフェイスを設定して・・・とやっていくと結構奥が深いところにいきますな(笑
ラボ構成を考え直して次回はフレームリレー設定いろいろ編&ISDN設定編をお送りします。
ではまた!


By kyo @ 02:47 PM | CCDA / CCNA / CCNA | コメント (7) | トラックバック (2)

コメント

kyoさん、はじめまして。
CCIE取得日記、内容が充実していてとても参考になります。
私は今年になってCCNP、CCDPを取得しました。
日常業務のボリュームと相談しながらの勉強継続になりますが、まずはCCIE筆記合格を目指して頑張っています。

CCIE取得日記の更新、楽しみにしています!

By Nao | 2005年01月29日 18:57


こんにちは

CCIEこそフレームリレーって気がします。
ATMにはそんなに苦しめられないのではないでしょうか。まあ、慣れの問題かもしれませんが・・

ブログ細かいところまで書けてるところがすごいですね。見習わないとなあ。

By kazu | 2005年01月30日 06:18


kazuさんも書かれているとおり、もうレガシーサービスとなってしまったフレームリレーは、かなりのウェイトを占めます。しかも、ハブ&スポークトポロジです。
ブログでハブ&スポークトポロジについてまとめていけば、理解を深められると思います。

By Gene | 2005年01月30日 09:31


ややや、みなさんどうもです!

Naoさん
どもども、ようこそです。
今年に入ってCCNP&DP取得!?相当な瞬殺をされましたか??(笑
多分、そんなことができるならCCIE筆記はわりかしかんたんかもしれませぬ・・・。
がんばっていきましょー!

Kazuさん
情報どうもですー。
どうも、ATMって馴染みがなくてCCIEで初登場なカンジがしたもので。。よくよく考えてみるとフレーリレーって結構えぐいものなのですね。。

ブログはノート代わりに書いてます(笑)新入社員研修な季節になったらちゃんとまとめたいなぁ・・・そのころはそれどころじゃなさそうな気もしますが(笑

Gene師匠
ハブ&スポークですか~。(・ ・)Φめもめも
今BCRANの教科書(新しい試験の奴)みてますけど、
FRの設定って実務では1回(拠点)しかやったことないんで大分忘れちゃってます;


と、いうわけでシリアルインターフェイスが4つ付いてるルータ(Cisco4500??)をゲットしたのでハブアンドスポークな構成を作って次回に続きます(笑

#これ音がでかいです・・・ファンはずしちゃおうかな;

By kyo | 2005年01月31日 00:02


ちなみに、うちらがCCNAを受けているときに、みんなが苦しんだフレームリレーの問題がこれでした(笑

問題:
自分のフレームリレー網に設定されたDLCI番号を見たいとき用いるコマンドはどれが。

show frame-relay map
show frame-relay dlci
show frame-relay pvc
show frame-relay lmi

設定して終わりじゃなくて、showやdebugをたくさん打って、見て、理解することが大切ですね。
ちなみにみんな、試験前のアンケートのときにこのコマンドを配布されるボードに書いていた・・・。(笑

By kyo | 2005年01月31日 00:15


おべんきょしませんか?~から流れてきたCafe_61cと申します。元クラブDJというのに興味しんしんです。

CCIEがんばってください。

By cafe_61c | 2005年01月31日 10:18


cafe_61cさん

やや、どうもです!HP見ました凄すぎです・・・。プロフィールとか特に。。。

プライベートをあまり話すと会社の人に正体がばれちゃうので多くは語れませんが(笑)今ではシンセサイザーで曲作りとかをしていま。。。いや、CCIEまでは封印w

長い道のりですががんばっていくのでよろしくおねがいします♪

By kyo | 2005年02月01日 23:25


コメントを書く







名前、アドレスを登録しますか?




トラックバック

このエントリーのトラックバックURL:
http://www.n-study.com/mt/mt-tb.cgi/409


CCNA用のPPPの勉強にいかが? … “CCNAでは、WANプロトコルについてもけっこう幅広く出てきます。その中でPPPについては、showやdebugを見せてうんぬんって感じのなかなか難しい問題です...”
From ネットワークのおべんきょしませんか?ブログ @ 2005年01月30日 09:35


casino hotel resort trump … “”
From casino hotel resort trump @ 2006年10月22日 19:05