RIPネイバー の問題

ネットワーク構成

rip_neighbor01.png
図 RIPネイバー ネットワーク構成

設定概要

各ルータのRIPに関連する設定は次のとおりです。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
ip address 192.168.1.1 255.255.255.255
ip rip advertise 5
!
interface Serial0/0
ip address 192.168.123.1 255.255.255.0
ip rip advertise 5
ip rip authentication mode md5
ip rip authentication key-chain RIP
encapsulation frame-relay
frame-relay map ip 192.168.123.2 120
frame-relay map ip 192.168.123.3 130
no frame-relay inverse-arp
!
router rip
version 2
timers basic 5 15 15 20
network 192.168.1.0
network 192.168.123.0
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
ip address 192.168.2.2 255.255.255.255
ip rip advertise 5
!
interface Serial0/0
ip address 192.168.123.2 255.255.255.0
ip rip advertise 5
ip rip authentication mode md5
ip rip authentication key-chain RIP
encapsulation frame-relay
frame-relay map ip 192.168.123.1 210
frame-relay map ip 192.168.123.3 210
no frame-relay inverse-arp
!
router rip
version 2
timers basic 5 15 15 20
network 192.168.2.0
network 192.168.123.0
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
ip address 192.168.3.3 255.255.255.255
ip rip advertise 5
!
interface Serial0/0
ip address 192.168.123.3 255.255.255.0
ip rip advertise 5
ip rip authentication mode md5
ip rip authentication key-chain RIP
encapsulation frame-relay
frame-relay map ip 192.168.123.1 310
frame-relay map ip 192.168.123.2 310
no frame-relay inverse-arp
!
router rip
version 2
timers basic 5 15 15 20
network 192.168.3.0
network 192.168.123.0
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

GNS3プロジェクトダウンロード

~問題~
フレームリレー上にはブロードキャスト/マルチキャストパケットを転送でき
ないようにしています。フレームリレー上でRIPパケットを送受信できるよう
に設定を行ってください。

解答

R1

----------------------------------------------------
router rip
neighbor 192.168.123.2
neighbor 192.168.123.3
passive-interface Serial0/0
----------------------------------------------------

R2

----------------------------------------------------
router rip
neighbor 192.168.123.1
passive-interface Serial0/0
----------------------------------------------------

R3

----------------------------------------------------
router rip
neighbor 192.168.123.1
passive-interface Serial0/0
----------------------------------------------------

ワンポイント

  • RIPv2は224.0.0.9のマルチキャストアドレスを利用する
  • neighborコマンドによってユニキャストでRIPルートをアドバタイズする

解説

フレームリレーの設定でブロードキャスト/マルチキャストパケットが送信できないようになっているので、R1~R3でフレームリレーインタフェースでのRIPパケットの送受信ができていません。フレームリレーインタフェースでRIPパケットの送受信ができるように、R1~R3でネイバーの指定を行います。なお、ネイバーを指定してもマルチキャストのRIPパケットの送信は行なっています。
余計なマルチキャストのRIPパケットの送信を止めるためにpassive-interfaceを設定します。

R1

----------------------------------------------------
router rip
neighbor 192.168.123.2
neighbor 192.168.123.3
passive-interface Serial0/0
----------------------------------------------------

R2

----------------------------------------------------
router rip
neighbor 192.168.123.1
passive-interface Serial0/0
----------------------------------------------------

R3

----------------------------------------------------
router rip
neighbor 192.168.123.1
passive-interface Serial0/0
----------------------------------------------------

なお、ハブ&スポーク構成なのでハブであるR1ではスプリットホライズンを無効にする必要があります。RIPであれば、特別な設定をしなくても、フレームリレーのインタフェースは、スプリットホライズンが無効化されています。そのため、スポークルータであるR2とR3も正しくRIPルートを学習できます。

※EIGRPでは、明示的にハブルータのインタフェースでスプリットホライズンを無効化しなければいけません。

R1

----------------------------------------------------
R1#show ip interface serial 0/0
Serial0/0 is up, line protocol is up
Internet address is 192.168.123.1/24
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound  access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is enabled
IP Flow switching is disabled
~省略~
R1#show ip route rip
192.168.2.0/32 is subnetted, 1 subnets
R       192.168.2.2 [120/1] via 192.168.123.2, 00:00:04, Serial0/0
192.168.3.0/32 is subnetted, 1 subnets
R       192.168.3.3 [120/1] via 192.168.123.3, 00:00:03, Serial0/0
----------------------------------------------------

R2

----------------------------------------------------
R2#show ip route rip
192.168.1.0/32 is subnetted, 1 subnets
R       192.168.1.1 [120/1] via 192.168.123.1, 00:00:03, Serial0/0
192.168.3.0/32 is subnetted, 1 subnets
R       192.168.3.3 [120/2] via 192.168.123.3, 00:00:03, Serial0/0
----------------------------------------------------

R3

----------------------------------------------------
R3#show ip route rip
192.168.1.0/32 is subnetted, 1 subnets
R       192.168.1.1 [120/1] via 192.168.123.1, 00:00:01, Serial0/0
192.168.2.0/32 is subnetted, 1 subnets
R       192.168.2.2 [120/2] via 192.168.123.2, 00:00:01, Serial0/0
----------------------------------------------------

設定完了時のGNS3プロジェクトダウンロード

Follow me!