RIPタイマの設定

ネットワーク構成

rip_neighbor01.png

図 RIPネイバー ネットワーク構成

設定概要

各ルータのRIPに関連する設定は次のとおりです。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
key chain RIP
key 1
key-string cisco
!
interface Loopback0
ip address 192.168.1.1 255.255.255.255
!
interface Serial0/0
ip address 192.168.123.1 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 192.168.123.2 120
frame-relay map ip 192.168.123.3 130
no frame-relay inverse-arp
!
router rip
version 2
network 192.168.1.0
network 192.168.123.0
neighbor 192.168.123.3
neighbor 192.168.123.2
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
key chain RIP
key 1
key-string cisco
!
interface Loopback0
ip address 192.168.2.2 255.255.255.255
!
interface Serial0/0
ip address 192.168.123.2 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 192.168.123.1 210
frame-relay map ip 192.168.123.3 210
no frame-relay inverse-arp
!
router rip
version 2
network 192.168.2.0
network 192.168.123.0
neighbor 192.168.123.1
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
key chain RIP
key 1
key-string cisco
!
interface Loopback0
ip address 192.168.3.3 255.255.255.255
!
interface Serial0/0
ip address 192.168.123.3 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 192.168.123.1 310
frame-relay map ip 192.168.123.2 310
no frame-relay inverse-arp
!
router rip
version 2
network 192.168.3.0
network 192.168.123.0
neighbor 192.168.123.1
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

GNS3プロジェクトダウンロード

問題

ネットワークに障害が発生した場合、該当するルートを20秒以内にルーティングテーブルから削除できるようにしたいと考えています。どのような設定を行えばよいですか。

解答

R1/R2/R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router rip
timers basic 5 15 15 20
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

GNS3プロジェクトダウンロード

ワンポイント

  • RIPはUpdateタイマの間隔でルートを送信する
  • Invalidタイマの間、ルートを受信できなければそのルートは無効とみなしてホールドダウン状態になる
  • Hold Downタイマの間、ホールドダウン状態が続く
  • Flush afterタイマの間、ルートを受信できなければ、そのルートをルーティングテーブルから削除する
  • ルーティングプロトコルでタイマを変更するときには、関連するすべてのルータで変更する。

解説

RIPはシンプルなルーティングプロトコルです。OSPFやEIGRPのようにネイバーを確立することはありません。ルータやネットワークが正常に動作しているかどうかは、基本的に定期的なルートのアップデートによって確認します。そして、定期的なアップデートやルートが正常かどうかは、RIPタイマによって制御されています。
RIPタイマとして、以下の4つあります。

  • Update
  • Invalid
  • Hold down
  • Flush after

Updateタイマは、定期的なRIPルートのアップデートを送信する間隔です。デフォルトは30秒です。30秒ごとにRIPルートを受信できていれば、ネットワークは正常に動作していることになります。
Invalidタイマは、ルートを無効とみなすまでの時間です。定期的なRIPルートのアップデートが途絶えて、Invalidタイマがタイムアウトするとそのルートは無効とみなします。RIPでは、無効なルートはすぐに消さずにホールドダウン状態(possibly down)とします。Invalidタイマはデフォルトで180秒です。
Hold downタイマは、ホールダウン状態を維持する時間です。すぐにルートを消しません。デフォルトで180秒です。
Flush afterタイマの間、RIPルートを受信できなければ、そのルートをルーティングテーブルから削除します。デフォルトで240秒です。つまり、定期的なRIPルートのアップデートが途絶えると、Flush afterタイマがタイムアウトする240秒後にルーティングテーブルからルートが削除されることになります。

問題の条件にあるように、ネットワークに障害が発生した場合、該当するルートを20秒以内にルーティングテーブルから削除するためには、Flush afterタイマを20秒にすればよいです。Flush afterタイマだけを変更すると、タイマの整合性が取れないので、Update、Invalid、Hold downタイマも変更します。それぞれ5秒、15秒、15秒とします。

※Update、Invalid、Hold downタイマの値は適当なものです。

そして、RIPに限らず何かのタイマを変更するときには、たいていは関連する機器全部で変更する必要があるということに気をつけてください。ルーティングプロトコルなどは、ルータ単体で動作するわけではありません。他のルータと相互作用するので、1台だけタイマを変更すると、その他のルータとの整合性が取れなくなってしまうことがあるからです。つまり、R1~R3のすべてのルータでRIPタイマを変更します。

R1/R2/R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
router rip
timers basic 5 15 15 20
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

変更したRIPタイマはshow ip protocolsコマンドで確認できます。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 5 seconds, next due in 3 seconds
Invalid after 15 seconds, hold down 15, flushed after 20
Redistributing: rip
Neighbor(s):
192.168.123.2
192.168.123.3
Default version control: send version 2, receive version 2
Interface             Send  Recv  Triggered RIP  Key-chain
Serial0/0             2     2                    RIP
Loopback0             2     2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.1.0
192.168.123.0
Routing Information Sources:
Gateway         Distance      Last Update
192.168.123.3        120      00:00:00
192.168.123.2        120      00:00:01
Distance: (default is 120)
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

また、ルーティングテーブルを見ると、RIPルートの経過時間はUpdateタイマの5秒未満になっているのが正常です。RIPルートの経過時間が5秒を越えてしまっているとうことは、アップデートが途絶えていることになります。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#show ip route rip
192.168.2.0/32 is subnetted, 1 subnets
R       192.168.2.2 [120/1] via 192.168.123.2, 00:00:03, Serial0/0
192.168.3.0/32 is subnetted, 1 subnets
R       192.168.3.3 [120/1] via 192.168.123.3, 00:00:02, Serial0/0
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

Follow me!