ネットワーク構成

rip_neighbor01.png
図 RIPネイバー認証 ネットワーク構成

設定概要

各ルータのRIPに関連する設定は次のとおりです。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
ip address 192.168.1.1 255.255.255.255
!
interface Serial0/0
ip address 192.168.123.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 192.168.123.2 120 broadcast
frame-relay map ip 192.168.123.3 130 broadcast
no frame-relay inverse-arp
!
router rip
version 2
network 192.168.1.0
network 192.168.123.0
neighbor 192.168.123.3
neighbor 192.168.123.2
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
ip address 192.168.2.2 255.255.255.255
!
interface Serial0/0
ip address 192.168.123.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 192.168.123.1 210 broadcast
frame-relay map ip 192.168.123.3 210 broadcast
no frame-relay inverse-arp
!
router rip
version 2
network 192.168.2.0
network 192.168.123.0
neighbor 192.168.123.1
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
interface Loopback0
ip address 192.168.3.3 255.255.255.255
!
interface Serial0/0
ip address 192.168.123.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 192.168.123.1 310 broadcast
frame-relay map ip 192.168.123.2 310 broadcast
no frame-relay inverse-arp
!
router rip
version 2
network 192.168.3.0
network 192.168.123.0
neighbor 192.168.123.1
no auto-summary
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

GNS3プロジェクトダウンロード(MM_1227_RIP_authentication_init.zip)

問題

RIPルータ間で認証を行いたいと考えています。それぞれのルータでどのような設定を行えばよいですか。

解答

R1/R2/R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
key chain RIP
key 1
key-string cisco
!
interface Serial0/0
ip rip authentication mode md5
ip rip authentication key-chain RIP
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

GNS3プロジェクトダウンロード(MM_1227_RIP_authentication_comp.zip)

ワンポイント

  • RIPのネイバー認証はキーチェインを利用する

解説

RIPのネイバー認証は、認証パスワードとしてキーチェインを利用します。キーチェインの設定コマンドは以下の通りです。

(config)#key chain
(config-keychain)#key
(config-keychain-key)#key-string

ネイバー認証では、キーIDとパスワード文字列の両方が一致している必要があります。また、キーの有効期間を設定することも可能です。

キーチェインを設定したら、インタフェースコンフィグレーションモードでRIPネイバー認証を有効化して、利用するキーチェインを指定します。

(config-if)#ip authentication rip mode md5
(config-if)#ip authentication rip key-chain

R1/R2/R3の設定はすべて共通です。キーチェインとしてキーID:1、文字列:ciscoを指定して、他のRIPルータが存在するSerial0/0でネイバー認証の有効化とキーチェインを指定します。

R1/R2/R3

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
key chain RIP
key 1
key-string cisco
!
interface Serial0/0
ip rip authentication mode md5
ip rip authentication key-chain RIP
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

ネイバー認証を有効化するとRIPアップデートにはMD5のメッセージダイジェストが含まれるようになります。debug ip ripコマンドでRIPアップデートにMD5メッセージダイジェストが含まれていることがわかります。

R1

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar  1 00:06:30.303: RIP: received packet with MD5 authentication
*Mar  1 00:06:30.303: RIP: received v2 update from 192.168.123.2 on Serial0/0
*Mar  1 00:06:30.307:      192.168.2.2/32 via 0.0.0.0 in 1 hops
*Mar  1 00:06:30.307:      192.168.3.3/32 via 192.168.123.3 in 3 hops
*Mar  1 00:06:30.311:      192.168.123.0/24 via 0.0.0.0 in 1 hops
~省略~
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

関連記事