4.1. Auto QoS

  •  R3-R5間でVoIPパケットを絶対優先で転送してください。
  •  これを1つのインタフェースコンフィグレーションモードのコマンドで実現してください。

【設定】

R3

---------------------------------------------------------------------------------
interface Serial2/1
auto qos voip
---------------------------------------------------------------------------------

R5

---------------------------------------------------------------------------------
interface Serial2/0
auto qos voip
---------------------------------------------------------------------------------

【確認のポイント】

  • show auto qos
    Auto QoSで自動生成された設定を確認します。

【解説】

Auto QoSによって、音声パケットを絶対優先する設定を自動生成することができます。Auto QoSの設定は、インタフェースコンフィグレーションモードで次のコマンドを利用します。

(config-if)3auto qos voip

このコマンドにより、音声パケットを絶対優先する設定が自動的に生成されることになります。自動生成された設定は、show auto qosコマンドで確認することができます。R3では、show auto qosの出力は次のようになります。

R3 show auto qos

---------------------------------------------------------------------------------
R3#show auto qos
!
policy-map AutoQoS-Policy-UnTrust
class AutoQoS-VoIP-RTP-UnTrust
priority percent 70
set dscp ef
class AutoQoS-VoIP-Control-UnTrust
bandwidth percent 5
set dscp af31
class AutoQoS-VoIP-Remark
set dscp default
class class-default
fair-queue
!
class-map match-any AutoQoS-VoIP-Remark
match ip dscp ef
match ip dscp cs3
match ip dscp af31
!
class-map match-any AutoQoS-VoIP-Control-UnTrust
match access-group name AutoQoS-VoIP-Control
!
class-map match-any AutoQoS-VoIP-RTP-UnTrust
match protocol rtp audio
match access-group name AutoQoS-VoIP-RTCP
!
ip access-list extended AutoQoS-VoIP-RTCP
permit udp any any range 16384 32767
!
ip access-list extended AutoQoS-VoIP-Control
permit tcp any any eq 1720
permit tcp any any range 11000 11999
permit udp any any eq 2427
permit tcp any any eq 2428
permit tcp any any range 2000 2002
permit udp any any eq 1719
permit udp any any eq 5060
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.1081.1083 30 absolute rising-threshold 1 33333 falling-threshold 0 owner AutoQoS

Serial2/1 -
!
interface Serial2/1
service-policy output AutoQoS-Policy-UnTrust
---------------------------------------------------------------------------------