※ ネットワーク構成は↓よりご覧ください。
CCIE Routing & Switching Trouble Shooting 攻略 Part2 問題 (v4向け)

問題

5.OSPFドメインのルーティングが正しく行われていません。OSPFドメインのルーティングができるようにしてください。なお、フレームリレー上ではDR/BDRを選出できるようにしてください。

トラブルの解決

R1

----
interface FastEthernet1/0
 no ip mtu 1492
!
interface Serial2/0
 frame-relay traffic-shaping
 no frame-relay lmi-type q933a
----

R2

----
interface FastEthernet1/0.24
 encapsulation dot1Q 24
!
interface Serial2/0.1 multipoint
 ip ospf network non-broadcast
 ip ospf hello-interval 10
----

R4

----
interface Serial2/0
 no frame-relay route 200 interface Serial2/1 100
 frame-relay route 100 interface Serial2/1 200
!
interface Serial2/1
 no frame-relay route 100 interface Serial2/0 200
 frame-relay route 200 interface Serial2/0 100
----

SW2

----
router ospf 1
 area 2 nssa
----

トラブルの症状と原因、切り分け

CCIE_TS_Part2_16

表 トラブルの症状と原因、切り分け(No.5)

【R1 F1/0のMTUサイズが1492バイトに設定されている】

R1-SW1間のOSPFネイバーの状態がEXSTARTでスタックして、LSDBの同期を取ることができていません。これはDBD(Database Description)の交換が正常にできていません。OSPFではネイバーとの間でMTUサイズが不一致になっている場合、このようにEXSTART状態でスタックして、LSDBの同期を取ることができません。R1 F1/0でMTUサイズが1492バイトに変更されているので、デフォルトに戻します。

R1

----
interface FastEthernet1/0
 no ip mtu 1492
----

【R1 S2/0でLMIタイプが一致していない】

フレームリレースイッチのR4では、LMIタイプはすべてCiscoで設定されています。ですが、R1 S2/0でフレームリレーLMIタイプとして
Q933aが設定されています。LMIタイプが不一致だとフレームリレーインタフェースは正しく機能しません。R1でLMIタイプを修正します。

R1

----
interface Serial2/0
 no frame-relay lmi-type q933a
----

【フレームリレースイッチのPVC設定が間違っている】

R1/R2でshow frame-relay mapを確認すると、DLCI番号は正しいのにも関わらずPVCの状態がDeletedとなっています。このことからフ
レームリレースイッチに問題があることがわかります。R4のフレームリレーPVCの設定を確認すると、DLCI番号の設定が間違っています。
R4で正しいフレームリレーPVCの設定を行います。

R4

----
interface Serial2/0
 no frame-relay route 200 interface Serial2/1 100
 frame-relay route 100 interface Serial2/1 200
!
interface Serial2/1
 no frame-relay route 100 interface Serial2/0 200
 frame-relay route 200 interface Serial2/0 100
----

【R2 S2/0.1のOSPFネットワークタイプがPOINT_TO_POINTになっている】

R2 S2/0.1のOSPFネットワークタイプがPOINT_TO_POINTになっています。R1-R2間のフレームリレー上でDR/BDRを選出するためには、BROADCASTまたはNON_BROADCASTにする必要があります。R1と合わせて、R2 S2/0.1のOSPFネットワークタイプをNON_BROADCASTにします。

R2

----
interface Serial2/0.1 multipoint
 ip ospf network non-broadcast
----

【OSPF Hello/Deadインターバルが不一致】

R1 S2/0.1とR2 S2/0.1のHello/Deadインターバルが一致していません。そのため、OSPFネイバーを確立できません。R1 S2/0.1とR2 S2/0.1のHello/Deadインターバルが一致するように設定を修正します。

R2

----
interface Serial2/0.1 multipoint
 ip ospf hello-interval 10
----

【R1でFRTSが有効化されていない】

R1-R2間のフレームリレーネットワークでは、FRF.12によるフラグメントの設定が行われています。ところが、R1 S2/0でFRTSが有効
化されていません。そのため、R1はFRF.12のフラグメントを行いません。
OSPF Helloパケットのサイズは小さいので、フラグメントされずにR1-R2間で正常にやり取りできます。ですが、LSDBの同期を取る際
のパケットサイズは大きくなり、フラグメントの設定に不整合があると、正常にやり取りできなくなります。そのため、R1-R2間でネ
イバーの状態がEXCHANGE状態でスタックします。R1でもFRF.12のフラグメントを行うようにFRTSを有効化します。

R1

----
interface Serial2/0
 frame-relay traffic-shaping
----

【R2 F1/0.24で関連づけるVLANが間違っている】

R2 F1/0.24はVLAN24に対応付けるサブインタフェースです。ですが、VLAN24ではなくVLAN44に対応付けるように設定されています。そのため、R2-SW2間のIP通信ができなくなっています。R2 F1/0.24はVLAN24に対応付けます。

R2

----
interface FastEthernet1/0.24
 encapsulation dot1Q 24
----

【SW2でNSSAの設定が抜けている】

エリア2はNSSAです。R2側ではエリア2をNSSAとする設定が行われていますが、SW2では設定されていません。そのため、R2-SW2でOSPFネイバーを確立できません。SW2でエリア2をNSSAとして設定します。

SW2

----
router ospf 1
 area 2 nssa
----
図 トラブルの症状と原因、切り分け(No.5)

図 トラブルの症状と原因、切り分け(No.5)

トラブルの仕込み

R1

----
interface FastEthernet1/0
 ip mtu 1492
!
interface Serial2/0
 no frame-relay traffic-shaping
 frame-relay lmi-type q933a
----

R2

----
interface FastEthernet1/0.24
 encapsulation dot1Q 44
!
interface Serial2/0.1 multipoint
 ip ospf network point-to-point
 ip ospf hello-interval 15
----

R4

----
interface Serial2/0
 no frame-relay route 100 interface Serial2/1 200
 frame-relay route 200 interface Serial2/1 100
!
interface Serial2/1
 no frame-relay route 200 interface Serial2/0 100
 frame-relay route 100 interface Serial2/0 200
----

SW2

----
router ospf 1
 no area 2 nssa
----