Cisco Catalystスイッチのポートの種類

Cisco Catalystスイッチの「内部ルータ」「VLAN」「ポート」の内部レイヤ構造をどのように接続するかによって、Catalystスイッチのポートは、次の4つの種類に大別できます。

・アクセスポート
・トランクポート
・SVI(Switch Virtual Interface)
・ルーテッドポート

今回は、アクセスポート、トランクポートの考え方と設定コマンドを解説します。

アクセスポート

アクセスポートとは、

「1つのVLANに所属し、そのVLANのフレームを送受信することができるポート」

です。つまり、アクセスポートとは内部のVLANのうちの1つにだけつながっているポートということになります。そして、どのVLANにつながっているかということを「VLANメンバーシップ」と呼ぶことがあります。

VLANメンバーシップの決め方は、次の2通りあります。

・スタティック
・ダイナミック

スタティックは、ポートとVLANの接続をあらかじめ固定的に設定する方法です。一番、直感的でわかりやすいVLANメンバーシップの決め方です。ポートごとにひとつひとつコマンドを使って設定しなければいけないので、大規模な環境では、設定作業が煩雑になる可能性があります。ただ、ほとんどの場合、連続したポートは同じVLANのアクセスポートになるので、連続したポートで一括の設定を行えばそれほど煩雑な設定作業にはなりません。たぶん、このスタティックなVLANメンバーシップの設定が一番よく使われています。

一方、ダイナミックはポートに接続されるコンピュータやそのコンピュータのユーザなどのパラメータに応じて、自動的にポートとVLANの接続を行います。接続するVLANを決めるパラメータとして、「MACアドレス」や「ユーザ名/パスワード」などがあります。ダイナミックなVLANメンバーシップを行うようにすれば、ネットワーク上のどの部分にコンピュータを接続しても、いつでも同じVLAN、つまりサブネットに所属できるようになり、柔軟性が向上します。ただ、そのためのサーバなどが別途必要になります。

トランクポート

トランクポートは、

「複数のVLANに所属し、そのVLANのフレームを送受信するポート」

です。もう少し別の言い方をすると、

「1つのポートに複数のVLANのフレームを多重化する」

とも言えます。

また、よく混乱することにもなるのですが他のベンダの機器では、タギングVLANともいいます。複数のVLANとはデフォルトで、スイッチ上に存在するすべてのVLANです。トランクポートは、スイッチ内部のすべてのVLANと接続されているポートとなります。なお、設定によって、トランクポートの接続先のVLANを特定のVLANだけに制限することもできます。
トランクポートで気をつけなくてはいけないことが、1つのポートで複数のVLANのフレームが送受信されます。しかし、VLANが違えば、違うネットワークのフレームになるわけで、きちんと異なるVLAN間でフレームを分離する必要があります。そのために、トランクポートで送受信されるフレームにはVLAN識別情報
(タグ)が付加されます。このタグをつけるプロトコルをトランクプロトコルという言い方をして、次の2つあります。

・Cisco ISL
・IEEE802.1Q

いまは、ほとんどIEEE802.1Qを使います。よく「どっとわんきゅー」とか言いますね。

以上のアクセスポート、トランクポートの2つを総称して「スイッチポート」とも言います。スイッチのポートだから「スイッチポート」・・・そのまんまです。ま、この場合の「スイッチ」とはレイヤ2スイッチと考えてください。

VLANの作成とアクセスポート、トランクポートの設定

デフォルトでは、すべてのポートはデフォルトVLAN(VLAN1)のアクセスポートになっています。ここから必要に応じて、新しくVLANを作成したり、そのVLANのアクセスポートの設定をしたり、あるポートをトランクポートにしたりという流れで設定を行います。

  • VLANの作成
    (config)#vlan [vlan-number]
  • アクセスポートの設定
    (config-if)#switchport mode access
  • スタティックなVLANメンバーシップ
    (config-if)#switchport access vlan [vlan-number]
  • トランクプロトコルの設定
    (config-if)#switchport trunk encapsulation {dot1q | isl}
  • トランクポートの設定
    (config-if)#switchport mode trunk

※Cisco CatalystスイッチはDTP(Dynamic Trunk Protocol)が動作していて、接続先に応じて自動的にアクセスポート、トランクポートを判断することもできます。上のコマンドは、静的にアクセスポート、トランクポートに設定するコマンドです。
※スイッチのモデルによっては、swithcport mode trunkの設定の前にカプセル化の設定が必要です

では、

のスイッチで、

・VLAN2を作成
・Fa0/2をVLAN2のアクセスポート
・Fa0/3をIEEE802.1Qのトランクポート

の設定をして見ましょう。

まず、VLAN2を作ります。

(config)#vlan 2

と入力すれば、スイッチの内部にVLAN2が作られます。必要ならばわかりやすくVLANに名前をつけることも可能です。そして、次にFa0/2をVLAN2のアクセスポートにするためには、

(config)#interface fa0/2
(config-if)#switchport mode access
(config-if)#switchport access vlan 2

と設定します。
それから、図のFa0/3をIEEE802.1Qのトランクポートにするには、次のように設定します。

(config)#interface fa0/3
(config-if)#switchport trunk encapsulation dot1q
(config-if)#switchport mode trunk

すると、Fa0/3はVLAN1にもVLAN2にも接続されることになり、各VLANの識別情報を付加してフレームを転送することができます。

で、ここが大事なところですが、上記のように設定した場合のCatalystスイッチの内部の接続がどのようになっているかということをきちんと意識してください。上記の設定を行った場合、Catalystスイッチの内部の接続は次の図になります。

このように内部の接続の様子を見てみると、VLAN1のアクセスポートのFa0/1とVLAN2のアクセスポートのFa0/2が直接通信できなくなってしまうのもよくわかりますね。同じスイッチのポートだけど、レイヤ3スイッチ内部ではFa0/1、Fa0/2はつながっていないので。異なるVLANのポート同士で通信をさせるためには、内部ルータを経由することが必要です。そのために、次回、解説するSVIやルーテッドポートがあります。