レイヤ3スイッチの設定

レイヤ3スイッチの設定を行うには、まずグローバルコンフィグレーションモードでip routingコマンドを入力してIPルーティングを有効にします。

機種によってはip routingコマンドは不要です。

そして、レイヤ3スイッチにIPアドレスを設定することでVLAN(ネットワーク)を相互接続して、VLAN間の通信を可能にします。レイヤ3スイッチのIPアドレス設定は、次のいずれかで行います。

  • SVIの設定
  • ルーテッドポートの設定

SVIの設定

SVIは、内部ルータとVLANを接続する仮想的なインタフェースです。SVIにIPアドレスを設定して、VLANと内部ルータを接続します。グローバルコンフィグレーションモードで次のコマンドを入力します。

SVIの設定

(config)#interface vlan <vlan-id>
(config-if)#ip address <address> <subnetmask>

<vlan-id> : VLAN番号
<address> : IPアドレス
<subnetmask> : サブネットマスク

ルーテッドポートの設定

ルーテッドポートは内部ルータと直結しているポートです。レイヤ3スイッチのポートをルーテッドポートにして、IPアドレスを設定することで、レイヤ3スイッチはネットワークの接続を行います。ルーテッドポートの設定は以下の通りです。

ルーテッドポートの設定

(config)#interface <interface-name>
(config-if)#no switchport
(config-if)#ip address <address> <subnetmask>

<interface-name> : ルーテッドポートにしたいインタフェース
<address> : IPアドレス
<subnetmask> : サブネットマスク

SVI/ルーテッドポートのいずれの設定でも、IPアドレスを設定してインタフェースがupになるとルーティングテーブルにIPアドレスに応じたDirectly connectedのルート情報が登録されるようになります。

レイヤ3スイッチの設定例

次の図のネットワーク構成で、SW1の設定を行います。SW1 Fa0/3はルーテッドポートとして設定します。そして、内部ルータでSVIを作成してVLAN10とVLAN20を相互接続します。

SW1のVLANの作成とアクセスポートの割り当ては設定済みとします。

レイヤ3スイッチの設定例
図 レイヤ3スイッチの設定例

SW1

ip routing
!
interface FastEthernet0/3
 no switchport
 ip address 10.1.1.6 255.255.255.252
!
interface Vlan10
 ip address 192.168.10.254 255.255.255.0
 no shutdown
!
interface Vlan20
 ip address 192.168.20.254 255.255.255.0
 no shutdown

この設定によって、SW1の内部ルータとVLAN、ポートは次のような接続となります。

SW1の内部の構成 (SVI/ルーテッドポート)
図 SW1の内部の構成 (SVI/ルーテッドポート)

SW1において、show ip interface briefコマンドおよびshow ip routeコマンドの出力は以下のように表示されます。

SW1

SW1#show ip interface brief 
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/1            unassigned      YES unset  up                    up      
FastEthernet0/2            unassigned      YES unset  up                    up      
FastEthernet0/3            10.1.1.6        YES manual up                    up      
~省略~
Vlan10                     192.168.10.254  YES manual up                    up      
Vlan20                     192.168.20.254  YES manual up                    up     
SW1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, Vlan10
C    192.168.20.0/24 is directly connected, Vlan20
     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.4 is directly connected, FastEthernet0/3