概要

レイヤ3スイッチで、SVI/ルーテッドポートにIPアドレスを設定して、ネットワーク(VLAN)を相互接続します。そして、EIGRPを有効化してほかのルータとルート情報を交換できるようにします。

ネットワーク構成

図 レイヤ3スイッチ 基本的な設定例 ネットワーク構成
図 レイヤ3スイッチ 基本的な設定例 ネットワーク構成

設定条件

  1. R1と直接接続しているSW1 Fa0/3はルーテッドポートとして利用します。Fa0/1、Fa0/2はスイッチポートとして利用します。
  2. SW1のVLAN10、VLAN20に対応するIPアドレスはサブネット内の最大のIPアド レスを利用します。Fa0/3のIPアドレスは設定可能なIPアドレスを判断して設定します。
  3. EIGRP AS1を利用して図のネットワーク構成におけるIPルーティングができるように設定します。

初期設定

  • ホスト名
  • IPアドレス
    R1 Fa0/0
  • VTPドメイン、VLAN
    SW1 VTPドメイン「SWITCH」、VTPトランスペアレント
    SW1でVLAN10およびVLAN20を作成済み
  • ルーティングプロトコル
    R1で必要なEIGRPの設定は完了済み

設定

【Step1:アクセスポートの割り当て】

SW1 Fa0/1、Fa0/2はスイッチポートです。単一のVLANに割り当てるのでアクセスポートの設定を行います。SW1 Fa0/1をVLAN10、SW1 Fa0/2をVLAN20のアクセスポートとして設定します。

SW1

interface FastEthernet0/1
 switchport mode access
 switchport access vlan 10
!
interface FastEthernet0/2
 switchport mode access
 switchport access vlan 20

【Step2:アクセスポートの確認】

Cisco3725ルータにイーサネットスイッチモジュールを搭載してSW1としています。そのため、VLANとアクセスポートの割り当ての確認は、show vlan-switch briefコマンドで行います。SW1のshow vlan-switch briefコマンドは次のようになります。

SW1

SW1#show vlan-switch brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12
10   VLAN0010                         active    Fa0/1
20   VLAN0020                         active    Fa0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active
 

Catalystスイッチでは、show vlan briefコマンドです。

【Step3:ルーテッドポート、SVIのIPアドレスの設定】

SW1でルーティングを可能にするために、ip routingコマンドを設定します。そして、SW1 Fa0/3はルーテッドポートとして直接IPアドレスを設定します。対向のR1 Fa0/0のIPアドレスは10.1.1.5/30です。R1 Fa0/0と同一サブネットで利用可能なIPアドレスは10.1.1.6/30です。そのため、SW1 Fa0/3のIPアドレスとして10.1.1.6/30を設定します。

また、VLAN10、VLAN20を接続するためのSVIを作成して、IPアドレスを設定します。SW1のIPアドレスをまとめると、次の表のようになります。

インタフェースIPアドレス
Fa0/3(ルーテッドポート)10.1.1.6/30
VLAN10(SVI)192.168.10.254/24
VLAN20(SVI)192.168.20.254/24
表 SW1に設定するIPアドレス

SW1

ip routing
!
interface FastEthernet0/3
 no switchport
 ip address 10.1.1.6 255.255.255.252
 no shutdown
!
interface Vlan10
 ip address 192.168.10.254 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.254 255.255.255.0

【Step4: ルーテッドポート、SVIのIPアドレスの確認】

SW1において、show ip interface briefコマンドおよびshow ip routeコマンドでルーテッドポート、SVIに正しくIPアドレスが設定されていることを確認します。

SW1

SW1#show ip interface brief 
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/1            unassigned      YES unset  up                    up      
FastEthernet0/2            unassigned      YES unset  up                    up      
FastEthernet0/3            10.1.1.6        YES manual up                    up      
~省略~
Vlan10                     192.168.10.254  YES manual up                    up      
Vlan20                     192.168.20.254  YES manual up                    up     
SW1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, Vlan10
C    192.168.20.0/24 is directly connected, Vlan20
     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.4 is directly connected, FastEthernet0/3

IPアドレスを設定したあとのSW1内部の状態を表すと、次の図のようになります。

図 SW1のIPアドレスの設定
図 SW1のIPアドレスの設定

【Step5:EIGRPの設定】

SW1でEIGRPを有効化し、R1とルート情報を送受信できるようにします。

SW1

router eigrp 1
 network 192.168.10.0
 network 192.168.20.0
 network 10.0.0.0
 no auto-summary

【Step6:EIGRPの確認】

show ip eigrp neighborコマンドでR1とSW1がEIGRPネイバーとなっていることを確認します。また、SW1のルーティングテーブルにEIGRPルート172.16.1.0/24、172.16.2.0/24が存在していることを確認します。

SW1

SW1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.1.5                Fa0/3             13 00:01:10 1271  5000  0  4
SW1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, Vlan10
     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.1.0 [90/156160] via 10.1.1.5, 00:01:12, FastEthernet0/3
D       172.16.2.0 [90/156160] via 10.1.1.5, 00:01:12, FastEthernet0/3
C    192.168.20.0/24 is directly connected, Vlan20
     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.4 is directly connected, FastEthernet0/3

【Step7:通信確認】

ホストから正しく通信できることを確認します。

H1

H1#ping 192.168.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/36/44 ms
H1#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/48 ms
H1#ping 172.16.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/39/40 ms

関連記事