この部分の広告を募集しています。 詳しくはこちら

CCIE Routing & Switching Trouble Shooting 攻略 Part2 TT04 (v4向け)

(所属カテゴリー:IPルーティング | シスコ---投稿日時:2015年9月 4日)

※ ネットワーク構成は↓よりご覧ください。
CCIE Routing & Switching Trouble Shooting 攻略 Part2 問題 (v4向け)

問題

4.RIPドメインのルーティングが正しく行われていません。RIPドメインのルーティングができるようにしてください。なお、SW4はRIPアップデートをマルチキャスト/ブロードキャストでR4へ送信してはいけません。

トラブルの解決

R4
----
interface FastEthernet0/0
 no ip rip receive version 1
!
router rip
 no timers basic 5 10 10 10
----

SW2
----
no monitor session 1 destination interface Fa1/2
!
interface fastethernet1/2
 switchport trunk allowed vlan add 22
----

SW4
----
interface range fastethernet1/10 -15
 switchport trunk allowed vlan add 44
!
router rip
 neighbor 15.15.15.129
----

トラブルの症状と原因、切り分け

表 トラブルの症状と原因、切り分け(No.4)
CCIE_TS_Part2_14.png

【SW2 F1/2がSPANの送信先ポートになっている】

SPANの送信元ポートは、トラフィックをキャプチャするために通常の通信はできません。show interfaceを見ると、line protocol is down (monitoring)と表示されます。R2-R4間でIP通信できるようにするためには、SW2 F1/2のSPAN送信元ポートの設定を削除します。

SW2
----
no monitor session 1 destination interface Fa1/2
----

【SW2 F1/2でVLAN22を転送できない】

R2 F1/0はVLAN22とVLAN24のサブインタフェースに分割しています。R2 F1/0が接続されるSW2 F1/2をトランクポートとしてVLAN22とVLAN24のフレームを転送できるようにしなければいけません。しかし、SW2 F1/2のトランクポート上でVLAN22の転送が許可されていません。その結果、R2-R4間で通信ができなくなっています。解決するために、SW2 F1/2のトランクポートにVLAN22を追加します。

SW2
----
interface fastethernet1/2
 switchport trunk allowed vlan add 22
----

【SW4 VLAN44がUp/downになっている】

SW4のVLAN44のSVIの状態がUp/downとなっています。SVIがUp/downになる原因は、該当するVLANに対するアクティブなスイッチポートが存在しないことです。SW4のトランクポートを確認すると、VLAN44の転送が許可されていません。VLAN44をUp/upにしてR4-SW4間で通信可能にするためには、SW4のトランクポート上にVLAN44を転送できるようにします。

SW4
----
interface range fastethernet1/10 -15
 switchport trunk allowed vlan add 44
----

【SW4でneighborコマンドの設定が抜けている】

SW4では、ブロードキャスト/マルチキャストでのRIPアップデートを行わないようにするために、passive-interface defaultですべてのインタフェースをパッシブインタフェースとしています。このままでは、SW4からR4へRIPアップデートが送信されません。SW4からR4へRIPアップデートをユニキャストで転送するためには、neighborコマンドが必要です。

SW4
----
router rip
 neighbor 15.15.15.129
----

【R4 F0/0はRIPv1のみを受信するように設定されている】

RIPドメインはRIPv2でアップデートを送受信します。しかし、R4 F0/0はインタフェースでip rip receive version 1の設定がされていて、RIPv1アップデートのみを受信するようになっています。そのため、SW4からのRIPv2アップデートを受信できません。解決するために、R4 F0/0のRIPのバージョンコントロールの設定を削除します。

R4
----
interface FastEthernet0/0
 no ip rip receive version 1
----

【R4のRIPタイマーの指定が間違っている】

R4でルーティングテーブル上のRIPルートを確認すると、ルートがフラッピングしています。RIPルートが登録されてもすぐにpossibly downとなりルートが削除されます。ossibly downとなるのは、RIPルートを最後に受信してからInvalid timerが経過したあとです。そのため、Invalid timerなどのタイマーの値が正しくないということが推測できます。show ip protocolsを確認すると、R4でRIPのタイマーの値が他のルータと整合性がとれていないことがわかります。解決するためには、R4で他のルータと整合性がとれるようにRIPタイマーをデフォルトに戻します。

R4
----
router rip
 no timers basic 5 10 10 10
----

CCIE_TS_Part2_15.png
図 トラブルの症状と原因、切り分け(No.4)

トラブルの仕込み

R4
----
interface FastEthernet0/0
 ip rip receive version 1
!
router rip
 timers basic 5 10 10 10
----

SW2
----
monitor session 1 destination interface Fa1/2
!
interface fastethernet1/2
 switchport trunk allowed vlan remove 22
----

SW4
----
interface range fastethernet1/10 -15
 switchport trunk allowed vlan remove 44
!
router rip
 no neighbor 15.15.15.129
----

Google
Web n-study.com

各コンテンツの最新記事

有料コンテンツライブラリ(ITエンジニア教育資料)

ネットワーク技術雑誌レビュー

ベンダ資格受験記

オススメ!ネットワーク技術雑誌・書籍

MindMapでおべんきょ

結果を出せるコーチング

Geneのつぶやき

The Power of Words

スポンサードリンク

スポンサードリンク