Ciscoデバイスの管理 Ciscoルータの初期設定サンプル

(所属カテゴリー:シスコ---投稿日時:2006年8月13日)

Ciscoルータの初期設定サンプル

実際にCiscoルータの基本的な初期設定を行ってみましょう。初期設定として、 下記の設定を行い、その動作を確認します。

  • ホスト名
  • パスワード
    -イネーブルパスワード
    -コンソール/AUXパスワード
    -VTY(Telnet)パスワード
  • インタフェース
    -IPアドレスの設定
    -インタフェースの有効化

設定するパラメータと設定コマンドは表の通りです。

ホスト名を設定するにはグローバルコンフィグレーションモードでhostnameコ マンドを使います。まず、イネーブルモードに入ってconfigure terminalでグ ローバルコンフィグレーションモードに移ってから、ホスト名を設定します。

ログ ホスト名の設定

Router>enable 
Router#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Gene
Gene(config)#

ホスト名を設定すると、すぐにプロンプトに反映されます。そして、この時点 でruuning-configにhostnameコマンドが追加されています。これ以降のコマン ド入力も入力した時点でrunning-configに反映されます。

次にパスワードの設定を行います。特権EXECモードに入るためのイネーブルパ スワードを設定するには、

  • enable password
  • enable secret
の2つのコマンドがあります。enable secretコマンドで設定したパスワードは、 show running-configで設定を表示した時に暗号化されます。一方、enable password コマンドで設定したパスワードは、show running-configで設定を表示した時 に暗号化されません。両方とも設定した場合は、enable secretコマンドで設 定したパスワードが適用されます。パスワードが管理者以外に漏えいしてしま う可能性を小さくするために、enable secretコマンドでパスワードを設定し ます。

では、ホスト名の設定に引き続いて、イネーブルパスワードを設定します。そ の様子が下記のログです。

ログ イネーブルパスワードの設定

Gene(config)#enable secret cisco
Gene(config)#end
Gene#show running-config
Building configuration...

Current configuration : 684 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Gene
!
logging rate-limit console 10 except errors
enable secret 5 $1$9e5d$tIcQvbnm1.1ocUIrxSx4H1

~以下、省略~

enable secretコマンドでイネーブルパスワードを設定した後、show running-config を見ると、パスワード「cisco」が暗号化されていることがわかります。また、 いったんユーザEXECモードに戻ります。そして、再度、enableコマンドで特権 EXECモードに移行しようとするとパスワードの入力が求められるようになります。

ログ イネーブルパスワードの設定後

Gene>enable 
Password: 
Gene#

次にコンソール/AUXポート、VTY(Telnet)のパスワードです。こちらはグロー バルコンフィグレーションモードからそれぞれのラインコンフィグレーション モードに入ります。ラインコンフィグレーションモードには、次のコマンドで 入ります。

(config)#line [con|aux|vty] [line-number]

コンソール、AUXポートの[line-number]は必ず「0」です。VTYはデフォルトで は0~4ですが、現在のIOSではさらに多くのラインを指定できるようになって います。コンソール/AUXパスワード、VTYパスワードを設定している様子が次 のログです。

ログ コンソール/AUX、VTYパスワードの設定

Gene(config)#line console 0
Gene(config-line)#login
Gene(config-line)#password cisco
Gene(config-line)#exit
Gene(config)#line aux 0
Gene(config-line)#login
Gene(config-line)#password cisco
Gene(config-line)#exit
Gene(config)#line vty 0 4
Gene(config-line)#login
Gene(config-line)#password telnet

設定した後、いったんユーザEXECモードでexitコマンドを入力してコンソール を抜けます。再度、コンソールに入ろうとするとパスワードが求められます。

ログ コンソールパスワード

Gene con0 is now available





Press RETURN to get started.




00:05:48: %SYS-5-CONFIG_I: Configured from console by console

User Access Verification

Password: 
Gene>

そして、他のデバイスからTelnetしたときも、パスワードが求められるように なります。

ログ VTYパスワード

Router#telnet 192.168.1.1
Trying 192.168.1.1 ... Open


User Access Verification

Password: 
Gene>

続いて、インタフェースへのIPアドレスの設定です。グローバルコンフィグレ ーションモードから設定したいインタフェースのインタフェースコンフィグレ ーションモードに入り、ip addressコマンドでIPアドレスを設定します。ip address コマンドは、IPアドレスを設定するだけでなく、その前提としてインタフェー スでIPによる処理を有効化するという意味もあります。また、もうひとつ注意 しなければいけないのが、Ciscoルータはデフォルトでshutdownコマンドが入 っていて、無効化されている点です。インタフェースを有効化するためにno shutdown を忘れないようにしてください。
インタフェースにIPアドレスを設定しno shutdownでインタフェースを有効化 して正常にインタフェースが起動すれば、ルーティングテーブルに直接接続 (Directly Connected)のネットワークとして設定したネットワークアドレスが 登録されます。そして、ルーティングテーブルに登録された直接接続のネット ワーク間でルーティングが可能になります。

このルータのEthernet0にIPアドレスを設定している様子が次のログです。

ログ IPアドレスの設定

Gene(config)#interface ethernet 0
Gene(config-if)#ip address 192.168.1.1 255.255.255.0
Gene(config-if)#no shutdown 
Gene(config-if)#
00:15:33: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
00:15:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, 
changed state to up

インタフェースのIPアドレスの設定と状態(up/down)を確認するには次のよう ないくつかのコマンドがあります。

  • show ip interface brief
    インタフェースのIPアドレス、状態を一覧表示
  • show interface
    インタフェースのレイヤ1、レイヤ2の情報を中心として表示
  • show ip interface
    インタフェースのレイヤ3の情報を中心として表示
IPアドレスの確認、インタフェースの状態は上記のどれでも可能です。それ以 外の情報を確認するときは、必要に応じて使い分けてください。

※ただし、show ip interface briefコマンドではサブネットマスクを確認できません。

この例のルータにおける上記3つのコマンドの出力結果は以下の通りです。

ログ show ip interface brief、show interface ethernet0、show ip interface ethernet0

Gene#show ip interface brief 
Interface                 IP-Address      OK? Method Status                Protocol
Ethernet0                  192.168.1.1     YES manual up                    up
Serial0                    unassigned      YES unset  administratively down down
Serial1                    unassigned      YES unset  administratively down down

Gene#show interfaces ethernet 0
Ethernet0 is up, line protocol is up 
  Hardware is Lance, address is 0010.7b7f.728d (bia 0010.7b7f.728d)
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
~以下、省略~

Gene#show ip interface ethernet 0
Ethernet0 is up, line protocol is up
  Internet address is 192.168.1.1/24
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
~以下、省略~

また、インタフェースの状態について補足です。インタフェースの状態は次の ように2つ表示されます。

Ethernet0 is up, line protocol is up

[interface] is ~の部分は物理層レベルの状態です。そして、line protocol is ~ はデータリンク層レベルの状態です。両方ともupになっている状態が正常です。 もし、両方ともupでなければ何らかのトラブルが発生していることになります ので、そのトラブルを解決する必要があります。インタフェースの状態の取り うるケースをまとめているのが次の表です。

http://www.n-study.com/network/gene/interface_status.html

※up/upの状態はあくまでもデータリンク層までの話です。up/upになっていてもネットワーク層以上のトラブルで通信できない場合はあります。

以上のルータの初期設定後のshow running-configは次のとおりになります。

Gene#show running-config 
Building configuration...

Current configuration : 684 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Gene
!
logging rate-limit console 10 except errors
enable secret 5 $1$9e5d$tIcQvbnm1.1ocUIrxSx4H1
!
ip subnet-zero
no ip finger
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
line con 0
 password cisco
 login
 transport input none
line aux 0
 password cisco
 login
line vty 0 4
 password telnet
 login
!
end

これを見ると、設定したコマンドがrunning-configに表れていることがよくわ かります。また、copyコマンドで設定をstartup-configに保存せずにルータを 再起動したら、設定した内容が失われてしまうので注意してください。


※このコンテンツは、6/19にリリースしたCCNAテキストの一部です。CCNAテキストは、ボリューム900ページ以上!徹底的に詳細な解説でCCNA合格だけでなく、ネットワーク技術の大幅なスキル アップに最適です!!

Google
Web n-study.com

各コンテンツの最新記事

有料コンテンツライブラリ(ITエンジニア教育資料)

ネットワーク技術雑誌レビュー

ベンダ資格受験記

オススメ!ネットワーク技術雑誌・書籍

MindMapでおべんきょ

結果を出せるコーチング

Geneのつぶやき

The Power of Words

スポンサードリンク

スポンサードリンク