概要

2つのEIGRPドメインとRIPドメインを組み合わせてルーティングを行います。再配送、ルート集約、不等コストロードバランスについての理解を深めるための演習です。

ネットワーク構成

図 EIGRP応用設定 ネットワーク構成
図 EIGRP応用設定 ネットワーク構成

設定条件

  1. ネットワーク構成の通りにRIP、EIGRP AS1、EIGRP AS2の設定を行います。自動集約はすべて無効化してください。
  2. R6のK値を次のように設定してください。
    K1=K2=K3=K4=K5=1
  3. RIPドメインのルートはEIGRP AS1ドメインでは、172.16.0.0/16で見えるようにしてください。
  4. EIGRP AS2ドメインのルートはEIGRP AS1ドメインでは、10.1.0.0/16で見えるようにしてください。
  5. R1のルーティングテーブルに192.168.2.0/24のルートが次のように登録されるようにしてください。なお、このための設定はR1でのみ行なってください。メトリックの値そのものは例と異なっていても問題ありません。
    —————————————————-
    R1#show ip route eigrp             
    — omitted —
    D    192.168.2.0/24 [90/439600] via 192.168.21.2, 00:03:05, Ethernet0/1
                        [90/2349056] via 192.168.14.4, 00:03:05, Serial1/0
                        [90/439600] via 192.168.12.2, 00:03:05, Ethernet0/0
    — omitted —
    —————————————————-
  6. R4から192.168.3.3に対するTracerouteの結果が次のように表示されるようにしてください。
    —————————————————-
    R4#traceroute 192.168.3.3

    Type escape sequence to abort.
    Tracing the route to 192.168.3.3

      1 192.168.34.3 20 msec *  16 msec
    —————————————————-

初期設定

以下の内容は設定済みです。

  • ホスト名
  • IPアドレス

R1 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.21.1 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 ip address 172.16.15.1 255.255.255.0
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 192.168.14.1 255.255.255.0
 encapsulation ppp
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.21.2 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 ip address 192.168.23.2 255.255.255.0
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.3.3 255.255.255.0 secondary
 ip address 192.168.34.3 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Ethernet0/0
 ip address 192.168.34.4 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 10.1.46.4 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 192.168.14.4 255.255.255.0
 encapsulation ppp
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R5 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 172.16.5.5 255.255.255.0
!
interface Ethernet0/0
 ip address 172.16.15.5 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 10.1.6.6 255.255.255.0
!
interface Ethernet0/0
 ip address 10.1.46.6 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

設定と確認

Step1:EIGRP AS1ドメインの設定

R1~R4でEIGRP AS1を有効化します。

R1 EIGRP AS1ドメインの設定

router eigrp 1
 network 192.168.12.0
 network 192.168.14.0
 network 192.168.21.0
 no auto-summary

R2 EIGRP AS1ドメインの設定

router eigrp 1
 network 192.168.2.0
 network 192.168.12.0
 network 192.168.21.0
 network 192.168.23.0
 no auto-summary

R3 EIGRP AS1ドメインの設定

router eigrp 1
 network 192.168.3.0
 network 192.168.23.0
 network 192.168.34.0
 no auto-summary

R4 EIGRP AS1ドメインの設定

router eigrp 1
 network 192.168.14.0
 network 192.168.34.0
 no auto-summary

Step2:EIGRP AS1ドメインの確認

Step1のEIGRP AS1ドメインの設定を確認するために、次のコマンドを利用します。

  • show ip protocols
  • show ip eigrp interface
  • show ip eigrp neighbor
  • show ip route eigrp

R1では、次のような表示です。

R1 EIGRP AS1ドメインの確認

R1#show ip protocols 
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.12.0
    192.168.14.0
    192.168.21.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.14.4          90      00:01:09
    192.168.12.2          90      00:01:09
    192.168.21.2          90      00:01:09
  Distance: internal 90 external 170

R1#show ip eigrp interfaces 
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et0/0              1        0/0        26       0/2          120           0
Et0/1              1        0/0        30       0/2          128           0
Se1/0              1        0/0        24       0/15         115           0
R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   192.168.14.4            Se1/0             12 00:17:01   24   200  0  26
1   192.168.21.2            Et0/1             14 00:18:00   30   200  0  45
0   192.168.12.2            Et0/0             14 00:18:03   26   200  0  44
R1#show ip route eigrp 
D    192.168.23.0/24 [90/307200] via 192.168.21.2, 00:01:51, Ethernet0/1
                     [90/307200] via 192.168.12.2, 00:01:51, Ethernet0/0
D    192.168.34.0/24 [90/332800] via 192.168.21.2, 00:01:51, Ethernet0/1
                     [90/332800] via 192.168.12.2, 00:01:51, Ethernet0/0
D    192.168.2.0/24 [90/409600] via 192.168.21.2, 00:01:18, Ethernet0/1
                    [90/409600] via 192.168.12.2, 00:01:18, Ethernet0/0
D    192.168.3.0/24 [90/332800] via 192.168.21.2, 00:01:51, Ethernet0/1
                    [90/332800] via 192.168.12.2, 00:01:51, Ethernet0/0

Step3:EIGRP AS2ドメインの設定

R4、R6でEIGRP AS2を有効化します。R6でK値の値を変更するという条件ですが、R4でも変更しなければいけません。EIGRPでは、ネイバー確立のためにAS番号とK値が一致している必要があります。

R4 EIGRP AS2ドメインの設定

router eigrp 2
 network 10.1.46.0 0.0.0.255
 metric weights 0 1 1 1 1 1
 no auto-summary

R6 EIGRP AS2ドメインの設定

router eigrp 2
 network 10.0.0.0
 metric weights 0 1 1 1 1 1
 no auto-summary

Step4:EIGRP AS2ドメインの確認

Step3のEIGRP AS2ドメインの設定を確認するために、次のコマンドを利用します。

  • show ip protocols
  • show ip eigrp interface
  • show ip eigrp neighbor
  • show ip route eigrp

R4では、次のような表示です。

R1 EIGRP AS2ドメインの確認

R4#show ip protocols 
Routing Protocol is "eigrp 1"
-- omitted --

Routing Protocol is "eigrp 2"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=1, K3=1, K4=1, K5=1
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 2
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.1.46.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.46.6             90      00:01:03
  Distance: internal 90 external 170

R4#show ip eigrp 2 interfaces 
IP-EIGRP interfaces for process 2
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et0/1              1        0/0        33       0/2          140           0
R4#show ip eigrp 2 neighbors 
IP-EIGRP neighbors for process 2
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.46.6               Et0/1             14 00:01:46   33   200  0  5
R4#show ip route eigrp 
D    192.168.12.0/24 [90/332800] via 192.168.34.3, 00:02:21, Ethernet0/0
D    192.168.21.0/24 [90/332800] via 192.168.34.3, 00:02:21, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.1.6.0 [90/1603] via 10.1.46.6, 00:01:48, Ethernet0/1
D    192.168.23.0/24 [90/307200] via 192.168.34.3, 00:02:21, Ethernet0/0
D    192.168.2.0/24 [90/435200] via 192.168.34.3, 00:02:21, Ethernet0/0
D    192.168.3.0/24 [90/2246656] via 192.168.14.1, 00:02:21, Serial1/0

Step5:RIPドメインの設定

R1とR5でRIPv2を有効化します。

R1 RIPドメインの設定

router rip
 version 2
 network 172.16.0.0
 no auto-summary

R5 RIPドメインの設定

router rip
 version 2
 network 172.16.0.0
 no auto-summary

Step6:RIPドメインの確認

Step5のRIPの設定を確認するために、次のコマンドを利用します。

  • show ip protocols
  • show ip rip database
  • show ip route rip

R1では、次のような表示です。

R1 RIPドメインの確認

R1#show ip protocols 
Routing Protocol is "eigrp 1"
-- omitted --

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 4 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/2           2     2                                    
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.15.5          120      00:00:10
  Distance: (default is 120)

R1#show ip rip database 
172.16.0.0/16    auto-summary
172.16.5.0/24
    [1] via 172.16.15.5, 00:00:14, Ethernet0/2
172.16.15.0/24    directly connected, Ethernet0/2
R1#show ip route rip
     172.16.0.0/24 is subnetted, 2 subnets
R       172.16.5.0 [120/1] via 172.16.15.5, 00:00:22, Ethernet0/2

Step7:再配送の設定

R1でEIGRP AS1ドメインとRIPドメインの再配送を行います。また、R4でEIGRP AS1ドメインとEIGRP AS2ドメインの再配送を行います。シードメトリックの指定を忘れないように注意が必要です。

R1 再配送の設定

router eigrp 1
 redistribute rip metric 100000 10 255 1 1500
!
router rip
 redistribute eigrp 1 metric 5

R4 再配送の設定

router eigrp 1
 redistribute eigrp 2 metric 1000000 10 255 1 1500
!
router eigrp 2
 redistribute eigrp 1 metric 1000000 10 255 1 1500

Step8:再配送の確認

R1でRIPデータベースとEIGRPトポロジテーブルを見て、RIPドメインとEIGRP AS1ドメインの再配送を確認します。また、R4でEIGRPトポロジテーブルを見て、EIGRP AS1ドメインとEIGRP AS2ドメインの再配送を確認します。

R1 再配送の確認

R1#show ip protocols 
Routing Protocol is "eigrp 1"
-- omitted --
  Redistributing: eigrp 1, rip
-- omitted --

Routing Protocol is "rip"
-- omitted --
  Redistributing: eigrp 1, rip
-- omitted --

R1#show ip rip database 
-- omitted --
192.168.2.0/24    auto-summary
192.168.2.0/24    redistributed
    [5] via 192.168.12.2, 
    [5] via 192.168.21.2, 
192.168.3.0/24    auto-summary
192.168.3.0/24    redistributed
    [5] via 192.168.12.2, 
    [5] via 192.168.21.2, 
192.168.12.0/24    auto-summary
192.168.12.0/24    redistributed
    [5] via 0.0.0.0, 
192.168.14.0/24    auto-summary
192.168.14.0/24    redistributed
    [5] via 0.0.0.0, 
192.168.14.4/32    redistributed
    [5] via 0.0.0.0, 
192.168.21.0/24    auto-summary
192.168.21.0/24    redistributed
    [5] via 0.0.0.0, 
192.168.23.0/24    auto-summary
192.168.23.0/24    redistributed
    [5] via 192.168.12.2, 
    [5] via 192.168.21.2, 
192.168.34.0/24    auto-summary
192.168.34.0/24    redistributed
    [5] via 192.168.12.2, 
    [5] via 192.168.21.2, 
R1#show ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(192.168.21.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

-- omitted --
P 172.16.15.0/24, 1 successors, FD is 28160
        via Redistributed (28160/0)
P 172.16.5.0/24, 1 successors, FD is 28160
        via Redistributed (28160/0)

R4 再配送の確認

R4#show ip protocols 
Routing Protocol is "eigrp 1"
-- omitted --
  Redistributing: eigrp 1, eigrp 2
-- omitted --

Routing Protocol is "eigrp 2"
-- omitted --
  Redistributing: eigrp 1, eigrp 2
-- omitted --
R4#show ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(192.168.34.4)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.6.0/24, 1 successors, FD is 5120
        via Redistributed (5120/0)
P 10.1.46.0/24, 1 successors, FD is 5120
        via Redistributed (5120/0)
-- omitted --
IP-EIGRP Topology Table for AS(2)/ID(192.168.34.4)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

-- omitted --
P 192.168.34.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 192.168.12.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 192.168.14.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 192.168.14.1/32, 1 successors, FD is 20
        via Redistributed (20/0)
P 192.168.2.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 192.168.3.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 192.168.21.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 192.168.23.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 172.16.15.0/24, 1 successors, FD is 20
        via Redistributed (20/0)
P 172.16.5.0/24, 1 successors, FD is 20
        via Redistributed (20/0)

Step9:ルート集約の設定

RIPドメインとEIGRP AS2ドメインのルートを集約して、EIGRP AS1ドメインで見えるようにします。

RIPドメインのルートは、R5で集約ルート172.16.0.0/16を生成して、R1で再配送時に集約ルートのみを再配送するフィルタを適用します。

R1 ルート集約の設定 RIPドメイン

router eigrp 1
 redistribute rip metric 1000000 10 255 1 1500 route-map RIP-SUM
!
access-list 1 permit 172.16.0.0
!
route-map RIP-SUM permit 10
 match ip address 1

R5 ルート集約の設定 RIPドメイン

interface Ethernet0/0
 ip summary-address rip 172.16.0.0 255.255.0.0

図 RIPドメインの集約
図 RIPドメインの集約

EIGRP AS2ドメインのルートは、R4でEIGRP AS1ドメインのインタフェースからアドバタイズするときに集約します。

R4 ルート集約の設定 EIGRP AS2ドメイン

interface Ethernet0/0
 ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
!
interface Serial1/0
 ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5

図 EIGRP AS2ドメインの集約
図 EIGRP AS2ドメインの集約

Step10:ルート集約の確認

Step9のルート集約を確認します。EIGRP AS1ドメインのR3のルーティングテーブルは次のようになります。

R3 ルート集約の確認 RIPドメイン

R3#show ip route eigrp 
D    192.168.12.0/24 [90/307200] via 192.168.23.2, 01:05:41, Ethernet0/0
     192.168.14.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.14.4/32 [90/2221056] via 192.168.23.2, 01:06:32, Ethernet0/0
D       192.168.14.0/24 [90/2195456] via 192.168.34.4, 01:05:42, Ethernet0/1
D       192.168.14.1/32 [90/2195456] via 192.168.34.4, 01:05:42, Ethernet0/1
     172.16.0.0/16 is subnetted, 1 subnets
D EX    172.16.0.0 [170/309760] via 192.168.23.2, 00:03:19, Ethernet0/0
D    192.168.21.0/24 [90/307200] via 192.168.23.2, 01:05:41, Ethernet0/0
     10.0.0.0/16 is subnetted, 1 subnets
D       10.1.0.0 [90/284160] via 192.168.34.4, 00:12:54, Ethernet0/1
D    192.168.2.0/24 [90/409600] via 192.168.23.2, 00:53:05, Ethernet0/0

RIPドメインのルートは172.16.0.0/16、EIGRP AS2ドメインのルートは10.1.0.0/16となっていることがわかります。なお、EIGRP AS2ドメインの集約ルートは内部ルート扱いとなります。ip summary-address eigrpコマンドで生成した集約ルートは内部ルートになるからです。

Step11:不等コストロードバランスの設定

設定条件5.のようにR1のルーティングテーブルに192.168.2.0/24のルートを登録するためには、不等コストロードバランスの設定が必要です。EIGRPでは、不等コストロードバランスによって、メトリックが異なる複数のルートをルーティングテーブルに登録することができます。ただし、不等コストロードバランスでメトリックが大きいルートをルーティングテーブルに登録するのは、フィージブルサクセサでなければいけないことに注意してください。

不等コストロードバランスにより、R1では192.168.2.0/24のルートとしてR2経由だけでなくR4経由のものもルーティングテーブルに登録しようとしています。そのためには、R4は192.168.2.0/24に対するフィージブルサクセサでなければいけません。R1での192.168.2.0/24のメトリック(FD)は409600です。一方、R4では192.168.0.2/32に対するメトリック(FD)は435200です。つまり、R4はR1よりも192.168.2.0/24から遠くに位置していることになります。そのため、R1はR4経由の192.168.2.0/24のルートがループフリーであることを保証できずに、フィージブルサクセサとしてR4を利用できません。

フィージブルサクセサとなる条件は、「サクセサのFD > フィージブルサクセサのAD」である必要があります。

図 192.168.2.0/24に対するR1とR4の位置関係
図 192.168.2.0/24に対するR1とR4の位置関係

フィージブルサクセサでなければ、varianceをいくら大きくしてもルーティングテーブルには登録されません。そこで、R1にとって192.168.2.0/24のフィージブルサクセサとしてR4を利用できるように、オフセットリストでR1のFDを大きくしたうえで、varianceコマンドを設定します。

R1 不等コストロードバランスの設定

router eigrp 1
 variance 6
 offset-list 2 in 30000 Ethernet0/0
 offset-list 2 in 30000 Ethernet0/1
!
access-list 2 permit 192.168.2.0

図 不等コストロードバランスの設定
図 不等コストロードバランスの設定

Step12:不等コストロードバランスの確認

オフセットリストでR1での192.168.2.0/24のFDを大きくすることで、R4が192.168.2.0/24のフィージブルサクセサとなります。R1のshow ip eigrp topology all-linksを見ると、R4はフィージブルサクセサの条件を満足しています。

R1 不等コストロードバランスの確認

R1#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(192.168.21.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

-- omitted --
P 192.168.2.0/24, 2 successors, FD is 409600, serno 110
        via 192.168.12.2 (439600/158256), Ethernet0/0
        via 192.168.21.2 (439600/158256), Ethernet0/1
        via 192.168.14.4 (2349056/435200), Serial1/0, serno 22
-- omitted --

show ip protocolsコマンドでvarianceの値がわかります。そして、varianceの設定によってルーティングテーブルは設定条件で提示された内容と同じになっていることがわかります。

R1 不等コストロードバランスの確認

R1#show ip protocols 
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Incoming routes in Ethernet0/0 will have 30000 added to metric if on list 2
  Incoming routes in Ethernet0/1 will have 30000 added to metric if on list 2
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 6
-- omitted --

R1#show ip route eigrp              
-- omitted --
D    192.168.2.0/24 [90/439600] via 192.168.21.2, 00:03:05, Ethernet0/1
                    [90/2349056] via 192.168.14.4, 00:03:05, Serial1/0
                    [90/439600] via 192.168.12.2, 00:03:05, Ethernet0/0
-- omitted --

Step13:セカンダリアドレスのアドバタイズ

R3のE0/1にはセカンダリアドレス192.168.3.3を設定していますが、スプリットホライズンによって192.168.3.0/24のルートをE0/1から送信しません。R4から192.168.3.3へのTracerouteの結果が設定条件で提示されているようにするためには、R3のE0/1でスプリットホライズンを無効化します。

R3 セカンダリアドレスのアドバタイズ

interface Ethernet0/1
 no ip split-horizon eigrp 1

図 セカンダリアドレスのアドバタイズ
図 セカンダリアドレスのアドバタイズ

その結果、R4のルーティングテーブルには、R3経由の192.168.3.0/24のルートが登録されます。そして、Tracerouteの結果が設定条件で提示された内容と同じになります。

R4 セカンダリアドレスのアドバタイズの確認

R4#show ip route eigrp | include 192.168.3.0
D    192.168.3.0/24 [90/307200] via 192.168.34.3, 00:00:58, Ethernet0/0
R4#traceroute 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.3.3

  1 192.168.34.3 20 msec *  16 msec

演習完了の設定ファイル

R1 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.21.1 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 ip address 172.16.15.1 255.255.255.0
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 192.168.14.1 255.255.255.0
 encapsulation ppp
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 variance 6
 redistribute rip metric 1000000 10 255 1 1500 route-map RIP-SUM
 offset-list 2 in 30000 Ethernet0/0
 offset-list 2 in 30000 Ethernet0/1
 network 192.168.12.0
 network 192.168.14.0
 network 192.168.21.0
 no auto-summary
!
router rip
 version 2
 redistribute eigrp 1 metric 5
 network 172.16.0.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
access-list 1 permit 172.16.0.0
access-list 2 permit 192.168.2.0
!
route-map RIP-SUM permit 10
 match ip address 1
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.21.2 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 ip address 192.168.23.2 255.255.255.0
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 192.168.2.0
 network 192.168.12.0
 network 192.168.21.0
 network 192.168.23.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 192.168.3.3 255.255.255.0 secondary
 ip address 192.168.34.3 255.255.255.0
 no ip split-horizon eigrp 1
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 192.168.3.0
 network 192.168.23.0
 network 192.168.34.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Ethernet0/0
 ip address 192.168.34.4 255.255.255.0
 ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
 half-duplex
!
interface Ethernet0/1
 ip address 10.1.46.4 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 192.168.14.4 255.255.255.0
 encapsulation ppp
 ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 redistribute eigrp 2 metric 1000000 10 255 1 1500
 network 192.168.14.0
 network 192.168.34.0
 no auto-summary
!
router eigrp 2
 redistribute eigrp 1 metric 1000000 10 255 1 1500
 network 10.1.46.0 0.0.0.255
 metric weights 0 1 1 1 1 1
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R5 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 172.16.5.5 255.255.255.0
!
interface Ethernet0/0
 ip address 172.16.15.5 255.255.255.0
 ip summary-address rip 172.16.0.0 255.255.0.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router rip
 version 2
 network 172.16.0.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 10.1.6.6 255.255.255.0
!
interface Ethernet0/0
 ip address 10.1.46.6 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 2
 network 10.0.0.0
 metric weights 0 1 1 1 1 1
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

関連記事

関連記事