Overview

If the best-path BGP route is not registered in the routing table, the route is placed in RIB Failure status.This section describes RIB Failure of BGP route.

What is RIB Failure?

RIB Failure status of a BGP route means that the best-path BGP route is not registered in the routing table. RIB (Routing Information Base) means routing table.

The main reason for RIB Failure, i.e., the best-path BGP route is not registered in the routing table, is that the route of another routing process is preferred over the BGP route.

Notice

Other causes of RIB Failure include

  • When BGP routes cannot be registered in the routing table due to insufficient router memory
  • If the maximum number of VRF prefixes has exceeded the limit

Example of RIB Failure

The following figure shows a simple example of a BGP route that results in RIB Failure condition.

Figure Causes of RIB Failure
Figure Causes of RIB Failure

Route information for 192.168.1.0/24 is advertised from R2 to R1 as an OSPF route. At the same time, R2 advertises 192.168.1.0/24 route information to R1 as an IBGP route.

R1 has learned the 192.168.1.0/24 route as both an OSPF route and an IBGP route. Depending on the administrative distance, the 192.168.1.0/24 route will be registered as an OSPF route. The administrative distance for OSPF routes is 110. On the other hand, the Administrative Distance for IBGP routes is 200. As a result, the BGP route 192.168.1.0/24 is in RIB Failure.

Note that even if a route is RIB Failure, it is still the best path, and BGP routes in the RIB Failure state will be advertised to other BGP neighbors.

Specific example of RIB Failure

Consider the following network diagram, which is a specific example of a BGP route that results in a RIB Failure.

Figure Examples of RIB Failure Part 1
Figure Examples of RIB Failure Part 1

R2 advertises 192.168.1.0/24 as an OSPF route to R1. R2 also advertises 192.168.1.0/24 as an IBGP route to R1.

Excerpts of configuration

An excerpt of each router’s configuration is as follows

R1 Excerpts of configuration(Click)

hostname R1
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 172.16.13.1 255.255.255.0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 65012
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 172.16.13.3 remote-as 65003
 neighbor 192.168.0.2 remote-as 65012
 neighbor 192.168.0.2 update-source Loopback0
 neighbor 192.168.0.2 next-hop-self
 no auto-summary

R2 Excerpts of configuration(Click)

hostname R2
!
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface Loopback1
 ip address 192.168.1.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 65012
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 network 192.168.1.0
 neighbor 192.168.0.1 remote-as 65012
 neighbor 192.168.0.1 update-source Loopback0
 no auto-summary

R3 Excerpts of configuration(Click)

hostname R3
!
interface FastEthernet0/0
 ip address 172.16.13.3 255.255.255.0
!
router bgp 65003
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 172.16.13.1 remote-as 65012
 no auto-summary

Verification of RIB Failure

The IBGP route of 192.168.1.0/24 is in RIB Failure state. The show ip bgp command on R1 shows the following. Additionally, to see the RIB Failure route, the show ip bgp rib failure command can be used.

R1 Verification of RIB Failure

R1#show ip bgp
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i192.168.1.0      192.168.0.2              0    100      0 i
R1#show ip bgp 192.168.1.0
BGP routing table entry for 192.168.1.0/24, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17))
  Advertised to update-groups:
        2
  Local
    192.168.0.2 (metric 11) from 192.168.0.2 (2.2.2.2)
      Origin IGP, metric 0, localpref 100, valid, internal, best
R1#show ip bgp rib-failure
Network            Next Hop                      RIB-failure   RIB-NH Matches
192.168.1.0        192.168.0.2         Higher admin distance              n/a

The IBGP route of 192.168.1.0/24 is RIB Failure because the OSPF route has priority. In the routing table, 192.168.1.0/24 is registered as an OSPF route.

OSPF route is preferred

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.13.0 is directly connected, FastEthernet0/1
     192.168.0.0/32 is subnetted, 2 subnets
C       192.168.0.1 is directly connected, Loopback0
O       192.168.0.2 [110/11] via 192.168.12.2, 00:11:03, FastEthernet0/0
O    192.168.1.0/24 [110/11] via 192.168.12.2, 00:11:03, FastEthernet0/0

Even though RIB Failure, 192.168.1.0/24 is advertised as a BGP route from R1 to R3.

RIB Failureルートのアドバタイズ

R1#show ip bgp neighbors 172.16.13.3 advertised-routes
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i192.168.1.0      192.168.0.2              0    100      0 i

Total number of prefixes 1
R3#show ip bgp
BGP table version is 2, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0      172.16.13.1                            0 65012 i
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.13.0 is directly connected, FastEthernet0/0
B    192.168.1.0/24 [20/0] via 172.16.13.1, 00:11:07
 Figure Examples of RIB Failure Part 2
Figure Examples of RIB Failure Part 2

Summary

Point

  • RIB Failure status of a BGP route means that the best-path BGP route is not registered in the routing table.
  • The main cause of RIB Failure is that routes of other routing processes are preferred and registered in the routing table by the administrative distance.
  • Even with RIB Failure, BGP routes are advertised to other neighbors.
  • Use the show ip bgp rib-failure command to verify BGP routes that are in the RIB Failure state.