概要

シンプルなネットワークで、スタティックルートによってルーティングテーブルを作成しています。しかし、設定ミスのため通信できないところがあります。設定ミスの切り分けと修正を行います。

ネットワーク構成

図 IPルーティング基礎演習Part3 ネットワーク構成
図 IPルーティング基礎演習Part3 ネットワーク構成

ルータインタフェースIPアドレス
R1Fa0/0192.168.1.254/24
 Fa0/1192.168.0.1/24
R2Fa0/0192.168.2.254/24
 Fa0/1192.168.0.2/24
R3Fa0/0192.168.3.254/24
 Fa0/1192.168.0.3/24

初期設定

R1/R2/R3の初期設定は以下の通りです。R1とR2に設定ミスがあります。

R1 Initial Configuration

hostname R1
!
interface FastEthernet0/0
 ip address 192.168.1.250 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.0.1 255.255.255.0

ip route 192.168.2.0 255.255.255.0 192.168.0.20
ip route 192.168.3.0 255.255.255.0 192.168.0.3

R2 Initial Configuration

hostname R2
!
interface FastEthernet0/0
 ip address 192.168.2.254 255.255.255.0
 shutdown
!
interface FastEthernet0/1
 ip address 192.168.0.2 255.255.255.0
!
ip route 191.168.1.0 255.255.255.0 192.168.0.1
ip route 192.168.3.0 255.255.255.0 192.168.0.3

R3 Initial Configuration

hostname R3
!
interface FastEthernet0/0
 ip address 192.168.3.254 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.0.3 255.255.255.0
!
ip route 192.168.1.0 255.255.255.0 192.168.0.1
ip route 192.168.2.0 255.255.255.0 192.168.0.2

設定ミスの内容

R1

Fa0/0 IPアドレス

R1 Fa0/0のIPアドレスが誤って設定されています。

R1 show ip interface brief

---------------------
R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.250   YES NVRAM  up                    up
FastEthernet0/1            192.168.0.1     YES NVRAM  up                    up

R1 Fa0/0の正しいIPアドレスは192.168.1.254/24です。

R1 IPアドレスの修正

interface FastEthernet0/0
 ip address 192.168.1.254 255.255.255.0

スタティックルートのネクストホップ

192.168.2.0/24のスタティックルートのネクストホップが誤って設定されています。

R1 show running-config | include iproute / show ip route static

R1#show running-config | include ip route
ip route 192.168.2.0 255.255.255.0 192.168.0.20
ip route 192.168.3.0 255.255.255.0 192.168.0.3
R1#show ip route static
S    192.168.2.0/24 [1/0] via 192.168.0.20
S    192.168.3.0/24 [1/0] via 192.168.0.3

192.168.2.0/24のネクストホップは192.168.0.2です。

R1 ネクストホップの修正

ip route 192.168.2.0 255.255.255.0 192.168.0.2
no ip route 192.168.2.0 255.255.255.0 192.168.0.20

R2

Fa0/0 shutdown

Fa0/0のshutdownが解除されていません。

R2 show ip interface brief

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.2.254   YES NVRAM  administratively down down
FastEthernet0/1            192.168.0.2     YES NVRAM  up                    up

利用するインタフェースは必ずno shutdownで有効化します。

R2 no shutdown

int fa 0/0
 no shutdown

スタティックルートのネットワークアドレス

192.168.1.0/24ではなく191.168.1.0/24のスタティックルートが設定されています。

R2 show running-config | include ip route / show ip route static

R2#show running-config | include ip route
ip route 191.168.1.0 255.255.255.0 192.168.0.1
ip route 192.168.3.0 255.255.255.0 192.168.0.3
R2#show ip route static
     191.168.0.0/24 is subnetted, 1 subnets
S       191.168.1.0 [1/0] via 192.168.0.1
S    192.168.3.0/24 [1/0] via 192.168.0.3

正しいネットワークアドレス「192.168.2.0/24」のスタティックルートを設定します。

R2 ネットワークアドレスの修正

ip route 192.168.1.0 255.255.255.0 192.168.0.1
no ip route 191.168.1.0 255.255.255.0 192.168.0.1

設定ミスのまとめ

図  図 IPルーティング基礎演習Part3 設定ミスのまとめ
図 図 IPルーティング基礎演習Part3 設定ミスのまとめ

IPルーティングのキホン