CCIE Routing & Switching Trouble Shooting 攻略 Part1 TT06 (v4向け)

※ ネットワーク構成は↓よりご覧ください。
http://www.n-study.com/network/2015/05/ccie_routing_switching_trouble_1.html

問題

6.Host4とHost5の通信ができません。Host4とHost5の通信ができるようにしてください。

トラブルの解決

R7
----
router ospf 1
area 1 virtual-link 9.9.9.9 message-digest-key 1 md5 C?sco
----
R9
----
interface Ethernet0/0
no shutdown
!
interface Serial1/0
no ppp chap hostname
!
router ospf 1
no area 1 virtual-link 10.7.9.7 message-digest-key 1
area 1 virtual-link 7.7.7.7 message-digest-key 1 md5 C?sco
----

トラブルの症状と原因、切り分け

表 トラブルの症状と原因、切り分け(No.6)
CCIE_TS_Part1_11.png

【R7-R9間のPPPリンクでCHAP認証に失敗している】

R7-R9間のPPPリンクでは、CHAP認証を行っています。CHAP認証では、デフォルトでルータのホスト名をユーザ名として利用します。しかし、R9 S1/0でppp chap hostnameコマンドでユーザ名を変更しています。その結果、対向のR7で設定しているユーザ名と不一致になり、CHAP認証に失敗します。R9のCHAPユーザ名をデフォルトにします。

R9
----
interface Serial1/0
no ppp chap hostname
----

【R9 E0/0がShutdownされている】

R9 E0/0がShutdownされているためR8とOSPFネイバーを確立できません。R9 E0/0を有効化します。

R9
----
interface Ethernet0/0
no shutdown
----

【R7でVirtual-link上の認証パスワードが設定されていない】

Virtual-linkはエリア0のインタフェースなので、MD5認証を行います。しかし、R7でVirtual-link上で利用するパスワードの設定が行われていません。そのため、Virtual-linkが確立できません。R7のVirtual-link上で認証パスワードの設定を行います。

R7
----
router ospf 1
area 1 virtual-link 9.9.9.9 message-digest-key 1 md5 C?sco
----

【R9でVirtual-linkのルータIDの指定が間違っている】

Virtual-linkの設定は、対向のルータのルータIDを指定します。しかし、R9のVirtual-linkの設定を確認すると、R7のルータIDではなくR7のS1/2のIPアドレスを指定しています。R9のVirtual-linkの設定を修正して、R7のルータIDを指定するようにします。

R9
----
router ospf 1
no area 1 virtual-link 10.7.9.7 message-digest-key 1
area 1 virtual-link 7.7.7.7 message-digest-key 1 md5 C?sco
----

CCIE_TS_Part1_12.png
図 トラブルの症状と原因、切り分け(No.6)

トラブル仕込み

R7
----
router ospf 1
no area 1 virtual-link 9.9.9.9 message-digest-key 1
area 1 virtual-link 9.9.9.9
----
R9
----
interface Ethernet0/0
shutdown
!
interface Serial1/0
ppp chap hostname R99
!
router ospf 1
no area 1 virtual-link 7.7.7.7 message-digest-key 1
area 1 virtual-link 10.7.9.7 message-digest-key 1 md5 cisco
----

Follow me!