レイヤ3スイッチの考え方と設定 Catalystスイッチでの設定例

設定するトポロジ

前回、レイヤ2/レイヤ3スイッチを使った典型的なLANの構成について、ご紹介しました。その典型的なLANの構成を実際にCisco Catalystスイッチで設定してみます。

設定は、次の図のようにクライアントコンピュータ用にVLAN100とVLAN200、レイヤ2スイッチの管理用のVLANとしてVLAN1000を作ります。ディストリビューションスイッチとコアスイッチの間はポイントツーポイントでそれぞれネットワークを分割する構成です。

アクセススイッチの設定

アクセススイッチの設定は、

  • VLANの作成
  • アクセスポート、トランクポートの設定
  • 管理用のIPアドレスの設定

が必要です。

デフォルトではVLAN1のみなので、クライアントコンピュータ用と自身の管理用VLANを新しく作成します。そのためには、グローバルコンフィグレーションモードで次のようにコマンドを入力します。

ASW1(config)#vlan 100,200,1000

そうすると、ASW1の内部に新しくVLANが作成されます。VLANを作成したら、そのVLANにポートを割り当てないと意味がありません。PC1をVLAN100に接続する構成なのでPC1が接続されているFa0/1をVLAN100に接続します。そのためには、次の設定です。

ASW1(config)#interface fastehternet0/1
ASW1(config-if)#swithcport mode access
ASW1(config-if)#switchport access vlan 100

swithcport mode accessのコマンドは、このポートが明示的なアクセスポートであるという設定です。今回の構成では、必須ではありませんが、明示的にアクセスポートであると設定したわかりやすくなります。switchport access vlan 100のコマンドでFa0/1をVLAN100に接続するというイメージです。

同様にPC2をVLAN200に接続するため、PC2が接続されているFa0/2をVLAN200に接続します。

ASW1(config)#interface fastehternet0/2
ASW1(config-if)#swithcport mode access
ASW1(config-if)#switchport access vlan 200

また、ASW1自体にPingやTelnetに応答できるように管理上のVLAN1000のIPアドレスを設定します。ASW1の内部のTCP/IPスタックは物理的なポートに接続されているわけではありません。ASW1内部でTCP/IPスタックを論理的にVLAN1000に接続するには、レイヤ3スイッチでのSVI作成と同じように次のように設定してください。

ASW1(config)#interface vlan 1000
ASW1(config-if)#ip address 10.1.0.1 255.255.255.0

レイヤ3スイッチのSVI作成と同じコマンドですが、これは、ASW1のTCP/IPスタックをVLAN1000に接続するものだと考えてください。

これで、PC1はVLAN100にPC2はVLAN200に接続されたので、PC1とPC2はデータリンク層レベルで直接通信できなくなります。ASW1のTCP/IPスタックもVLAN1000に接続されているため、PC1やPC2と直接通信できなくなります。
PC1とPC2、ASW1が通信をする際は、DSW1もしくはDSW2でIPルーティングを行います。DSW1/DSW2がルーティングを行えるようにASW1からDSW1/DSW2にVLAN100とVLAN200とVLAN1000のフレームを転送しなければいけません。

そこで、ASW1とDSW1/DSW2を接続するGi0/1とGi0/2をトランクポートにし、VLAN100/VLAN200/VLAN1000のフレームを1本のリンクで多重化して転送できるようにします。そのための設定は次のようになります。Gi0/1とGi0/2の設定は同じなので、rangeを使います。

ASW1(config)#interface range gi 0/1 -2
ASW1(config-if-range)#switchport trunk encapsulation dot1q
ASW1(config-if-range)#switchport mode trunk

switchport trunk encapsulationコマンドでトランクカプセル化プロトコルをIEEE802.1Qに指定しています。ただ、モデルによってはこのコマンドがサポートされていないことがあります。このコマンドをサポートしていないモデル(Catalyst2950など)は、IEEE802.1Qのみをサポートしているからです。そして、switchport mode trunkで明示的にトランクポートの設定を行っています。

これでASW1の設定は終了です。この時点で、ASW1の内部のVLANとポートの接続の様子を考えると次の図のようになります。

ディストリビューションスイッチの設定

アクセススイッチからやって来たフレームにはIPパケットが入っています。これをルーティングするのがディストリビューションスイッチの仕事です。構成例のようにディストリビューションスイッチを冗長化している場合は、設定はほとんど同じです。ですから、DSW1を中心に設定を解説します。

設定するべき内容は、

  • VLANの作成
  • アクセススイッチからのフレームを受信するためのトランクポートの設定
  • 異なるVLANのIPパケットをルーティングするためのSVI、ルーテッドポートの設定

です。

アクセスポートが転送したイーサネットフレームは、DSW1のGi0/1に入ってきます。複数のVLANが多重化されているので、DSW1のGi0/1もトランクポートにしなければいけません。ただし、その前に、VLANを作らなければいけません。スイッチにVLANがない状態で、そのVLANあてのフレームがやってくると破棄されてしまいます。今回は、VLAN100/200/1000が存在するので、DSW1でもこれらのVLANを作る必要があります。

DSW1(config)#vlan 100,200,1000

そして、Gi0/1をトランクポートに設定します。

DSW1(config)#interface gi 0/1
DSW1(config-if)#switchport trunk encapsulation dot1q
ASW1(config-if)#switchport mode trunk

これにより、ASW1から受信したイーサネットフレームのIEEE802.1Qタグを見て、DSW1の中で適切なVLANにフレームを振り分けることができます。さらに、異なるVLAN間でルーティングするためには、DSW1の内部で各VLANに応じたSVIを作りVLANに対応したネットワークアドレスからIPアドレスを設定し
ます。
つまり、今回の構成では、VLAN100、VLAN200、VLAN1000に対応するSVIを作り、IPアドレスを設定します。

DSW1(config)#interface vlan 100
DSW1(config-if)#ip address 10.1.100.253 255.255.255.0
DSW1(config-if)#exit
DSW1(config)#interface vlan 200
DSW1(config-if)#ip address 10.1.200.253 255.255.255.0
DSW1(config-if)#exit
DSW1(config)#interface vlan 1000
DSW1(config-if)#ip address 10.1.0.253 255.255.255.0
DSW1(config-if)#exit

そして、コアスイッチ(Core)とはポイントツーポイントで接続されているので、SVIではなくルーテッドポートにします。Coreと接続されているGi0/2をルーテッドポートにしてIPアドレスを設定します。

DSW1(config)#interface gigabitethernet0/2
DSW1(config-if)#no switchport
DSW1(config-if)#ip address 172.16.0.1 255.255.255.252

以上の設定によって、DSW1はVLAN100、VLAN200、VLAN1000のSVIとGi0/2のルーテッドポート間でIPパケットをルーティングできるようになります。この時点での、DSW1の内部ルータ、VLAN、ポートの内部的な接続の様子は次の図の通りです。

なお、DSW2の設定は、IPアドレスのホスト部分が変わる以外はDSW1と同じです。

コアスイッチの設定

コアスイッチ、CoreではDSW1/DSW2のルーテッドポートから送られてきたIPパケットをルーティングできるようにします。そのために、2つのルーテッドポートを作成します。
DSW1が接続されているGi0/1で次のようにルーテッドポートにして、IPアドレスの設定をします。

Core(config)#interface gigabitethernet0/1
Core(configif)#no switchport
Core(configif)#ip address 172.16.0.2 255.255.255.252

同様にDSW2が接続されているGi0/2でも設定します。

Core(config)#interface gigabitethernet0/1
Core(configif)#no switchport
Core(configif)#ip address 172.16.0.6 255.255.255.252

Coreでは、ルーテッドポートで内部ルータとポートを直結しているので、VLANを作成する必要はありません。ルーテッドポートで内部ルータと直結している場合は、ルータと同じと考えればいいです。

この時点でのCoreの内部ルータとポートの接続は次の図のようになります。

上記のアクセススイッチ、ディストリビューションスイッチ、コアスイッチの設定はあくまでも一例です。スイッチを利用した典型的なLANの構成のメリットは、物理構成を変更しなくてもネットワークの設計者が好きなように論理構成を作り上げられることでえす。その場合も、各スイッチにおいて、内部的にポートやVLAN、内部ルータをどのように接続すればいいかを考えて設定すれば、すっきりと理解できるようになるでしょう。

Follow me!