CCIE R&S Configuration Part1 2.7 BGP

2.7.BGP

  • SW1、SW2、R3、R5でBGP AS1を構成します。BGPネイバーはすべてのLoopback0を利用します。また、next-hop-selfの設定をしてはいけません。必要ならば、BB1-SW1間、BB2-SW2間のリンクをOSPFの外部ルートとしてアドバタイズしても構いません。
  • SW1-BB1(AS254)、SW2-BB2(AS254)間でBGPネイバーを確立します。
  • AS1内ではAS_PATHによってベストパスが決定されないようにしてください。
  • R3はAS254へパケットを送信するときにはSW1を利用し、R5はAS254へパケットを送信するときはSW2を利用するようにしてください。
  • SW1、SW2はAS1内の「168」ではじまるルートを集約した集約ルート1つのみをBB1、BB2へアドバタイズしてください。

 

【設定】

R3

---------------------------------------------------------------------------------
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.5.5 remote-as 1
 neighbor 192.168.5.5 update-source Loopback0
 neighbor 192.168.6.6 remote-as 1
 neighbor 192.168.6.6 update-source Loopback0
 neighbor 192.168.6.6 weight 1000
 neighbor 192.168.7.7 remote-as 1
 neighbor 192.168.7.7 update-source Loopback0
 no auto-summary
---------------------------------------------------------------------------------

 

R5

---------------------------------------------------------------------------------
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.3.3 remote-as 1
 neighbor 192.168.3.3 update-source Loopback0
 neighbor 192.168.6.6 remote-as 1
 neighbor 192.168.6.6 update-source Loopback0
 neighbor 192.168.7.7 remote-as 1
 neighbor 192.168.7.7 update-source Loopback0
 neighbor 192.168.7.7 weight 1000
 no auto-summary
---------------------------------------------------------------------------------

 

SW1

---------------------------------------------------------------------------------
router ospf 1
 redistribute connected subnets route-map BB1-Link
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 192.168.6.6 mask 255.255.255.255
 aggregate-address 192.168.0.0 255.255.0.0 summary-only
 neighbor 150.1.1.254 remote-as 254
 neighbor 192.168.3.3 remote-as 1
 neighbor 192.168.3.3 update-source Loopback0
 neighbor 192.168.5.5 remote-as 1
 neighbor 192.168.5.5 update-source Loopback0
 neighbor 192.168.7.7 remote-as 1
 neighbor 192.168.7.7 update-source Loopback0
 no auto-summary
!
route-map BB1-Link permit 10
 match interface FastEthernet0/9
---------------------------------------------------------------------------------

 

SW2

---------------------------------------------------------------------------------
router ospf 1
 redistribute connected subnets route-map BB2-Link
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 192.168.7.7 mask 255.255.255.255
 aggregate-address 192.168.0.0 255.255.0.0 summary-only
 neighbor 150.2.2.254 remote-as 254
 neighbor 150.2.2.254 route-map Add_AS in
 neighbor 192.168.3.3 remote-as 1
 neighbor 192.168.3.3 update-source Loopback0
 neighbor 192.168.5.5 remote-as 1
 neighbor 192.168.5.5 update-source Loopback0
 neighbor 192.168.6.6 remote-as 1
 neighbor 192.168.6.6 update-source Loopback0
 no auto-summary
!
route-map Add_AS permit 10
 set as-path prepend 253
!
route-map BB2-Link permit 10
 match interface FastEthernet0/9
---------------------------------------------------------------------------------

 

【確認のポイント】

  • show ip bgp summary
    BGPネイバーが正常に確立できていることを確認します。
  • show ip bgp
    R3でAS254のルートのベストパスがSW1から受信しているルートであることを確認します。R5ではAS254のルートのベストパスがSW2から受信しているルートであることを確認します。
    SW1、SW2で168.0.0/16の集約ルートを生成していることを確認します。

 

【解説】

R3、R5、SW1、SW2でAS1を構成しています。AS1内はIBGPネイバーをフルメッシュで設定します。

 

  • ルートリフレクタやコンフェデレーションの設定でも問題ありません。

 

next-hop-selfの設定は禁止されていますが、BB1やBB2のIPアドレスに対する接続性は、OSPFへの再配送で確保することができます。

BB1、BB2からは同じルートがアドバタイズされていますが、AS_PATHが異なります。

 

BB1→SW1

197.68.1.0   254 253
197.68.4.0   254 253
197.68.5.0   254 253
197.68.21.0  254 253
197.68.22.0  254 253

BB2→SW2

197.68.1.0   254
197.68.4.0   254
197.68.5.0   254
197.68.21.0  254
197.68.22.0  254

AS_PATHでベストパスが決定されないようにするために、SW2でAS_PATHをプリペンドして、AS_PATH長を同じ長さにします。SW2でのAS_PATHプリペンとの設定は次の通りです。

 

SW2

---------------------------------------------------------------------------------
router bgp 1
 neighbor 150.2.2.254 route-map Add_AS in
!
route-map Add_AS permit 10
 set as-path prepend 253
---------------------------------------------------------------------------------

 

R3、R5でのパス選択は、ルータローカルでの制御となります。R3ではSW1に対してWeightを高く設定します。また、R5ではSW2に対してWeightを高く設定します。これにより、R3はAS254のルートへパケットをルーティングするときはSW1を優先し、R5はSW2を優先します。

 

R3

---------------------------------------------------------------------------------
router bgp 1
 neighbor 192.168.6.6 weight 1000
---------------------------------------------------------------------------------

 

R5

---------------------------------------------------------------------------------
router bgp 1
 neighbor 192.168.7.7 weight 1000
---------------------------------------------------------------------------------

 

そして、SW1、SW2ではBB1、BB2へ集約ルート192.168.0.0/16のみをアドバタイズします。集約ルートを生成するために、集約の範囲内に含まれるルートをBGPテーブルに生成したうえで、aggregate-addressコマンドを利用します。

 

SW1

---------------------------------------------------------------------------------
router bgp 1
 network 192.168.6.6 mask 255.255.255.255
 aggregate-address 192.168.0.0 255.255.0.0 summary-only
---------------------------------------------------------------------------------

 

SW2

---------------------------------------------------------------------------------
router bgp 1
 network 192.168.7.7 mask 255.255.255.255
 aggregate-address 192.168.0.0 255.255.0.0 summary-only
---------------------------------------------------------------------------------

 

CCIE_CFG_Part1_18

図 BGPの設定まとめ

 

 

Follow me!