CCNP BSCI 旧バージョン(640-901J)の模擬問題 No.96~No.100

Table of Contents

問題

No.96

以下の条件に基づいて、図のルータAの設定をしてください。

・ルーティングプロトコルはEIGRPで、AS番号は100
・E0/0とS0/0でEIGRPを有効にする。ただし、コマンドは1行で
・S0/0でのHello間隔を30秒に設定する
・自動集約は無効にする


No.97

以下の図で、ルータAにおいてRIPとEIGRPのリディストリビューションの設定をしてください。


No.98

ルータAで、ルータBとのEBGPピアの設定をしてください。ただし、ピアのアドレスとしてお互いのループバックアドレスを利用してください。

ルータA、ルータB、ルータCはフレームリレーネットワークに接続されています。フレームリレーのトポロジは、ルータAを中心とするハブ&スポーク型です。
このフレームリレーネットワークでOSPFによってルータAのループバックインタフェースをルータBとルータCにアドバタイズする設定を行ってください。


No.100

IGRPのルートのアドミニストレイティブディスタンスを115にするための設定を行ってください。AS番号は100とします。

解答と解説

No.96

【解答】

router eigrp 100
network 192.168.0.0 0.0.255.255
no auto-summary
interface serial 0/0
ip hello-interval eigrp 100 30

【解説】
EIGRPは、「router eigrp 」コマンドでプロセスが起動します。EIGRPを有効にするインタフェースを指定するには、他のルーティングプロトコルと同様に「network」コマンドを使います。

EIGRPでの「netowrk」コマンドはクラスフルな境界で指定することもできますし、OSPFと同じく、ワイルドカードマスクによって、より詳細なインタフェースの指定ができます。

この問題では、E0/0とS0/0で有効にするのですが、コマンドを1行と条件が付いているので、

network 192.168.0.0 0.0.255.255

と入力します。これにより先頭が「192.168」で始まるすべてのインタフェースでEIGRPが有効になります。またデフォルトの自動集約を無効にするには、

no auto-summary

を入力します。

OSPFと同じくEIGRPもHelloによるネイバーの発見、維持を行います。LANや1.5M以上の高速なWANインタフェースでは5秒ごと、1.5M以下のWANインタフェースでは、60秒ごとにHelloパケットをやり取りします。そのデフォルトのHelloの間隔を変更するにはインタフェースで、

ip hello-interval eigrp

のコマンドです。
ある一定時間Helloパケットを受け取らないと、ネイバーがダウンしたとみなされます。その間隔をHold Downと呼んでいます。Hold Downはデフォルトでは、Helloの3倍なのですが、コマンドで変更することもできます。コマンドはインタフェースで、

ip hold-time eigrp

を入力します。
OSPFの場合はHelloを変えると、自動的にDeadも変わっていたのですが、EIGRPの場合はHelloを変えても自動的にHold Downは変わりません。


No.97

【解答】

router rip
network 172.16.0.0
redistribute eigrp 100
default-metric 4
passive-interface ethernet 0/1
router eigrp 100
network 172.16.2.0 0.0.0.255
redistribute rip
default-metric 10000 10 255 1 1500

【解説】
リディストリビューションは、それぞれのルーティングプロセスの中で設定します。その場合、注意しなくてはいけないことがシードメトリックを必ず指定するということです。シードメトリックとは、リディストリビュートしたルートに与えられるメトリックです。OSPF、BGP以外のルーティングプロセスではシードメトリックを指定しないと、ルートが流れません。

RIPの場合は、

default-metric 4

で、リディストリビュートしたEIGRPのルートにホップカウント4をシードメトリックとして与えています。

EIGRPでは、

default-metric 10000 10 255 1 1500

で、リディストリビュートしたRIPのルートに複合メトリックを計算する要素を指定しています。帯域幅、遅延、信頼性、負荷、MTUという順番で指定します。


No.98

【解答】

router bgp 100
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 update-source loopback 0
neighbor 2.2.2.2 ebgp-multihop 

【解説】

EBGPピアは通常、ピアと物理的に直接接続されているインタフェースを利用してピアを確立します。しかし、なんらかの理由で直接接続されているインタフェース以外をピアのアドレスとする場合は気をつけてください。

EBGPピアへ送信されるHelloメッセージは、IPヘッダの中のTTLフィールドが1になっているのです。直接接続のインタフェースならTTLが1でも構いませんが、他のインタフェースのアドレスならば、ルータがルーティングするのでTTLが減らされてパケットが捨てられてしまいます。そのため、EBGPピアを直接接続のインタフェース以外で確立するためには、

neighbor 2.2.2.2 ebgp-multihop

というコマンドが必要です。ebgp-multihopは、IPヘッダのTTLフィールドの値を変更することができます。特に何も指定しなければ、TTLを255に変更することになります。


No.99

【解答】

interface loopback 0
ip ospf network point-to-point
interface serial 0/0
ip ospf priority 255
router ospf 100
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
neighbor 192.168.2.2
neighbor 192.168.2.3 

【解説】
フレームリレーのようなNBMAネットワークで、しかもPVCがハブ&スポーク型トポロジになっている場合は、さまざまなルーティングプロトコルの設定において注意しなければいけないことがあります。

OSPFは、NBMAネットワークではDRの選定が必要です。DRの条件としては、その他のOSPFルータと直接通信できなくてはいけません。とすると、ハブ&スポーク型トポロジにおいては、必然的にハブルータがDRにならないといけないのです。

DRは、OSPFプライオリティによって決まります。ハブルータ、つまり、ルータAをNBMAネットワークのDRとするためには、

interface serial 0/0
ip ospf priority 255

で、Serial0/0インタフェースのOSPFプライオリティを高い値に設定します。あと、それとルータBやルータCで

interface serial 0/0
ip ospf priority 0

としておくといいでしょう。プライオリティ0は、DR/BDRに絶対にならないということを意味しています。

そして、DRとなったルータAで直接ネイバーの指定を行います。NBMAは、ブロードキャスト機能がありません。ブロードキャストだけでなくマルチキャストも通せないのです。OSPFは224.0.0.5、224.0.0.6というマルチキャストアドレスを利用してネイバーの発見やLSAの交換を行っています。ユニキャストは通すことができるので、マルチキャストのOSPFアドレスをネイバーにユニキャストで送るために、

neighbor 192.168.2.2
neighbor 192.168.2.3

コマンドでNBMAネットワーク上のネイバーを直接指定します。このコマンドは片方向だけ設定すればOKです。

あと、この問題の条件には直接関係しませんが、OSPFはループバックのネットワークアドレスを/32のホストルートとして送ります。これは、RFCにも規定されていることなのですが、論理的なインタフェースは/32で送るということがOSPFの仕様になっています。

これをサブネットマスクを反映したネットワークアドレスにするためには、

interface loopback 0
ip ospf network point-to-point

というコマンドを入力すればいいです。


No.100

【解答】

router igrp 100
distance 115

【解説】
ルーティングプロトコルごとにアドミニストレイティブディスタンスのデフォルト値が決まっています。デフォルト値を使っていると、リディストリビューションによって、ルーティングループが発生したり、最適ではない経路選択を行ってしまうことがあります。

アドミニストレイティブディスタンスを変更するには、各ルーティングプロセスで、「distance」コマンドを使います。

単純に「distance」コマンドを使った場合には、そのルーティングプロトコルで学習したすべてのルートのアドミニストレイティブディスタンスを変えてしまいます。「distance」コマンドのあとに、さらにネイバーのアドレスやアクセスリスト番号と関連付けることによって、より細かくアドミニストレイティブディスタンス値を制御することができるようになります。でも、これはCCIEレベルなのでBSCIの試験には必要ないのでご安心を・・・

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA