CCIE R&S Configuration Part1 2.5 IPv6

2.5.IPv6

  • IPv6構成図のように必要な機器の必要なインタフェースにIPv6アドレスを設定してください。
  • SW1、SW2のみトンネルインタフェースを作成してもかまいません。ただし、トンネルインタフェースには明示的にIPv6アドレスを設定してはいけません。
  • OSPFv3によって、IPv6ネットワークの通信ができるようにしてください。

 

【設定】

R2

---------------------------------------------------------------------------------
ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:1:1:FFFF::2/128
 ipv6 address FE80::2 link-local
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2 native
 ipv6 address 2001:1:1:2::2/64
 ipv6 address FE80::2 link-local
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0.26
 encapsulation dot1Q 26
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ipv6 address 2001:1:1:26::2/64
 ipv6 address FE80::2 link-local
 ipv6 ospf 1 area 0
!
interface Virtual-Template1
 ipv6 address 2001:1:1:23::2/64
 ipv6 address FE80::2 link-local
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
---------------------------------------------------------------------------------

 

R3

---------------------------------------------------------------------------------
ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:1:1:FFFF::3/128
 ipv6 address FE80::3 link-local
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 ipv6 address 2001:1:1:3::3/64
 ipv6 address FE80::3 link-local
 ipv6 ospf 1 area 0
!
interface Virtual-Template1
 ip ospf hello-interval 1
 ip ospf 1 area 0
 ipv6 address 2001:1:1:23::3/64
 ipv6 address FE80::3 link-local
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
---------------------------------------------------------------------------------

 

SW1

---------------------------------------------------------------------------------
ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:1:1:FFFF::6/128
 ipv6 address FE80::6 link-local
 ipv6 ospf 1 area 0
!
interface Tunnel0
 no ip address
 ipv6 unnumbered Loopback0
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source Loopback0
 tunnel destination 192.168.7.7
 tunnel mode ipv6ip
!
interface Vlan26
 ip address 192.168.0.98 255.255.255.224
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ipv6 address 2001:1:1:26::6/64
 ipv6 address FE80::6 link-local
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
---------------------------------------------------------------------------------

SW2

---------------------------------------------------------------------------------
ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:1:1:FFFF::7/128
 ipv6 address FE80::7 link-local
 ipv6 ospf 1 area 0
!
interface Tunnel0
 no ip address
 ipv6 unnumbered Loopback0
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source Loopback0
 tunnel destination 192.168.6.6
 tunnel mode ipv6ip
!
interface Vlan234
 ipv6 address 2001:1:1:7::7/64
 ipv6 address FE80::7 link-local
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
---------------------------------------------------------------------------------

 

【確認のポイント】

  • show ipv6 interface brief
    IPv6アドレスが正しく設定されていることを確認します。
  • show ipv6 ospf neighbor
    OSPFv3ネイバーが正しく確立できていることを確認します。
  • show ipv6 route
    IPv6ルーティングテーブルに必要なルート情報が登録されていることを確認します。

【解説】

Catalystスイッチ実機でIPv6の設定を行うときには、次の手順が必要になるので注意してください。

(config)#sdm prefer dual-ipv4-and-ipv6 default
(config)#end
#reload

参考:SDMテンプレートの設定

http://www.cisco.com/japanese/warp/public/3/jp/service/manual_j/sw/cat30/3560scg1/chapter07/8553_01_7.pdf

IPv6アドレスの設定は、禁止されていなければリンクローカルアドレスをわかりやすいスタティックの設定にした方がよいです。ただし、問題文の条件で禁止されていたり、インタフェースIDをEUI-64形式でダイナミックに生成する場合は、リンクローカルアドレスをスタティックに設定できません。今回の条件は、特に禁止していないので、リンクローカルアドレスをスタティックに設定します。

各機器で設定するべきIPv6アドレスをまとめものが次の表と図です。

 

表 3 IPv6アドレス

機器 インタフェース IPv6アドレス
R2 Loopback0 2001:1:1:FFFF::2/128
FE80::2
Fa0/0.26 2001:1:1:26::2/64
FE80::2
Fa0/0.2 2001:1:1:2::2/64
FE80::2
Virtual-Templete1 2001:1:1:23::2/64
FE80::2
R3 Loopback0 2001:1:1:FFFF::3/128
FE80::3
Fa0/0 2001:1:1:3::3/64
FE80::3
Virtual-Templete1 2001:1:1:23::3/64
FE80::3
SW1 Loopback0 2001:1:1:FFFF::6/128
FE80::6
VL26 2001:1:1:26::6/64
FE80::6
Tunnel0 Uunumbered(loopback0)
FE80:: C0A8:606
SW2 Loopback0 2001:1:1:FFFF::7/128
FE80::7
VL234 2001:1:1:7::7/64
FE80::7
Tunnel0 Uunumbered(loopback0)
FE80:: C0A8:707

 

CCIE_CFG_Part1_13

図  IPv6アドレス

 

SW1-SW2間のTunnelインタフェースをどのように設定するかがポイントです。IPv6アドレスは6to4のアドレスではないので、6to4トンネルは利用できません。また、離れたIPv6ネットワークを接続するためのトンネルなので、ISATPトンネルを利用できません。そのため、SW1-SW2間はスタティックトンネルを利用することになります。

SW1とSW2でのスタティックトンネルの設定は、次の通りです。

SW1

---------------------------------------------------------------------------------
interface Tunnel0
 no ip address
 ipv6 unnumbered Loopback0
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source Loopback0
 tunnel destination 192.168.7.7
 tunnel mode ipv6ip
---------------------------------------------------------------------------------

 

SW2

---------------------------------------------------------------------------------
interface Tunnel0
 no ip address
 ipv6 unnumbered Loopback0
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source Loopback0
 tunnel destination 192.168.6.6
 tunnel mode ipv6ip
---------------------------------------------------------------------------------

 

SW1、SW2でお互いのLoopback0のIPv4アドレスへの接続性があれば、Tunnel0インタフェースがup/upの状態になります。そして、Tunnel0インタフェースのリンクローカルアドレスはFE80::[tunnel-sourceのIPv4アドレス]となります。また、明示的にIPv6アドレスを設定してはいけないので、ipv6 unnumberedコマンドでLoopback0のIPv6アドレスを利用するようにしています。

SW1でshow ipv6 interface tunnel0をみると、次のようになります。

 

SW1 show ipv6 interface tunnel0

---------------------------------------------------------------------------------
SW1#show ipv6 interface tunnel 0
Tunnel0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::C0A8:606
Interface is unnumbered. Using address of Loopback0
No global unicast address is configured
Joined group address(es):
FF02::1
FF02::2
FF02::5
FF02::1:FFA8:606
MTU is 1480 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
Hosts use stateless autoconfig for addresses.
---------------------------------------------------------------------------------

 

このようなIPv6ネットワークでOSPFv3でルーティングできるように設定します。条件では、エリアの指定は特にありません。シングルエリアのシンプルな構成でOSPFv3の設定を行います。OSPFv3の設定手順は、次のようになります。

 

  1. OSPFプロセスの有効化
    (config)#ipv6 router ospf <process>
    (config-rtr)#router-id <id>
  2. インタフェースでOSPFv3の有効化
    (config-if)#ipv6 ospf <process> area <area-id>

 

フレームリレーのインタフェースでネットワークタイプがNon Broadcastになっている場合は、さらにネイバーの指定が必要です。Non Broadcastのネットワーク上でネイバーを指定する場合は、インタフェースコンフィグレーションモードで次のコマンドを利用します。

 

(config-if)#ipv6 ospf neighbor <ipv6-address>

 

ここで指定するIPv6アドレスはネイバーのリンクローカルアドレスになることに注意してください。

今回の条件では、R2-R3間のフレームリレーネットワークはPPPoFRでPoint-to-pointのネットワークタイプになるので、ネイバーの指定は不要です。

OSPFv3で正しくルーティングできているかどうかは、IPv4でのOSPFと同様にネイバーが正常に確立できているかなどで確認してください。

SW1でOSPFv3ネイバーやIPv6ルーティングテーブルをみると、次のようになります。

SW1 show ipv6 ospf neighbor/show ipv6 route

---------------------------------------------------------------------------------
SW1#show ipv6 ospf neighbor
 
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/DR         00:00:35    13              Vlan26
7.7.7.7           1   FULL/  -        00:00:38    23              Tunnel0
SW1#show ipv6 route ospf
IPv6 Routing Table - 11 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   2001:1:1:2::/64 [110/2]
via FE80::2, Vlan26
O   2001:1:1:3::/64 [110/3]
via FE80::2, Vlan26
O   2001:1:1:7::/64 [110/11112]
via FE80::C0A8:707, Tunnel0
O   2001:1:1:FFFF::2/128 [110/1]
via FE80::2, Vlan26
O   2001:1:1:FFFF::3/128 [110/2]
via FE80::2, Vlan26
O   2001:1:1:FFFF::7/128 [110/11111]
via FE80::C0A8:707, Tunnel0
---------------------------------------------------------------------------------

Follow me!