概要

RIPngとOSPFv3を組み合わせたIPv6ルーティングを行う演習です。IPv6ルーティングの基本的な考え方は、IPv4ルーティングと同じです。

ネットワーク構成

図 [演習] IPv6ルーティング RIPng&OSPFv3 ネットワーク構成
図 [演習] IPv6ルーティング RIPng&OSPFv3 ネットワーク構成

設定条件

  • R1、R3 E0/0はIPv4のみ有効です。R1、R3でトンネルインタフェースを作成して、分断されているIPv6ネットワークを接続します。トンネルインタフェースでは、IPv6パケットを直接IPv4でカプセル化します。
  • 図のとおりIPv6グローバルユニキャストアドレスを設定します。R4 E0/0は明示的にIPv6アドレスを設定しません。また、各ルータのリンクローカルアドレスはFE80::X(X=ルータ番号)とします。
  • 図のとおりRIPng、OSPFv3を設定します。R1でRIPngとOSPFv3の双方向再配送を行います。OSPFv3ルータIDは、X.X.X.X(X=ルータ番号)とします。

初期設定

  • ホスト名
  • R1-R3間のIPv4アドレス

R1 Initial Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.13.1 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R2 Initial Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R3 Initial Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.13.3 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R4 Initial Configuration

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 half-duplex
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

設定

Step1:スタティックトンネルの設定

R1、R3間でスタティックトンネルを作成して、分断されたIPv6ネットワークを相互接続できるようにします。tunnel sourceコマンド、tunnel destinationコマンドで新しく付加するIPヘッダの宛先/送信元IPアドレスを決めます。

R1 スタティックトンネルの設定

interface Tunnel13
 tunnel source Ethernet0/0
 tunnel destination 192.168.13.3

R3 スタティックトンネルの設定

interface Tunnel13
 tunnel source Ethernet0/0
 tunnel destination 192.168.13.1

トンネルインタフェースでIPv6パケットを送受信するには、IPv6アドレスが必要です。IPv6アドレスの設定は次のStepで行います。tunnel modeの設定も次のStepで行います。

Step2:IPv6アドレスの設定

各ルータでIPv6ルーティングを有効化し、ネットワーク構成のとおりにIPv6リンクローカルアドレス、グローバルユニキャストアドレスを設定します。R4 E0/0はオートコンフィグレーションでIPv6アドレスを自動的に設定できるようにします。

R1 IPv6アドレスの設定

ipv6 unicast-routing
!         
interface Tunnel13
 ipv6 address 2001:1:1:13::1/64
 ipv6 address FE80::1 link-local
 ipv6 enable
 tunnel mode ipv6ip
!
interface Serial1/0
 ipv6 address 2001:1:1:12::1/64
 ipv6 address FE80::1 link-local
 ipv6 enable

R2 IPv6アドレスの設定

ipv6 unicast-routing
!         
interface Ethernet0/0
 ipv6 address 2001:1:1:2::2/64
 ipv6 address FE80::2 link-local
 ipv6 enable
!         
interface Serial1/0
 ipv6 address 2001:1:1:12::2/64
 ipv6 address FE80::2 link-local
 ipv6 enable

R3 IPv6アドレスの設定

ipv6 unicast-routing
!         
interface Tunnel13
 ipv6 address 2001:1:1:13::3/64
 ipv6 address FE80::3 link-local
 ipv6 enable
 tunnel source Ethernet0/0
 tunnel destination 192.168.13.1
 tunnel mode ipv6ip
!
interface Ethernet0/1
 ipv6 address 2001:1:1:34::3/64
 ipv6 address FE80::3 link-local
 ipv6 enable

R4 IPv6アドレスの設定

ipv6 unicast-routing
!         
interface Ethernet0/0
 ipv6 address FE80::4 link-local
 ipv6 address autoconfig
 ipv6 enable
!         
interface Ethernet0/1
 ipv6 address 2001:1:1:4::4/64
 ipv6 address FE80::4 link-local
 ipv6 enable

Step3:IPv6アドレスの確認

各ルータでshow ipv6 interface briefコマンドでIPv6アドレスを確認します。R1では、次のような出力です。

R1 show ipv6 interface brief

R1#show ipv6 interface brief | exclude down
Ethernet0/0                [up/up]
Serial1/0                  [up/up]
    FE80::1
    2001:1:1:12::1
Tunnel13                   [up/up]
    FE80::1
    2001:1:1:13::1

Step4:RIPngの設定

R1、R2でRIPngの設定を行います。

R1 RIPngの設定

interface Serial1/0
 ipv6 rip RIP enable

R2 RIPngの設定

interface Ethernet0/0
 ipv6 rip RIP enable
!
interface Serial1/0
 ipv6 rip RIP enable

Step5:RIPngの確認

R1でIPv6ルーティングテーブルを見て、RIPngでプレフィクスを学習できていることを確認します。

R1 show ipv6 route

R1#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
R   2001:1:1:2::/64 [120/2]
     via FE80::2, Serial1/0
C   2001:1:1:12::/64 [0/0]
     via ::, Serial1/0
L   2001:1:1:12::1/128 [0/0]
     via ::, Serial1/0
C   2001:1:1:13::/64 [0/0]
     via ::, Tunnel13
L   2001:1:1:13::1/128 [0/0]
     via ::, Tunnel13
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

Step6:OSPFv3の設定

R1、R3、R4でOSPFv3を設定します。ルータIDとして、X.X.X.X(X=ルータ番号)を指定します。

R1 OSPFv3の設定

ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
interface Tunnel13
 ipv6 ospf 1 area 0

R3 OSPFv3の設定

ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
interface Tunnel13
 ipv6 ospf 1 area 0
!
interface Ethernet0/1
 ipv6 ospf 1 area 0

R4 OSPFv3の設定

ipv6 router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
!
interface Ethernet0/0
 ipv6 ospf 1 area 0
!
interface Ethernet0/1
 ipv6 ospf 1 area 0

Step7:OSPFv3の確認

show ipv6 ospf neighborコマンドでOSPFv3ネイバーを確立できていることを確認します。また、IPv6ルーティングテーブルにOSPFv3ルートが登録されていることを確認します。R3では、次のような出力です。

R3 OSPFv3の確認 show ipv6 ospf neighbor/show ipv6 route

R3#show ipv6 ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
4.4.4.4           1   FULL/BDR        00:00:32    3               Ethernet0/1
1.1.1.1           1   FULL/  -        00:00:31    13              Tunnel13
R3#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   2001:1:1:4::/64 [110/20]
     via FE80::4, Ethernet0/1
C   2001:1:1:13::/64 [0/0]
     via ::, Tunnel13
L   2001:1:1:13::3/128 [0/0]
     via ::, Tunnel13
C   2001:1:1:34::/64 [0/0]
     via ::, Ethernet0/1
L   2001:1:1:34::3/128 [0/0]
     via ::, Ethernet0/1
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

Step8:RIPngとOSPFv3の再配送の設定

R1でRIPngとOSPFv3の双方向再配送を行います。RIPngへ再配送するときには、RIPv2と同様にシードメトリックを忘れないように注意してください。また、再配送時にはinclude-connectedのオプションを指定しないと直接接続のルートが再配送されないので注意してください。

R1 RIPng/OSPFv3の再配送の設定

ipv6 router ospf 1
 redistribute rip RIP include-connected
!
ipv6 router rip RIP
 redistribute ospf 1 metric 3 include-connected

Step9:RIPngとOSPFv3の再配送の確認

R1でshow ipv6 protocolsコマンドでRIPngとOSPFv3の再配送の設定を確認します。また、各ルータのIPv6ルーティングテーブルに必要なプレフィクスがすべて登録されていることを確認します。

R1 RIPng/OSPFv3の再配送の確認 show ipv6 protocols/show ipv6 route

R1#show ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "static"
IPv6 Routing Protocol is "rip RIP"
  Interfaces:
    Serial1/0
  Redistribution:
    Redistributing protocol ospf 1 with metric 3 include-connected
IPv6 Routing Protocol is "ospf 1"
  Interfaces (Area 0):
    Tunnel13
  Redistribution:
    Redistributing protocol rip RIP include-connected
R1#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
R   2001:1:1:2::/64 [120/2]
     via FE80::2, Serial1/0
O   2001:1:1:4::/64 [110/11131]
     via FE80::3, Tunnel13
C   2001:1:1:12::/64 [0/0]
     via ::, Serial1/0
L   2001:1:1:12::1/128 [0/0]
     via ::, Serial1/0
C   2001:1:1:13::/64 [0/0]
     via ::, Tunnel13
L   2001:1:1:13::1/128 [0/0]
     via ::, Tunnel13
O   2001:1:1:34::/64 [110/11121]
     via FE80::3, Tunnel13
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

R2 show ipv6 route

R2#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   2001:1:1:2::/64 [0/0]
     via ::, Ethernet0/0
L   2001:1:1:2::2/128 [0/0]
     via ::, Ethernet0/0
R   2001:1:1:4::/64 [120/4]
     via FE80::1, Serial1/0
C   2001:1:1:12::/64 [0/0]
     via ::, Serial1/0
L   2001:1:1:12::2/128 [0/0]
     via ::, Serial1/0
R   2001:1:1:13::/64 [120/4]
     via FE80::1, Serial1/0
R   2001:1:1:34::/64 [120/4]
     via FE80::1, Serial1/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

R3 show ipv6 route

R3#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OE2  2001:1:1:2::/64 [110/20]
     via FE80::1, Tunnel13
O   2001:1:1:4::/64 [110/20]
     via FE80::4, Ethernet0/1
OE2  2001:1:1:12::/64 [110/20]
     via FE80::1, Tunnel13
C   2001:1:1:13::/64 [0/0]
     via ::, Tunnel13
L   2001:1:1:13::3/128 [0/0]
     via ::, Tunnel13
C   2001:1:1:34::/64 [0/0]
     via ::, Ethernet0/1
L   2001:1:1:34::3/128 [0/0]
     via ::, Ethernet0/1
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

R4 show ipv6 route

R4#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OE2  2001:1:1:2::/64 [110/20]
     via FE80::3, Ethernet0/0
C   2001:1:1:4::/64 [0/0]
     via ::, Ethernet0/1
L   2001:1:1:4::4/128 [0/0]
     via ::, Ethernet0/1
OE2  2001:1:1:12::/64 [110/20]
     via FE80::3, Ethernet0/0
O   2001:1:1:13::/64 [110/11121]
     via FE80::3, Ethernet0/0
C   2001:1:1:34::/64 [0/0]
     via ::, Ethernet0/0
L   2001:1:1:34::4/128 [0/0]
     via ::, Ethernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

Step10:通信確認

RIPngドメインとOSPFv3ドメイン間の通信ができることを確認します。R2からR4へIPv6でPingを行います。

R2 IPv6 Ping

R2#ping 2001:1:1:4::4 source 2001:1:1:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:4::4, timeout is 2 seconds:
Packet sent with a source address of 2001:1:1:2::2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/52/56 ms

完了した設定ファイル

R1 Completed Configuration

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel13
 no ip address
 ipv6 address 2001:1:1:13::1/64
 ipv6 address FE80::1 link-local
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source Ethernet0/0
 tunnel destination 192.168.13.3
 tunnel mode ipv6ip
!
interface Ethernet0/0
 ip address 192.168.13.1 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 ipv6 address 2001:1:1:12::1/64
 ipv6 address FE80::1 link-local
 ipv6 enable
 ipv6 rip RIP enable
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute rip RIP include-connected
!
ipv6 router rip RIP
 redistribute ospf 1 metric 3 include-connected
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R2 Completed Configuration

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 half-duplex
 ipv6 address 2001:1:1:2::2/64
 ipv6 address FE80::2 link-local
 ipv6 enable
 ipv6 rip RIP enable
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 ipv6 address 2001:1:1:12::2/64
 ipv6 address FE80::2 link-local
 ipv6 enable
 ipv6 rip RIP enable
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
ipv6 router rip RIP
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R3 Completed Configuration

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel13
 no ip address
 ipv6 address 2001:1:1:13::3/64
 ipv6 address FE80::3 link-local
 ipv6 enable
 ipv6 ospf 1 area 0
 tunnel source Ethernet0/0
 tunnel destination 192.168.13.1
 tunnel mode ipv6ip
!
interface Ethernet0/0
 ip address 192.168.13.3 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 half-duplex
 ipv6 address 2001:1:1:34::3/64
 ipv6 address FE80::3 link-local
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R4 Completed Configuration

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 half-duplex
 ipv6 address FE80::4 link-local
 ipv6 address autoconfig
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Ethernet0/1
 no ip address
 half-duplex
 ipv6 address 2001:1:1:4::4/64
 ipv6 address FE80::4 link-local
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
ipv6 router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

関連記事