概要

基本的なMPLS-VPNの設定例です。MPLS-VPNバックボーンでMP-BGPネイバーを設定して、カスタマーの拠点間をフルメッシュ(Any-to-any)で接続できるようにします。

ネットワーク構成

図 MPLS-VPNのさまざまな接続性 ネットワーク構成
図 MPLS-VPNのさまざまな接続性 ネットワーク構成

A社およびB社の拠点間でAny-to-anyの接続性を確保するフルメッシュVPNの設定と確認を行います。

図 フルメッシュVPNの接続性
図 フルメッシュVPNの接続性


初期設定

  • MPLS-VPNバックボーン PE1~PE5のIPルーティングとMPLSの有効化
  • IPアドレス/ホスト名

MP-BGPネイバーの設定

フルメッシュのネイバー設定を回避するために、PE5をルートリフレクタとして設定し、PE1~PE5でVPNv4ルートを交換できるようにします。PE1~PE4はPE5とのネイバーを設定します。PE5は、PE1~PE4とのネイバーを設定し、さらにルートリフレクタクライアントの設定を行います。

PE1~PE4 MP-BGPネイバーの設定

router bgp 65000
 neighbor 5.5.5.5 remote-as 65000
 neighbor 5.5.5.5 update-source Loopback0
 !
 address-family vpnv4
 neighbor 5.5.5.5 activate
 neighbor 5.5.5.5 next-hop-self
 neighbor 5.5.5.5 send-community extended

PE5 MP-BGPネイバーの設定

router bgp 65000
 neighbor 1.1.1.1 remote-as 65000
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 2.2.2.2 remote-as 65000
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 65000
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 65000
 neighbor 4.4.4.4 update-source Loopback0
!
 address-family vpnv4
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 route-reflector-client
 neighbor 1.1.1.1 next-hop-self
 neighbor 1.1.1.1 send-community extended
 neighbor 2.2.2.2 activate
 neighbor 2.2.2.2 route-reflector-client
 neighbor 2.2.2.2 next-hop-self
 neighbor 2.2.2.2 send-community extended
 neighbor 3.3.3.3 activate
 neighbor 3.3.3.3 route-reflector-client
 neighbor 3.3.3.3 next-hop-self
 neighbor 3.3.3.3 send-community extended
 neighbor 4.4.4.4 activate
 neighbor 4.4.4.4 route-reflector-client
 neighbor 4.4.4.4 next-hop-self
 neighbor 4.4.4.4 send-community extended

図 MP-BGPネイバーの構成
図 MP-BGPネイバーの構成


VRFの設定

PEルータで各ユーザ拠点に対応するVRFを作成します。VRFを作成するには、以下のパラメータが必要です。

  • VRF名
  • RD
  • Import/Export RT
  • インタフェース

作成するVRFの情報を次の表にまとめています。

ルータVRF名RDImport RTExport RTインタフェース
PE1Customer_A1100:1100:1100:1Fa0/0.101
Customer_B1200:1200:1200:1Fa0/0.201
PE2Customer_A2100:1100:1100:1Fa0/0.102
Customer_B2200:1200:1200:1Fa0/0.202
PE4Customer_A3100:1100:1100:1Fa0/0.103
表 VRFの作成

PE1 VRFの設定

ip vrf Customer_A1
 rd 100:1
 route-target export 100:1
 route-target import 100:1

interface FastEthernet0/0.101
 encapsulation isl 101
 ip vrf forwarding Customer_A1
 ip address 192.168.0.1 255.255.255.252

ip vrf Customer_B1
 rd 200:1
 route-target export 200:1
 route-target import 200:1

interface FastEthernet0/0.201
 encapsulation isl 201
 ip vrf forwarding Customer_B1
 ip address 172.16.0.1 255.255.255.252

PE2 VRFの設定

ip vrf Customer_A2
 rd 100:1
 route-target export 100:1
 route-target import 100:1

interface FastEthernet0/0.102	
 encapsulation isl 102
 ip vrf forwarding Customer_A2
 ip address 192.168.0.5 255.255.255.252

ip vrf Customer_B2
 rd 200:1
 route-target export 200:1
 route-target import 200:1

interface FastEthernet0/0.202
 encapsulation isl 202
 ip vrf forwarding Customer_B2
 ip address 172.16.0.5 255.255.255.252

PE4 VRFの設定

ip vrf Customer_A3
 rd 100:1
 route-target export 100:1
 route-target import 100:1

interface FastEthernet0/0.103
 encapsulation isl 103
 ip vrf forwarding Customer_A3
 ip address 192.168.0.9 255.255.255.252

VRFルーティングの設定

MPLS-VPNでユーザ拠点間の通信を行うには、ユーザのVRFルーティングテーブルに拠点のルートを登録して、MP-BGPで他のPEルータへアドバタイズします。PEルータのVRFルーティングテーブルにユーザ拠点のルートを登録するため方法は次のように行います。

PEルータ拠点(VRF)ルーティング方法
PE1A社拠点1(Customer_A1)BGP
B社拠点1(Customer_B1)BGP
PE2A社拠点2(Customer_A2)スタティック
B社拠点2(Customer_B2)スタティック
PE4A社拠点3(Customer_A3)BGP
表 VRFルーティングの設定

また、CEルータでのルーティングの設定をまとめると次の表のようになります。

CEルータルーティング方法
CE-A1BGP(AS65100)
CE-A2スタティックルート(デフォルトルート)
CE-A3BGP(AS65100)
CE-B1BGP(AS65200)
CE-B2スタティックルート(デフォルトルート)
表 CEルータのルーティング
図 PE-CE間のルーティング
図 PE-CE間のルーティング

PE1 VRFルーティングの設定

router bgp 65000
address-family ipv4 vrf Customer_A1
 redistribute connected
 neighbor 192.168.0.2 remote-as 65100
 neighbor 192.168.0.2 activate
 neighbor 192.168.0.2 as-override
 
address-family ipv4 vrf Customer_B1
 redistribute connected
 neighbor 172.16.0.2 remote-as 65200
 neighbor 172.16.0.2 activate

A社拠点1とA社拠点3で共通のAS番号65100を利用しているので、neighbor as-overrideが必要です。
PE-CE間のリンクのルート情報をMP-BGPでアドバタイズするためにredistribute connectedを設定しています。

PE2 VRFルーティングの設定

ip route vrf Customer_A2 192.168.2.0 255.255.255.0 192.168.0.6
ip route vrf Customer_B2 172.16.2.0 255.255.255.0 172.16.0.6

router bgp 65000
 address-family ipv4 vrf Customer_B2
 redistribute connected
 redistribute static

 address-family ipv4 vrf Customer_A2
 redistribute connected
 redistribute static

PE-CE間のリンクのルート情報をMP-BGPでアドバタイズするためにredistribute connectedを設定しています。

PE4 VRFルーティングの設定

router bgp 65000
 address-family ipv4 vrf Customer_A3
 redistribute connected
 neighbor 192.168.0.10 remote-as 65100
 neighbor 192.168.0.10 activate
 neighbor 192.168.0.10 as-override

A社拠点1とA社拠点3で共通のAS番号65100を利用しているので、neighbor as-overrideが必要です。
PE-CE間のリンクのルート情報をMP-BGPでアドバタイズするためにredistribute connectedを設定しています。

CE-A1 ルーティングの設定

router bgp 65100
 network 192.168.1.0
 neighbor 192.168.0.1 remote-as 65000

CE-A2 ルーティングの設定

ip route 0.0.0.0 0.0.0.0 192.168.0.5

CE-A3 ルーティングの設定

router bgp 65100
 network 192.168.3.0
 neighbor 192.168.0.9 remote-as 65000

CE-B1 ルーティングの設定

router bgp 65200
 network 172.16.1.0 mask 255.255.255.0
 neighbor 172.16.0.1 remote-as 65000

CE-B2 ルーティングの設定

ip route 0.0.0.0 0.0.0.0 172.16.0.5

VRFルーティングテーブルの確認

このようにPEルータでのVRFルーティングおよびCEルータでのルーティング設定を行うことで、VRFルーティングテーブルに各拠点のルート情報を登録してAny-to-anyの接続性を確保することができます。たとえば、PE1におけるVRF Customer_A1のルーティングテーブルは次のようになります。

PE1 VRF Customer_A1のルーティングテーブル

PE1#sh ip route vrf Customer_A1
~省略~

Gateway of last resort is not set

     192.168.0.0/30 is subnetted, 3 subnets
B       192.168.0.8 [200/0] via 4.4.4.4, 00:08:48
C       192.168.0.0 is directly connected, FastEthernet0/0.101
B       192.168.0.4 [200/0] via 2.2.2.2, 00:13:49
B    192.168.1.0/24 [20/0] via 192.168.0.2, 00:19:45
B    192.168.2.0/24 [200/0] via 2.2.2.2, 00:13:49
B    192.168.3.0/24 [200/0] via 4.4.4.4, 00:08:48


有料メールマガジン「ネットワークのおべんきょしませんか? PREMIUM」の2014年8月のバックナンバーを購入していただくと、フルメッシュだけではなくエクストラネット、セントラルサービス、ハブ&スポーク構成のすべての動画解説をダウンロードしていただけます。

関連記事