概要

MPLS-VPNで特定のネットワークへの通信のみハブ&スポークの転送経路にするための設定例です。ハブ&スポークの転送経路になるように追加でVRFを作成して、ルートをアドバタイズします。

ネットワーク構成

図 MPLS-VPNのさまざまな接続性 ネットワーク構成
図 MPLS-VPNのさまざまな接続性 ネットワーク構成

A社の拠点からデータセンターDC2へ通信できるようにします。ただし、必ずA社拠点1を経由してDC2へ通信するようにします。

図 ハブ&スポークの接続性
図 ハブ&スポークの接続性

図の通信フローはA社拠点3からDC2への通信を考えています。

初期設定

以下のリンクのフルメッシュのMPLS-VPNの設定が完了している状態から開始します。



DC2を接続するための設定

追加でDC2の拠点を接続するために次の設定を行います。

  • PE3でDC2用のVRFを作成
  • DC2用のVRFルーティングの設定
  • DC2のルーティングの設定

設定するための情報は、次の表にまとめています。

ルータVRF名RDImport RTExport RTインタフェース
PE3DC2400:1400:1400:1Fa0/0.401
表 VRFの作成
PEルータ拠点(VRF)ルーティング方法
PE3DC2(DC2)スタティック
表 VRFルーティングの設定
CEルータルーティング方法
DC2スタティックルート(デフォルトルート)
表 CEルータのルーティング

PE3

ip vrf DC2
 rd 400:1
 route-target export 400:1
 route-target import 400:1

interface FastEthernet0/0.401
 ip vrf forwarding DC2
 ip address 10.2.0.1 255.255.255.252

router bgp 65000

 address-family ipv4 vrf DC2
 redistribute connected
 redistribute static

ip route vrf DC2 10.2.2.0 255.255.255.0 10.2.0.2

DC2

ip route 0.0.0.0 0.0.0.0 10.2.0.1

PE1で追加のVRF作成

ハブ&スポークの接続性を実現するためにPE1で追加のVRFを作成します。

ルータVRF名RDImport RTExport RTインタフェース
PE1Customer_A10400:1400:1400:1Fa0/0.111
表 PE1 追加のVRFの作成

PE1 追加のVRF作成

ip vrf Customer_A10
 rd 400:1
 route-target export 400:1
 route-target import 400:1

interface FastEthernet0/0.111
 ip vrf forwarding Customer_A10
 ip address 192.168.0.13 255.255.255.252

PE1とCE-A1で追加のBGPネイバーの設定

PE1のVRF Customer_A10に含まれるDC2のルートをCE-A1にアドバタイズするために追加のBGPネイバーの設定を行います。

PE1 追加のBGPネイバーの設定

router bgp 65000
 address-family ipv4 vrf Customer_A10
  redistribute connected
  neighbor 192.168.0.14 remote-as 65100
  neighbor 192.168.0.14 activate
  neighbor 192.168.0.14 as-override
  neighbor 192.168.0.14 allowas-in

 address-family ipv4 vrf Customer_A1
  neighbor 192.168.0.2 allowas-in

CE-A1(192.168.0.2)から受信するDC2のルートを利用するために、neighbor 192.168.0.2 allowas-inの設定が必要です。

CE-A1(192.168.0.14)から受信するA社拠点のルートを利用するために、neighbor 192.168.0.14 allowas-inの設定が必要です。

CE-A1 追加のBGPネイバーの設定

router bgp 65100
 neighbor 192.168.0.13 remote-as 65000

図 PE1とCE-A1間のEBGPネイバー
図 PE1とCE-A1間のEBGPネイバー

このようにPE1とCE-A1間で追加のEBGPネイバーを確立することで、DC2のルート情報が次のようにアドバタイズされることになります。

図 10.2.2.0/24がアドバタイズされていく様子(詳細)
図 10.2.2.0/24がアドバタイズされていく様子(詳細)

VRFルーティングテーブルの確認

A社拠点およびDCに対応する各PEルータのVRFルーティングテーブルを確認します。

PE1 VRFルーティングテーブルの確認

PE1#show ip route vrf Customer_A1
~省略~

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
B       172.16.0.0/30 is directly connected, 00:16:45, FastEthernet0/0.201
B       172.16.1.0/24 [20/0] via 172.16.0.2 (Customer_B1), 00:16:45
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B       10.2.0.0/30 [20/0] via 192.168.0.2, 00:12:12
B       10.2.2.0/24 [20/0] via 192.168.0.2, 00:12:12
B       10.1.1.0/24 [200/0] via 4.4.4.4, 00:16:45
B       10.1.0.0/30 [200/0] via 4.4.4.4, 00:16:45
     192.168.0.0/30 is subnetted, 4 subnets
B       192.168.0.8 [200/0] via 4.4.4.4, 00:16:46
B       192.168.0.12 [20/0] via 192.168.0.2, 00:06:45
C       192.168.0.0 is directly connected, FastEthernet0/0.101
B       192.168.0.4 [200/0] via 2.2.2.2, 00:16:46
B    192.168.1.0/24 [20/0] via 192.168.0.2, 00:16:54
B    192.168.2.0/24 [200/0] via 2.2.2.2, 00:16:47
B    192.168.3.0/24 [200/0] via 4.4.4.4, 00:16:47
PE1#show ip route vrf Customer_A10
~省略~

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
B       172.16.0.0/30 [20/0] via 192.168.0.14, 00:03:25
B       172.16.1.0/24 [20/0] via 192.168.0.14, 00:03:25
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B       10.2.0.0/30 [200/0] via 3.3.3.3, 00:15:54
B       10.1.1.0/24 [20/0] via 192.168.0.14, 00:03:25
B       10.2.2.0/24 [200/0] via 3.3.3.3, 00:15:54
B       10.1.0.0/30 [20/0] via 192.168.0.14, 00:03:25
     192.168.0.0/30 is subnetted, 4 subnets
B       192.168.0.8 [20/0] via 192.168.0.14, 00:03:26
C       192.168.0.12 is directly connected, FastEthernet0/0.111
B       192.168.0.0 [20/0] via 192.168.0.14, 00:03:26
B       192.168.0.4 [20/0] via 192.168.0.14, 00:03:26
B    192.168.1.0/24 [20/0] via 192.168.0.14, 00:15:10
B    192.168.2.0/24 [20/0] via 192.168.0.14, 00:03:26
B    192.168.3.0/24 [20/0] via 192.168.0.14, 00:03:26

PE2 VRFルーティングテーブルの確認

PE2#show ip route vrf Customer_A2
~省略~

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       10.2.0.0/30 [200/0] via 1.1.1.1, 00:14:11
B       10.2.2.0/24 [200/0] via 1.1.1.1, 00:14:11
     192.168.0.0/30 is subnetted, 4 subnets
B       192.168.0.8 [200/0] via 4.4.4.4, 00:57:14
B       192.168.0.12 [200/0] via 1.1.1.1, 00:08:40
B       192.168.0.0 [200/0] via 1.1.1.1, 00:18:56
C       192.168.0.4 is directly connected, FastEthernet0/0.102
B    192.168.1.0/24 [200/0] via 1.1.1.1, 00:18:56
S    192.168.2.0/24 [1/0] via 192.168.0.6
B    192.168.3.0/24 [200/0] via 4.4.4.4, 00:57:15

PE3 VRFルーティングテーブルの確認

PE3#sho ip route vrf DC2
~省略~

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
B       172.16.0.0/30 [200/0] via 1.1.1.1, 00:06:13
B       172.16.1.0/24 [200/0] via 1.1.1.1, 00:06:13
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.2.0.0/30 is directly connected, FastEthernet0/0.401
B       10.1.1.0/24 [200/0] via 1.1.1.1, 00:06:13
S       10.2.2.0/24 [1/0] via 10.2.0.2
B       10.1.0.0/30 [200/0] via 1.1.1.1, 00:06:13
     192.168.0.0/30 is subnetted, 4 subnets
B       192.168.0.8 [200/0] via 1.1.1.1, 00:06:15
B       192.168.0.12 [200/0] via 1.1.1.1, 00:09:44
B       192.168.0.0 [200/0] via 1.1.1.1, 00:06:15
B       192.168.0.4 [200/0] via 1.1.1.1, 00:06:15
B    192.168.1.0/24 [200/0] via 1.1.1.1, 00:18:02
B    192.168.2.0/24 [200/0] via 1.1.1.1, 00:06:16
B    192.168.3.0/24 [200/0] via 1.1.1.1, 00:06:16

PE4 VRFルーティングテーブルの確認

PE4#show ip route vrf Customer_A3
~省略~

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       10.2.0.0/30 [200/0] via 1.1.1.1, 00:17:06
B       10.2.2.0/24 [200/0] via 1.1.1.1, 00:17:06
     192.168.0.0/30 is subnetted, 4 subnets
C       192.168.0.8 is directly connected, FastEthernet0/0.103
B       192.168.0.12 [200/0] via 1.1.1.1, 00:11:36
B       192.168.0.0 [200/0] via 1.1.1.1, 00:21:37
B       192.168.0.4 [200/0] via 2.2.2.2, 01:00:06
B    192.168.1.0/24 [200/0] via 1.1.1.1, 00:21:37
B    192.168.2.0/24 [200/0] via 2.2.2.2, 01:00:08
B    192.168.3.0/24 [20/0] via 192.168.0.10, 02:45:14

各PEルータのVRFルーティングテーブルをみると、DC2のルートはいったんCE-A1を経由してアドバタイズされていることがわかります。

図 10.2.2.0/24がアドバタイズされていく様子(全体)
図 10.2.2.0/24がアドバタイズされていく様子(全体)

いったんCE-A1を経由するようにして、DC2の10.2.2.0/24のルートがアドバタイズされているのでA社拠点から10.2.2.0/24のネットワークへパケットをルーティングするとCE-A1を経由します。

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索