Sham Linkの設定手順

Sham Linkの設定を行う前に設定手順について解説します。Sham LinkはPEルータ間で設定します。その設定手順は次の通りです。

  1. Sham Linkのエンドポイントとなるインタフェースを作成
  2. エンドポイントのルートをPEルータ間でアドバタイズ
  3. Sham Linkの設定
Sham Linkのエンドポイントとなるインタフェースを作成
Loopbackインタフェースを作成して/32のIPアドレスを設定
エンドポイントのルートをPEルータ間でアドバタイズ
MP-BGPでエンドポイントのルートをアドバタイズ
Sham-linkの設定
任意のエリアのOSPFリンクとする

1.Sham Linkのエンドポイントとなるインタフェースを作成

PEルータでLoopbackインタフェースを作成し、VRFを割り当ててIPアドレスを設定します。サブネットマスク/32のホストルートとします。

Sham-linkのエンドポイントの設定

(config)#interface loopback <num>
(config-if)#ip vrf forwarding <VRF>
(config-fi)#ip address <address> <subnetmask>

<num> : インタフェース番号
<VRF> : VRF名
<address> : IPアドレス
<subnetmask> : サブネットマスク

2.エンドポイントのルートをPEルータ間でアドバタイズ

エンドポイントのルートをPEルータ間でMP-BGPによってアドバタイズします。

エンドポイントのルートをアドバタイズ

(config)#router bgp <AS>
(config-router)#address-family ipv4 vrf <VRF>
(config-router-af)#network <network> mask <subnetmask>

<AS> : AS番号
<VRF> : VRF名
<network> : ネットワークアドレス
<subnetmask> : サブネットマスク

3.Sham Linkの設定

PEルータのお互いのエンドポイントのIPアドレスを指定して、Sham Linkを設定します。

Sham-linkの設定

(config)#router ospf vrf <VRF>
(config-router)#area <area-id> sham-link <source-endpoint> <dest-endpoint>

Sham Linkの設定は、show ip ospf sham-linkコマンドで確認できます。また、show ip ospf interfaceを見ると、OSPF_SLというインタフェースが作成されます。OSPF_SL上でPEルータ間はOSPFネイバーとなります。

Sham Linkの設定例

では、実際にこれまで考えてきたネットワーク構成でSham Linkの設定を行います。

1.Sham Linkエンドポイントのインタフェース作成

PE1とPE2ルータで次のIPアドレスでエンドポイントのインタフェースを作成します。

PE1:Loopback100 100.100.100.100/32
PE2:Loopback100 200.200.200.200/32

PE1 エンドポイントの作成

interface Loopback100
 ip vrf forwarding VPN
 ip address 100.100.100.100 255.255.255.255

PE2 エンドポイントの作成

interface Loopback100
 ip vrf forwarding VPN
 ip address 200.200.200.200 255.255.255.255

2.エンドポイントのルートをPEルータ間でアドバタイズ

作成したエンドポイントインタフェースのルートをMP-BGPでアドバタイズします。

PE1 エンドポイントをアドバタイズ

router bgp 1
 address-family ipv4 vrf VPN
  network 100.100.100.100 mask 255.255.255.255

PE2 エンドポイントをアドバタイズ

router bgp 1
 address-family ipv4 vrf VPN
  network 200.200.200.200 mask 255.255.255.255

3.Sham Linkの設定

PE1とPE2でお互いのエンドポイントインタフェースのIPアドレスによって、Sham Linkを設定します。

PE1 Sham-link

router ospf 100 vrf VPN
 area 0 sham-link 100.100.100.100 200.200.200.200

PE2 Sham-link

router ospf 100 vrf VPN
 area 0 sham-link 200.200.200.200 100.100.100.100

Sham-linkの確認

PE1-PE2間でSham Linkが確立できたことを確認します。PE1のshow ip ospf sham-links、show ip ospf interface、show ip ospf neighborの出力は次のようになります。

R1 show ip ospf sham-links/show ip ospf interface/show ip ospf neighbor

PE1#show ip ospf sham-links
Sham Link OSPF_SL0 to address 200.200.200.200 is up
Area 0 source address 100.100.100.100
  Run as demand circuit
  DoNotAge LSA allowed. Cost of using 1 State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40,
    Hello due in 00:00:03
    Adjacency State FULL (Hello suppressed)
    Index 2/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec
PE1#sh ip ospf 100 interface
OSPF_SL0 is up, line protocol is up
  Internet Address 0.0.0.0/0, Area 0
  Process ID 100, Router ID 10.1.1.1, Network Type SHAM_LINK, Cost: 1
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.2.2.1  (Hello suppressed)
  Suppress hello for 1 neighbor(s)
FastEthernet1/0 is up, line protocol is up
  Internet Address 10.1.1.1/24, Area 0
  Process ID 100, Router ID 10.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 172.16.1.1, Interface address 10.1.1.2
  Backup Designated router (ID) 10.1.1.1, Interface address 10.1.1.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.1.1  (Designated Router)
  Suppress hello for 0 neighbor(s)
PE1#show ip ospf 100 neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.2.2.1          0   FULL/  -           -        200.200.200.200 OSPF_SL0
172.16.1.1        1   FULL/DR         00:00:36    10.1.1.2        FastEthernet1/0

サイト間の通信経路の確認

Sham Linkの設定をしたあと、CE1でルーティングテーブルを見てサイト2の172.16.2.0/24のルートを確認します。

CE1 show ip route

CE1#sh ip route
~省略~

Gateway of last resort is not set

     200.200.200.0/32 is subnetted, 1 subnets
O E2    200.200.200.200 [110/1] via 10.1.1.1, 00:04:54, FastEthernet1/0
     100.0.0.0/32 is subnetted, 1 subnets
O E2    100.100.100.100 [110/1] via 10.1.1.1, 00:04:54, FastEthernet1/0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.12.0 is directly connected, FastEthernet0/0
C       172.16.1.0 is directly connected, Loopback0
O       172.16.2.0 [110/4] via 10.1.1.1, 00:04:54, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
O       10.2.2.0 [110/3] via 10.1.1.1, 00:04:54, FastEthernet1/0
C       10.1.1.0 is directly connected, FastEthernet1/0

CE1のルーティングテーブルでは、172.16.2.0/24のネクストホップがPE1(10.1.1.1)になっていることがわかります。これはSham Linkのコストが1のためです。10MbpsのF0/0から直接CE2へルーティングするよりもMPLS-VPN経由の方が低コストになっています。

図 CE1での172.16.2.0/24のルート選択
図 CE1での172.16.2.0/24のルート選択

CE1から172.16.2.0/24への経路を確認するために、トレースルートを実行すると次のようになります。

CE1 trace 172.16.2.2 source 172.16.1.1

CE1#traceroute 172.16.2.2 source 172.16.1.1

Type escape sequence to abort.
Tracing the route to 172.16.2.2

  1 10.1.1.1 44 msec 28 msec 68 msec
  2 10.2.2.1 [MPLS: Label 20 Exp 0] 8 msec 52 msec 40 msec
  3 10.2.2.2 8 msec 68 msec *

トレースルートの結果より、CE1からCE2の172.16.2.0/24への通信経路はMPLS-VPNを経由していることがわかります。

図 CE1から172.16.2.0/24への転送経路(Sham Link設定時)
図 CE1から172.16.2.0/24への転送経路(Sham Link設定時)

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索