showコマンド表示のフィルタ

showコマンドによっては、非常に長い表示になることがあります。特にrunnig-configを表示するshow running-configコマンドは、場合によっては数百行にもなってしまいます。長い表示のshowコマンドから確認したい部分を効率よく見つけるには、showコマンドの表示をフィルタします。showコマンドのあとに「|」(パイプ)でどのような表示のフィルタをかけるかを決められます。

CLIのヘルプで「|」のあとに指定できるフィルタのオプションを確認すると、以下のようになります。

R1#show running-config | ?
  append    Append redirected output to URL (URLs supporting append operation
            only)
  begin     Begin with the line that matches
  exclude   Exclude lines that match
  include   Include lines that match
  redirect  Redirect output to URL
  section   Filter a section of output
  tee       Copy output to URL

主なフィルタの意味は次のようになります。

フィルタのオプション内容
begin指定した文字列を含む行から表示する
exclude指定した文字列を含む行を除外して表示する
include指定した文字列を含む行だけを表示する
section指定した文字列を含むセクションだけを表示する
表 showコマンド表示フィルタのオプション

セクションとは、ある行とその後に続くインデントされている行のまとまりです。以下は、show running-configのinterface FastEtehernet0/0のセクションの例です。

セクションの例
図 セクションの例

showコマンド表示フィルタの例

showコマンド表示のフィルタの例を具体的にみていきましょう。

begin

beginの表示フィルタとして、「interface FastEtehernet0/0」を含む行からrunning-configの表示を開始するフィルタの例です。

R1#<show running-config | begin interface FastEthernet0/0
interface FastEthernet0/0
 ip address 192.168.1.254 255.255.255.0
 duplex auto
 speed auto
!
!
no ip http server
ip forward-protocol nd
!
~省略~

exclude/include

excludeおよびincludeのフィルタの例です。show ip interface briefでインタフェースのIPアドレスと状態を見ています。インタフェースの状態がup/upとなっているインタフェースだけ表示する例です。

「exclude down」でdownのインタフェースを除外して表示します。または「include up」でupのインタフェースのみ抜き出して表示します。たくさんのインタフェースのうちアクティブなものだけを確認したいときに利用すると便利です。

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.254   YES manual up                    up
Loopback0                  192.168.0.1     YES manual administratively down down
R1#show ip interface brief | exclude down
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.254   YES manual up                    up
R1#show ip interface brief | include up
FastEthernet0/0            192.168.1.254   YES manual up                    up

個人的には、「exclude down」のフィルタをよく使います。show ip interface briefコマンドのヘッダ部分も表示されるので便利です。

section

sectionを使った表示フィルタの例です。「section line」と指定すると、「line」を含む行のセクションのみを表示します。これにより「line con 0」のセクションの設定と「line aux 0」のセクションの設定と「line vty 0 4」のセクションの設定だけを表示します。

R1#show running-config | section line
line con 0
 exec-timeout 0 0
 privilege level 15
 password 7 094F471A1A0A
 logging synchronous
 login
line aux 0
 exec-timeout 0 0
 privilege level 15
 password 7 060506324F41
 logging synchronous
 login
line vty 0 4
 login local

sectionのフィルタは、ルーティングプロトコルに関する設定を確認するときにもとても便利です。OSPFやBGPといったルーティングプロトコルに関する設定は、show runnign-configの表示の中の「router」という文字列のセクションです。

R11#show running-config | section router
router eigrp 1
 !
 address-family ipv4 vrf IVRF autonomous-system 1
  network 172.16.0.0
  network 172.17.0.0
 exit-address-family
 eigrp router-id 11.11.11.11
router ospf 1 vrf FVRF
 router-id 11.11.11.11
 network 10.0.0.11 0.0.0.0 area 0
 network 10.0.11.11 0.0.0.0 area 0

running-config/startup-configの特定インタフェース部分だけ表示

show running-config/show startup-configで特定のインタフェースの部分だけを表示することもできます。show running-config/show startup-configのあとにinterface <interface-name>を指定すると、そのインタフェースの部分だけを表示します。特定のインタフェースの設定だけをぱっと確認したいときに便利です。

R1#show running-config interface loopback 0
Building configuration...

Current configuration : 77 bytes
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
 shutdown
end

まとめ

ポイント

  • 長い表示のshowコマンドから確認したい部分を効率よく見つけるには、showコマンドの表示をフィルタします。
  • showコマンドのあとに「|」(パイプ)でどのような表示のフィルタをかけるかを決められます。
  • 主なフィルタの意味
フィルタのオプション内容
begin指定した文字列を含む行から表示する
exclude指定した文字列を含む行を除外して表示する
include指定した文字列を含む行だけを表示する
section指定した文字列を含むセクションだけを表示する
表 showコマンド表示フィルタのオプション

Ciscoのキホン