aggregate-addressのオプション summary-only

CiscoルータでBGPルートを集約するaggregate-addressにはたくさんのオプションがあります。オプションは、以下の2つにわかれます。

  • 集約前のルートをどう扱うか
  • 集約ルートのアトリビュートをどうするか

summary-onlyオプションは、「集約前のルートをどう扱うか」に関するオプションです。summary-onlyを指定すると、集約ルートのみをアドバタイズします。簡単なネットワーク構成に基づいてsummary-onlyの動作を解説します。

サンプルトポロジと事前設定

次のサンプルトポロジでR1でaggregate-addressとsummary-onlyのオプションを考えます。

図 summary-only サンプルネットワーク
図 summary-only サンプルネットワーク

aggregate-addressを設定する前のR1のBGPに関連する設定は次のとおりです。

R1

R1
interface Loopback0
 ip address 123.1.2.1 255.255.255.0 secondary
 ip address 123.1.3.1 255.255.255.0 secondary
 ip address 123.1.4.1 255.255.255.0 secondary
 ip address 123.1.5.1 255.255.255.0 secondary
 ip address 123.1.6.1 255.255.255.0 secondary
 ip address 123.1.7.1 255.255.255.0 secondary
 ip address 123.1.1.1 255.255.255.0
!
router bgp 123
 neighbor 14.0.0.4 remote-as 4
 neighbor 192.168.123.3 remote-as 123
 network 123.1.1.0 mask 255.255.255.0
 network 123.1.2.0 mask 255.255.255.0
 network 123.1.3.0 mask 255.255.255.0
 network 123.1.4.0 mask 255.255.255.0
 network 123.1.5.0 mask 255.255.255.0
 network 123.1.6.0 mask 255.255.255.0
 network 123.1.7.0 mask 255.255.255.0

R1ではBGPピアの設定とnetworkコマンドによるルートのアドバタイズの設定をしています。ルートをアドバタイズするためにLoopback0インタフェースに、セカンダリアドレスをたくさん設定しています。Loopbackインタフェースをいくつも作るより、この例のように1つのLoopbackインタフェースにセカンダリアドレスを設定するほうがシンプルになるのでオススメです。

通常の集約の設定 summary-onlyなし

まず、通常の集約の設定、つまりオプションなしでaggregate-addressの設定を行います。AS123の123.1.x.xのルートを集約して123.1.0.0/16としてアドバタイズします。アドバタイズするルータはR1です。

R1

router bgp 123
 aggregate-address 123.1.0.0 255.255.0.0

このコマンドによって集約ルートが生成されR1のBGPテーブルに載り、ネイバーにアドバタイズされます。summary-onlyオプションをつけなければ、集約前のルートも一緒にアドバタイズされます。これを確認するためにBGPテーブルを見ます。

R1

R1#sh ip bgp
BGP table version is 72, local router ID is 192.168.123.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network          Next Hop            Metric LocPrf Weight Path
*> 123.1.0.0/16     0.0.0.0                            32768 i
*> 123.1.1.0/24     0.0.0.0                  0         32768 i
*> 123.1.2.0/24     0.0.0.0                  0         32768 i
*> 123.1.3.0/24     0.0.0.0                  0         32768 i
*> 123.1.4.0/24     0.0.0.0                  0         32768 i
*> 123.1.5.0/24     0.0.0.0                  0         32768 i
*> 123.1.6.0/24     0.0.0.0                  0         32768 i
*> 123.1.7.0/24     0.0.0.0                  0         32768 i

BGPテーブルを確認すると、集約ルート123.1.0.0/16 が生成されベストパスとなりネイバーにアドバタイズされていることがわかります。それと同時に集約前の123.1.1.0/24~123.1.7.0/24のルートもアドバタイズされています。

図 通常の集約の設定
図 通常の集約の設定

summary-onlyオプション

以上のように、普通にaggregate-addressコマンドで集約ルートを生成すると、集約前のルートもすべてアドバタイズされるので、ルートの数が膨大になります。集約前ルートはアドバタイズせずに、集約ルートだけをアドバタイズしたいときに利用するのがsummary-onlyオプションです。summary-onlyオプションをつけることによって、名前のとおり、集約ルート「だけ」をアドバタイズすることができます。R1で次のように設定しています。

R1

router bgp 123
 aggregate-address 123.1.0.0 255.255.0.0 summary-only

この設定で、集約ルートだけのアドバタイズに変わります。それを確認するには、R1のBGPテーブルを見ればわかります。R1のBGPテーブルは次のようになっています。

R1

R1#sh ip bgp
BGP table version is 83, local router ID is 192.168.123.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network          Next Hop            Metric LocPrf Weight Path
*> 123.1.0.0/16     0.0.0.0                            32768 i
s> 123.1.1.0/24     0.0.0.0                  0         32768 i
s> 123.1.2.0/24     0.0.0.0                  0         32768 i
s> 123.1.3.0/24     0.0.0.0                  0         32768 i
s> 123.1.4.0/24     0.0.0.0                  0         32768 i
s> 123.1.5.0/24     0.0.0.0                  0         32768 i
s> 123.1.6.0/24     0.0.0.0                  0         32768 i
s> 123.1.7.0/24     0.0.0.0                  0         32768 i

集約前のルート123.1.1.0/24~123.1.7.0/24のエントリの前に「s」が付きました。「s」はStatus codesのところにも出ているように「suppressed」を表します。日本語では「抑制」です。つまり、集約前のルートがアドバタイズされなくなっています。

図 summary-onlyオプション
図 summary-onlyオプション

summary-onlyまとめ

  • 集約前ルートをどうするかについてのオプション
  • 集約前ルートをアドバタイズせず、集約ルートのみをアドバタイズする
  • summary-onlyでアドバタイズするルートの数を減らすことができる

関連記事

BGPの仕組み

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA