概要

1台のレイヤ3スイッチでSVIおよびルーテッドポートの設定を行って、3つのネットワークを相互接続します。レイヤ3スイッチ内部の仮想ルータとVLAN、そしてポートとの関連付けをイメージすることが重要です。

ネットワーク構成

図 演習:レイヤ3スイッチの基本[Cisco] ネットワーク構成
図 演習:レイヤ3スイッチの基本[Cisco] ネットワーク構成

設定条件

  • L3SW1でSVIを作成してVLAN10とVLAN20を相互接続します。
  • L3SW1 Fa1/5をルーテッドポートとして設定します。
  • L3SW1に設定するIPアドレスは、以下の通りです。
インタフェースIPアドレス/サブネットマスク
Vlan10(SVI)192.168.10.254/24
Vlan20(SVI)192.168.20.254/24
Fa1/5192.168.30.254/24

初期設定

L3SW1

  • ホスト名
  • VLANとアクセスポートの割り当て

L3SW1 Initical Configuration

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname L3SW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
macro name add_vlan
end
vlan database
vlan $v
exit
@
macro name del_vlan
end
vlan database
no vlan $v
exit
@
!
vtp file nvram:vlan.dat
archive
 log config
  hidekeys
! 
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 duplex full
 speed 100
!
interface FastEthernet1/1
 switchport access vlan 10
 duplex full
 speed 100
!
interface FastEthernet1/2
 switchport access vlan 10
 duplex full
 speed 100
!
interface FastEthernet1/3
 switchport access vlan 20
 duplex full
 speed 100
!
interface FastEthernet1/4
 switchport access vlan 20
 duplex full
 speed 100
!
interface FastEthernet1/5
 duplex full
 speed 100
!
interface FastEthernet1/6
 duplex full
 speed 100
!
interface FastEthernet1/7
 duplex full
 speed 100
!
interface FastEthernet1/8
 duplex full
 speed 100
!
interface FastEthernet1/9
 duplex full
 speed 100
!
interface FastEthernet1/10
 duplex full
 speed 100
!
interface FastEthernet1/11
 duplex full
 speed 100
!
interface FastEthernet1/12
 duplex full
 speed 100
!
interface FastEthernet1/13
 duplex full
 speed 100
!
interface FastEthernet1/14
 duplex full
 speed 100
!
interface FastEthernet1/15
 duplex full
 speed 100
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner exec 

***************************************************************
This is a normal Router with a Switch module inside (NM-16ESW)
It has been pre-configured with hard-coded speed and duplex

To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config

To view existing vlans use the command "show vlan-switch brief"

Alias(exec)     : vl   - "show vlan-switch brief" command
Alias(configure): va X - macro to add vlan X
Alias(configure): vd X - macro to delete vlan X
***************************************************************


alias configure va macro global trace add_vlan $v
alias configure vd macro global trace del_vlan $v
alias exec vl show vlan-switch brief
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

PC1/PC2/PC3/PC4/PC5

  • ホスト名
  • IPアドレス/サブネットマスク、デフォルトゲートウェイ
PCIPアドレス/サブネットマスクデフォルトゲートウェイ所属するネットワーク(VLAN)
PC1192.168.10.1/24192.168.10.254192.168.10.0/24(VLAN10)
PC2192.168.10.2/24192.168.10.254192.168.10.0/24(VLAN10)
PC3192.168.20.3/24192.168.20.254192.168.20.0/24(VLAN20)
PC4192.168.20.4/24192.168.20.254192.168.20.0/24(VLAN20)
PC5192.168.30.5/24192.168.30.254192.168.30.0/24

演習で利用するコマンド

この演習では、以下のコマンドを利用します。

コマンド概要
(config)#interface vlan <vlan-id> (config-if)#ip address <ip-address> <subnetmask>SVIを作成してIPアドレス/サブネットマスクを設定します。
(config-if)#no switchport (config-if)#ip address <ip-address> <subnetmask>  ポートをルーテッドポートとしてIPアドレス/サブネットマスクを設定します。
#show ip interface briefインタフェースの状態とIPアドレスを表示します。
#show ip routeルーティングテーブルを表示します。
> ping <ip-address>(VPCS) VPCSでPingを実行します。

設定と確認

Step1:SVIの設定

L3SW1でIPルーティングを有効にします。そして、VLAN10とVLAN20を接続するためのSVIを作成してIPアドレス/サブネットマスクを設定します。

インタフェースIPアドレス/サブネットマスク
Vlan10(SVI)192.168.10.254/24
Vlan20(SVI)192.168.20.254/24

L3SW1 SVIの設定

ip routing
!
interface vlan 10
 ip address 192.168.10.254 255.255.255.0
 no shutdown
!
interface vlan 20
 ip address 192.168.20.254 255.255.255.0
 no shutdown

Step2:ルーテッドポートの設定

PC5が接続されているFa1/5をルーテッドポートにします。そして、ルーテッドポートに192.168.30.254/24のIPアドレス/サブネットマスクを設定します。

L3SW1 ルーテッドポートの設定

interface FastEthernet1/5
 no switchport
 ip address 192.168.30.254 255.255.255.0

Step3:SVI/ルーテッドポートの確認

SVI/ルーテッドポートに設定したIPアドレスを確認します。show ip interface briefコマンドがわかりやすいです。

L3SW1 show ip interface brief

L3SW1#show ip interface brief | exclude down
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet1/1            unassigned      YES unset  up                    up
FastEthernet1/2            unassigned      YES unset  up                    up
FastEthernet1/3            unassigned      YES unset  up                    up
FastEthernet1/4            unassigned      YES unset  up                    up
FastEthernet1/5            192.168.30.254  YES manual up                    up
Vlan10                     192.168.10.254  YES manual up                    up
Vlan20                     192.168.20.254  YES manual up                    up

「| exclude down」で文字列「down」が含まれている行の表示をフィルタして、up状態のインタフェースのみを表示しています。

次の図にL3SW1のSVIとルーテッドポートのIPアドレスをまとめています。

図 L3SW1のIPアドレス設定
図 L3SW1のIPアドレス設定

そして、IPアドレスを設定すると、ルーティングテーブルに直接接続のルート情報が登録されます。IPアドレスを設定することが、ネットワークを繋ぐことなのです。

ルーティングテーブルを確認して、L3SW1で3つのネットワークを接続していることを確認します。

L3SW1 show ip route

L3SW1#show ip route
~省略~

Gateway of last resort is not set

C    192.168.30.0/24 is directly connected, FastEthernet1/5
C    192.168.10.0/24 is directly connected, Vlan10
C    192.168.20.0/24 is directly connected, Vlan20

L3SW1が3つのネットワークを相互接続している論理構成図は、次の図のようになります。

図 論理構成
図 論理構成

Step4:通信確認

L3SW1で3つのネットワークが相互接続されているので、3つのネットワーク間の通信ができます。PC1から他のPCへPingを実行してネットワーク間の通信を確認します。

PC1 Ping

PC1> ping 192.168.10.2
84 bytes from 192.168.10.2 icmp_seq=1 ttl=64 time=0.614 ms
84 bytes from 192.168.10.2 icmp_seq=2 ttl=64 time=0.718 ms
84 bytes from 192.168.10.2 icmp_seq=3 ttl=64 time=0.879 ms
84 bytes from 192.168.10.2 icmp_seq=4 ttl=64 time=0.667 ms
84 bytes from 192.168.10.2 icmp_seq=5 ttl=64 time=0.943 ms

PC1> ping 192.168.20.3
84 bytes from 192.168.20.3 icmp_seq=1 ttl=63 time=30.797 ms
84 bytes from 192.168.20.3 icmp_seq=2 ttl=63 time=30.112 ms
84 bytes from 192.168.20.3 icmp_seq=3 ttl=63 time=30.530 ms
84 bytes from 192.168.20.3 icmp_seq=4 ttl=63 time=30.569 ms
84 bytes from 192.168.20.3 icmp_seq=5 ttl=63 time=30.400 ms

PC1> ping 192.168.20.4
84 bytes from 192.168.20.4 icmp_seq=1 ttl=63 time=31.009 ms
84 bytes from 192.168.20.4 icmp_seq=2 ttl=63 time=31.080 ms
84 bytes from 192.168.20.4 icmp_seq=3 ttl=63 time=30.629 ms
84 bytes from 192.168.20.4 icmp_seq=4 ttl=63 time=30.528 ms
84 bytes from 192.168.20.4 icmp_seq=5 ttl=63 time=30.605 ms

PC1> ping 192.168.30.5
84 bytes from 192.168.30.5 icmp_seq=1 ttl=63 time=31.203 ms
84 bytes from 192.168.30.5 icmp_seq=2 ttl=63 time=30.330 ms
84 bytes from 192.168.30.5 icmp_seq=3 ttl=63 time=30.509 ms
84 bytes from 192.168.30.5 icmp_seq=4 ttl=63 time=30.529 ms
84 bytes from 192.168.30.5 icmp_seq=5 ttl=63 time=29.848 ms

関連記事

関連記事

VLAN(Virtual LAN)の仕組み