IPテレフォニーの概要

企業の社内ネットワークでは、音声通話をTCP/IPネットワークで実現するIPテレフォニーが導入されることが多くなっています。

IPテレフォニーは既存の電話機の代わりにIP Phone(IP電話)を導入します。IP Phoneは、電話機自体で音声をIPパケットに変換して転送することができ、LANに接続して利用します。

そして、IP Phoneの通話を制御するためのIP-PBXをLANに接続します。IP-PBXには専用装置もあれば、サーバに専用ソフトウェアをインストールする形態もあります。IP-PBXは「呼制御サーバ」とも呼ばれます。Ciscoでは、IP-PBXとしてCisco Unified Communication Managerを提供しています。

IP Phoneの接続

IP Phoneはスイッチに直接接続します。すると、IP Phoneを接続するためにスイッチのポートがより多く必要になってしまいます。ユーザ一人あたりホスト用とIP Phone用の2ポート、単純計算で2倍のポートが必要です。

そこで、スイッチのポート消費を抑えるために、2つのイーサネットポートを持つIP Phoneがあります。IP Phoneが簡易的なスイッチの機能を持ち、ホストは次の図のようにIP Phone経由でスイッチに接続し、社内LANにアクセスできるようになります。

スイッチ、IP Phoneとホストの接続
図 スイッチ、IP Phoneとホストの接続

上記の物理的な接続構成に基づいて、論理構成をホストが所属するデータVLANとIP Phoneが所属するVoice VLAN(音声VLAN)というように分割します。

図データVLANとVoice VLAN
図データVLANとVoice VLAN

データVLANとVoice VLANに分割することで、論理的にIP Phoneのパケットとホストのパケットを分離することができます。IP Phoneの音声パケットの転送は片方向の遅延が150ms以内にするように推奨されています。そのために、QoSを行います。Voice VLANを利用すれば、IP Phoneの音声パケットのIPアドレスはVoice VLANのネットワークのものになります。すると、音声パケットの識別が容易になり、QoSの設定を行いやすくなります。

データ用VLANは、通常、IEEE802.1QトランクのネイティブVLANとして設定します。つまり、ホストから送信されるデータはVLANタグをつけずにそのままIP Phoneからスイッチに転送されます。IP Phoneは音声パケットにVoice VLANのVLANタグをつけてスイッチに送信します。IPアドレスに基づいた優先制御以外にも、Voice VLANのVLANタグのPriorityを特定の値にセットして、IP Phoneのパケットを優先するような制御も可能です。

音声パケットとデータパケットの送信
図 音声パケットとデータパケットの送信

IP Phoneを接続するためのスイッチの設定(Voice VLAN)

IP Phoneを接続するためのスイッチの設定について解説します。IP Phoneおよびホストを接続するポートのインタフェースコンフィグレーションモードで次の設定を行います。

CiscoのVoice VLANの設定は、「データVLANとVoice VLANの2つのVLANに割り当てられるアクセスポート」と考えるとわかりやすくなります。本来、アクセスポートは1つのVLANだけに割り当てるポートですが、Voice VLANの設定によって追加でもう1つVLANの割り当てができます。

スタティックアクセスポートの設定

Switch(config-if)#switchport mode access

データ用のVLANをアクセスポートのVLANメンバーシップに設定

Switch(config-if)#switchport access vlan <vlan-id>

<vlan-id> : データVLANのVLAN番号

データVLANの割り当ては、アクセスポートとしてのVLANメンバーシップの設定で、switchport access vlanコマンドです。データVLANのイーサネットフレームはVLANタグをつけないネイティブVLAN扱いです。

Voice VLANの設定

Switch(config-if)#switchport voice vlan <vlan-id>

<vlan-id> : Voice VLANのVLAN番号

そして、Voice VLANの割り当ては、switchport voice vlanコマンドで指定します。IP Phoneが接続されることになるVoice VLANのイーサネットフレームにはVLANタグが付加されます。

PortFastの設定

Switch(config-if)#spanning-tree portfast

また、IP Phoneがスイッチに接続された際に、すぐにポートを利用できるようにspanning-tree portfastコマンドでPortFastを有効にします。

Voice VLANの設定コマンドのまとめ
図 Voice VLANの設定コマンドのまとめ

IP PhoneからスイッチにデータVLANとVoice VLANのイーサネットフレームを転送するには、IP PhoneでもVoice VLANの情報が必要です。スイッチ側で設定したVoice VLANの情報はCDPでIP Phoneへ通知されます。


PortFastは、以下のページで解説しています。


Voice VLANの設定例

次の図のSW1のVoice VLANの設定例を考えます。

IP Phone接続の設定例
図 IP Phone接続の設定例

SW1

interface fastethernet0/1
 switchport mode access
 switchport access vlan 200
 switchport voice vlan 100
 spanning-tree portfast

Voice VLANのVLAN番号を確認するには、show interface <interface> switchportコマンドを使います。設定例におけるshowコマンドは次のようになります。

SW1#show interfaces fastethernet0/1 switchport 
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 200 (VLAN0200)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: 100 (VLAN0100)
~省略~

また、show vlan briefを確認すると、Fa0/1はデータVLANとVoice VLANの2つのVLANのアクセスポートとして表示されます。

SW1#show vlan brief 

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24, Gi0/1, Gi0/2
100  VLAN0100                         active    Fa0/1
200  VLAN0200                         active    Fa0/1
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup

Fa0/1でVLAN100とVLAN200の2つのVLANのイーサネットフレームを転送できるようにしているので動作としてはトランクポートです。ただ、CiscoのVoice VLANはアクセスポートとして割り当てるVLANを1つ追加している設定なので、show vlan briefコマンドで確認できます。