VPCSとは

VPCS(Virtual PC Simulator)とは、負荷の軽いPCのシミュレータです。GNS3プロジェクトのネットワーク構成上でVPCSを利用して、Pingやトレースルートなどのネットワークの接続性の確認ができます。ホスト代わりにルータを利用するよりも、VPCSを利用するほうがPCへの負荷が軽くなります。

VPCSの設定とPingやトレースルートなどの操作について解説します。

VPCSの設定

IPアドレス/サブネットマスク、デフォルトゲートウェイの設定(スタティック)

VPCSのコンソールに接続して、以下のコマンドでIPアドレス/サブネットマスクとデフォルトゲートウェイを設定します。

VPCS IPアドレス/サブネットマスク、デフォルトゲートウェイの設定

VPCS>ip <ip-address> <subnetmask> <default-gateway>

<ip-address> : IPアドレス
<subnetmask> : サブネットマスク。10進表記でもプレフィクス表記でもOK
<default-gateway> : デフォルトゲートウェイのIPアドレス

DNSサーバのIPアドレスの設定

DNSサーバのIPアドレスの設定は以下のコマンドです。

VPCS DNSサーバのIPアドレスの設定

VPCS>ip dns <dns-server>

<dns-server> : DNSサーバのIPアドレス

DHCPクライアント

DHCPクライアントとして、IPアドレスなどをDHCPサーバから取得するには、以下のコマンドです。

VPCS DHCPクライアントの設定

VPCS>ip dhcp

ホスト名の設定

ホスト名を変更するには、次のコマンドを入力します。

VPCS ホスト名の設定

VPCS>set pcname <name>

<name> : ホスト名

TCP/IP設定の確認

設定したIPアドレスなどのTCP/IP設定の確認は、次のコマンドを入力します。

VPCS TCP/IP設定の確認

VPCS>show ip

TCP/IP設定のクリア

IPアドレスなどのTCP/IP設定を削除するには、以下のコマンドを利用します。

VPCS TCP/IP設定のクリア

VPC>clear ip

設定の保存

設定の保存を行うには、saveコマンドを使います。

VPCS 設定の保存

VPCS>save <file-name>

<file-name> : 設定ファイル名

設定ファイル名を省略すると、デフォルトのstarup.vpcファイルに設定が保存されます。設定ファイルは<GNSプロジェクトパス>\project-files\vpcs\<VPCSのUUID>\にあります。

VPCSの操作

Ping

Pingを実行するには、以下のコマンドを利用します。

VPCS Ping

VPCS>ping <ip-address>

<ip-address> : 宛先IPアドレス

TCP Ping/UDP Ping

通常のPingだけでなく、TCP Ping、UDP Pingも実行できます。VPCSから手軽にTCPセグメントやUDPデータグラムを送信できます。TCP PingでTCPセグメントを送信するには、以下のコマンドです。

VPCS TCP Ping

VPCS>ping <ip-address> -P 6 -p <port>

<ip-address> : 宛先IPアドレス
<port> : 宛先ポート番号

「-P 6」でTCPを表しています。6はTCPを表すプロトコル番号です。

UDP PingでUDPデータグラムを送信するには、以下のコマンドです。

VPCS UDP Ping

VPCS>ping <ip-address> -P 17 -p <port>

<ip-address> : 宛先IPアドレス
<port> : 宛先ポート番号

「-P 17」でUDPを表しています。17はUDPを表すプロトコル番号です。

トレースルート

トレースルートを実行するには、以下のコマンドを利用します。

VPCS トレースルート

VPCS>trace <ip-address>

<ip-address> : 宛先IPアドレス

ARPキャッシュの表示

ARPキャッシュを確認するには、以下のコマンドを利用します。

VPCS ARPキャッシュの表示

VPCS>show arp

VPCSの設定例

次のシンプルなネットワーク構成でVPCSの設定と通信確認を行います。

R1はDHCPサーバとしてDHCPプールを設定しています。また、Fa0/0にACLを適用しています。

R1#show running-config | section ip dhcp
no ip dhcp use vrf connected
ip dhcp pool AAA
   network 192.168.12.0 255.255.255.0
   default-router 192.168.12.1
   dns-server 8.8.8.8
R1#show running-config | section access-list
access-list 100 permit tcp any any eq 80 
access-list 100 permit udp any any eq 53
access-list 100 permit ip any any
R1#show run int fa 0/0
Building configuration...

Current configuration : 121 bytes
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip access-group 100 in
 duplex auto
 speed auto
end

TCP/IP設定(スタティック)

VPCSにスタティックでTCP/IP設定を行います。

  • IPアドレス/サブネットマスク : 192.168.12.100/24
  • デフォルトゲートウェイ : 192.168.12.1
  • DNSサーバのIPアドレス : 8.8.8.8

VPCS

VPCS> ip 192.168.12.100 255.255.255.0 192.168.12.1
Checking for duplicate address...
PC1 : 192.168.12.100 255.255.255.0 gateway 192.168.12.1

VPCS> ip dns 8.8.8.8

VPCS> show ip

NAME        : VPCS[1]
IP/MASK     : 192.168.12.100/24
GATEWAY     : 192.168.12.1
DNS         : 8.8.8.8
MAC         : 00:50:79:66:68:00
LPORT       : 10016
RHOST:PORT  : 127.0.0.1:10017
MTU:        : 1500

TCP/IP設定(DHCP)

VPCSのスタティック設定を削除して、DHCPクライアントにします。

VPCS

VPCS> clear ip
IPv4 address/mask, gateway, DNS, and DHCP cleared

VPCS> ip dhcp
DDORA IP 192.168.12.3/24 GW 192.168.12.1

VPCS> show ip

NAME        : VPCS[1]
IP/MASK     : 192.168.12.3/24
GATEWAY     : 192.168.12.1
DNS         : 8.8.8.8
DHCP SERVER : 192.168.12.1
DHCP LEASE  : 86396, 86400/43200/75600
MAC         : 00:50:79:66:68:00
LPORT       : 10016
RHOST:PORT  : 127.0.0.1:10017
MTU:        : 1500

Ping

VPCSからR1にPingを実行します。

VPCS

VPCS> ping 192.168.12.1
84 bytes from 192.168.12.1 icmp_seq=1 ttl=255 time=6.259 ms
84 bytes from 192.168.12.1 icmp_seq=2 ttl=255 time=6.433 ms
84 bytes from 192.168.12.1 icmp_seq=3 ttl=255 time=7.197 ms
84 bytes from 192.168.12.1 icmp_seq=4 ttl=255 time=5.321 ms
84 bytes from 192.168.12.1 icmp_seq=5 ttl=255 time=6.258 ms

TCP Ping/UDP Ping

VPCSからR1に宛先ポート番号80でTCP Ping、宛先ポート番号53でUDP Pingを実行します。

VPCS

VPCS> ping 192.168.12.1 -P 6 -p 80
Connect   80@192.168.12.1 RST returned
Connect   80@192.168.12.1 RST returned
Connect   80@192.168.12.1 RST returned
Connect   80@192.168.12.1 RST returned
Connect   80@192.168.12.1 RST returned

VPCS> ping 192.168.12.1 -P 17 -p 53
*192.168.12.1 udp_seq=1 ttl=255 time=10.087 ms (ICMP type:3, code:3, Destination port unreachable)
*192.168.12.1 udp_seq=2 ttl=255 time=3.372 ms (ICMP type:3, code:3, Destination port unreachable)
*192.168.12.1 udp_seq=3 ttl=255 time=5.326 ms (ICMP type:3, code:3, Destination port unreachable)
*192.168.12.1 udp_seq=4 ttl=255 time=8.978 ms (ICMP type:3, code:3, Destination port unreachable)
*192.168.12.1 udp_seq=5 ttl=255 time=6.009 ms (ICMP type:3, code:3, Destination port unreachable)

R1でshow access-listsを見ると、宛先ポート番号80のTCPセグメントと宛先ポート番号53のUDPセグメントを受信していることがわかります。

R1

R1#show access-lists
Extended IP access list 100
    10 permit tcp any any eq www (30 matches)
    20 permit udp any any eq domain (30 matches)
    30 permit ip any any (128 matches)

トレースルート

VPCSからR1へトレースルートを実行します。

VPCS

VPCS> trace 192.168.12.1
trace to 192.168.12.1, 8 hops max, press Ctrl+C to stop
 1   *192.168.12.1   9.203 ms (ICMP type:3, code:3, Destination port unreachable)

ARPキャッシュの表示

show arpコマンドでVPCSのARPキャッシュを表示します。

VPCS

VPCS> show arp

cc:01:29:a8:00:00  192.168.12.1 expires in 63 seconds

関連記事