概要

EIGRPについて、フィージブルサクセサ選出の様子を理解するための設定例です。また、スタブのオプションの設定によってアドバタイズするルートがどのように変わるかも確認できます。

ネットワーク構成

図 EIGRPの設定例 ネットワーク構成
図 EIGRPの設定例 ネットワーク構成

EIGRPの基本設定と確認

Step1.EIGRPの有効化

R1~R3でEIGRPをAS番号1でルーティングプロセスを有効化して、すべてのインタフェースでEIGRPを有効にします。また、自動集約を無効化します。

R1 EIGRPの有効化

router eigrp 1
 network 192.168.12.0
 network 192.168.13.0
 network 10.0.0.0
 no auto-summary

R2 EIGRPの有効化

router eigrp 1
 network 192.168.12.0
 network 192.168.23.0
 no auto-summary

R3 EIGRPの有効化

router eigrp 1
 network 192.168.13.0
 network 192.168.23.0
 no auto-summary

Step2.EIGRPの確認

show ip protocolsコマンドでEIGRPの概要を確認します。R1では、次のような表示になります。

R1 show ip protocols

R1#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.12.0
    192.168.13.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:09:13
    192.168.13.3          90      00:00:15
    192.168.12.2          90      00:00:16
  Distance: internal 90 external 170

show ip eigrp interfaceコマンドでEIGRPが有効なインタフェースを確認します。R1では、次のようになります

R1 show ip eigrp interface

R1#show ip eigrp interfaces
IP-EIGRP interfaces for process 1

                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0.12       1        0/0       140       0/10         704           0
Fa0/0.13       1        0/0       694       0/10        3472           0
Lo0            0        0/0         0       0/10           0           0

show ip eigrp neighborコマンドでEIGRPネイバーを確認します。R1では次のようになります。

R1 show ip eigrp neighbor

R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
1   192.168.13.3            Fa0/0.13      12 00:14:59  694  4164  0  17   
0   192.168.12.2            Fa0/0.12      10 00:15:27  140   840  0  17   

show ip eigrp topologyコマンドでEIGRPトポロジテーブルを確認します。R1では、次のようになります。

R1 show ip eigrp toplogy

R1#show ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.2.0/24, 1 successors, FD is 128256
         via Connected, Loopback0
P 10.1.1.0/24, 1 successors, FD is 128256
         via Connected, Loopback0
P 192.168.12.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0.12
P 192.168.13.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0.13
P 192.168.23.0/24, 2 successors, FD is 30720
         via 192.168.13.3 (30720/28160), FastEthernet0/0.13
         via 192.168.12.2 (30720/28160), FastEthernet0/0.12

現在、トポロジーテーブルではサクセサルートのみが表示されています。また、192.168.23.0/24のルート情報は最小メトリックのものが2つあるので、2つともサクセサルートとなっています。

show ip routeコマンドでルーティングテーブルを確認します。R1では、次のようになります。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0.12
C    192.168.13.0/24 is directly connected, FastEthernet0/0.13
     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.2.0 is directly connected, Loopback0
C       10.1.1.0 is directly connected, Loopback0
D    192.168.23.0/24 [90/30720] via 192.168.13.3, 00:00:26, FastEthernet0/0.13
                     [90/30720] via 192.168.12.2, 00:00:26, FastEthernet0/0.12

Step3.サクセサとフィージブルサクセサの確認

R3で10.1.1.0/24に対するサクセサとフィージブルサクセサをshow ip eigrp topologyコマンドで確認します。

R3 show ip eigrp topology

R3#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.2.0/24, 1 successors, FD is 156160
         via 192.168.13.1 (156160/128256), FastEthernet0/0.13
P 10.1.1.0/24, 1 successors, FD is 156160
         via 192.168.13.1 (156160/128256), FastEthernet0/0.13
P 192.168.12.0/24, 2 successors, FD is 30720
         via 192.168.13.1 (30720/28160), FastEthernet0/0.13
         via 192.168.23.2 (30720/28160), FastEthernet0/0.23
P 192.168.13.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0.13
P 192.168.23.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0.23

R3から10.1.1.0/24までのルートはR2経由のものもありますが、フィージブルサクセサとはなっていません。

R3で10.1.1.10/24に対するサクセサとフィージブルサクセサ以外の全EIGRPルートを確認するために、show ip eigrp topology detailed-linksコマ
ンドを使います。

R3 show ip eigrp topology detailed-links

R3#show ip eigrp topology detail-links
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.2.0/24, 1 successors, FD is 156160, serno 43
         via 192.168.13.1 (156160/128256), FastEthernet0/0.13
         via 192.168.23.2 (158720/156160), FastEthernet0/0.23
P 10.1.1.0/24, 1 successors, FD is 156160, serno 42
         via 192.168.13.1 (156160/128256), FastEthernet0/0.13
         via 192.168.23.2 (158720/156160), FastEthernet0/0.23
P 192.168.12.0/24, 2 successors, FD is 30720, serno 35
         via 192.168.23.2 (30720/28160), FastEthernet0/0.23
         via 192.168.13.1 (30720/28160), FastEthernet0/0.13
P 192.168.13.0/24, 1 successors, FD is 28160, serno 1
         via Connected, FastEthernet0/0.13
P 192.168.23.0/24, 1 successors, FD is 28160, serno 6, Stats m(24)M(24)A(24)c(1)
         via Connected, FastEthernet0/0.23

R3で10.1.1.0/24へのフィージブルサクセサが選ばれていないのは、R2経由のルートがフィージビリティ条件を満たしていないからです。サクセサのFDとルートのADを比較すると、同じ値になっています。

Step4.Delayの調整

R3で10.1.1.10/24に対するフィージブルサクセサが選ばれるように、R2のFa0/0.12のDelayを小さく設定します。

R2 delayの調整

interface fa 0/0.12
 delay 1

Step5.サクセサとフィージブルサクセサの確認

再度、R3でshow ip eigrp topologyコマンドを確認します。

R3 show ip eigrp topology

R3#show ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.2.0/24, 1 successors, FD is 156160
         via 192.168.13.1 (156160/128256), FastEthernet0/0.13
         via 192.168.23.2 (156416/153856), FastEthernet0/0.23
P 10.1.1.0/24, 1 successors, FD is 156160
         via 192.168.13.1 (156160/128256), FastEthernet0/0.13
         via 192.168.23.2 (156416/153856), FastEthernet0/0.23
P 192.168.12.0/24, 1 successors, FD is 28416
         via 192.168.23.2 (28416/25856), FastEthernet0/0.23
         via 192.168.13.1 (30720/28160), FastEthernet0/0.13
P 192.168.13.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0.13
P 192.168.23.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0.23

R2でDelayを小さくしたことでフィージビリティ条件を満たし、フィージブルサクセサが現れるようになります。

Step6.ルート集約の設定

R1のFa0/0.13をシャットダウンし、R2に対して集約ルート10.1.0.0/16を送信します。

R1 ルート集約の設定

interface fa 0/0.13
 shutdown
!
interface fa 0/0.12
ip summary-address eigrp 1 10.1.0.0 255.255.0.0

Step7.ルート集約の確認

R1でshow ip eigrp topologyコマンドで集約した10.1.0.0/16がトポロジーテーブルに載せられていることを確認します。

R1 show ip eigrp topology

R1#sh ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.1.2.0/24, 1 successors, FD is 128256
         via Connected, Loopback0
P 10.1.1.0/24, 1 successors, FD is 128256
         via Connected, Loopback0
P 10.1.0.0/16, 1 successors, FD is 128256
         via Summary (128256/0), Null0
P 192.168.12.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0.12
P 192.168.13.0/24, 1 successors, FD is 33280
         via 192.168.12.2 (33280/30720), FastEthernet0/0.12
P 192.168.23.0/24, 1 successors, FD is 30720
         via 192.168.12.2 (30720/28160), FastEthernet0/0.12

R1でshow ip route eigrpコマンドで集約ルート10.1.0.0/16がルーティングテーブルに載せられていることを確認します。

R1 show ip route

R1#show ip route eigrp 
D    192.168.13.0/24 [90/33280] via 192.168.12.2, 00:00:21, FastEthernet0/0.12
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.1.0.0/16 is a summary, 00:00:27, Null0
D    192.168.23.0/24 [90/30720] via 192.168.12.2, 00:00:21, FastEthernet0/0.12

R2でルーティングテーブルを確認します。

R2 show ip route

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0.12
D    192.168.13.0/24 [90/30720] via 192.168.23.3, 00:03:50, FastEthernet0/0.23
     10.0.0.0/16 is subnetted, 1 subnets
D       10.1.0.0 [90/153856] via 192.168.12.1, 00:03:29, FastEthernet0/0.12
C    192.168.23.0/24 is directly connected, FastEthernet0/0.23

Step8.EIGRP Stubの設定(connected)

R1に新しいLoopbackインタフェースを作成して、Loopback1でEIGRPを有効化します。

Loopback1 172.16.0.1/16
Loopback2 172.31.0.1/16

R1

interface loopback1
 ip address 172.16.0.1 255.255.0.0
!
interface loopback2
 ip address 172.31.0.1 255.255.0.0
!
router eigrp 1
 network 172.16.0.0

R1でEIGRP Stubの設定を行います。Stubのオプションは、connectedを指定します。

R1 stub connected

router eigrp 1
 eigrp stub connected

Step9.EIGRP Stubの確認

R2でshow ip eigrp neighbor detailコマンドでネイバーの詳細を確認します。

R2 show ip eigrp neighbor detail

R2#sh ip eigrp neighbors detail
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
0   192.168.12.1            Fa0/0.12      12 00:00:44  953  5000  0  56
   Version 12.2/1.2, Retrans: 0, Retries: 0
   Stub Peer Advertising ( CONNECTED ) Routes

R2でR1がEIGRP Stubであることを認識しています。そして、R2でshow ip eigrp topologyコマンドでR1から受信したルート情報を確認します。

R2 show ip eigrp topology

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.2.0/24, 1 successors, FD is 153856
         via 192.168.12.1 (153856/128256), FastEthernet0/0.12
P 10.1.1.0/24, 1 successors, FD is 153856
         via 192.168.12.1 (153856/128256), FastEthernet0/0.12
P 192.168.12.0/24, 1 successors, FD is 25856
         via Connected, FastEthernet0/0.12
P 172.16.0.0/16, 1 successors, FD is 153856
         via 192.168.12.1 (153856/128256), FastEthernet0/0.12

R2では、networkコマンドによってアドバタイズされたR1の直接接続のルート(10.1.1.0/24、10.1.2.0/24)が確認できます。

Step10.EIGRP stubの設定(summary)

R1でStubのオプションをsummaryに変更します。

R1

router eigrp 1
 eigrp stub summary

Step11.EIGRP stubの確認

R2でshow ip eigrp topologyコマンドでR1から受信したルート情報を確認します。

R2 show ip eigrp topology

R2#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.0.0/16, 1 successors, FD is 153856
         via 192.168.12.1 (153856/128256), FastEthernet0/0.12
P 192.168.12.0/24, 1 successors, FD is 25856
         via Connected, FastEthernet0/0.12

EIGRP Stubのオプションをsummaryに変更したことで、R2では、R1の集約ルート(10.1.0.0/16)が確認できます。

Step12.EIGRP stubの設定(static)

R1でR1で1.1.1.1/32に対するスタティックルートを設定し、EIGRPに再配送します。Stubのオプションをstaticに変更します。

R1

ip route 1.1.1.1 255.255.255.255 10.1.1.2 
!
router eigrp 1
 redistribute static
 eigrp stub static

Step13.EIGRP Stubの確認

R2でshow ip eigrp topologyコマンドでR1から受信したルート情報を確認します。

R2 show ip eigrp topology

R2#sho ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.1/32, 1 successors, FD is 153856
         via 192.168.12.1 (153856/128256), FastEthernet0/0.12
P 192.168.12.0/24, 1 successors, FD is 25856
         via Connected, FastEthernet0/0.12

EIGRP Stubのオプションをstaticに変更すると、R2ではR1でEIGRPに再配送されたスタティックルート(1.1.1.1/32)が確認できます。

Step14.EIGRP Stubの設定(receive-only)

R1でStubのオプションをreceive-onlyに変更します。

R1

router eigrp 1
 eigrp stub receive-only

Step15.EIGRP Stubの確認

R2でshow ip eigrp topologyコマンドでR1から受信したルート情報を確認します。

R2 show ip eigrp topology

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.12.0/24, 1 successors, FD is 25856
         via Connected, FastEthernet0/0.12

EIGRP Stubのオプションをreceive-onlyにすると、R1はルートを送信していないことがわかります。

関連記事