概要

不連続サブネットのアドレス構成のネットワークでEIGRPを利用するときの設定ミスについて切り分けと修正を行います。

ネットワーク構成

次のネットワーク構成でEIGRPによるルーティングを行い、ホスト間の通信を行います。

図 EIGRP 設定ミスの切り分けと修正 Part3 ネットワーク構成
図 EIGRP 設定ミスの切り分けと修正 Part3 ネットワーク構成

なお、Host1/Host2はR1/R3のLoopback0インタフェースとして利用しています。

設定概要

R1~R3のEIGRPに関する設定は以下の通りです。

R1

interface Loopback0
 ip address 172.16.1.100 255.255.255.248
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
!         
!
router eigrp 1
 network 172.16.0.0
 network 192.168.12.0
 auto-summary

R2

interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
 ip address 172.16.23.2 255.255.255.192
!
router eigrp 1
 network 172.16.0.0
 network 192.168.12.0
 auto-summary

R3

interface Loopback0
 ip address 172.16.3.100 255.255.255.248
!
interface FastEthernet0/0
 ip address 172.16.23.3 255.255.255.192
!         
!
router eigrp 1
 network 172.16.0.0
 auto-summary

トラブルの症状

現在のR1~R3のEIGRP設定では、Host1とHost2間の通信ができていません。R1~R3でのEIGRPのルーティングを確認すると、EIGRPネイバーを確立しているのですが、ルーティングテーブルに必要なルート情報が正しく登録されていません。トラブルの原因を調べるために、以下のshowコマンドを実行しました。

  • show ip protocols
  • show ip eigrp neighbor
  • show ip route eigrp

R1

R1#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Automatic address summarization:
    192.168.12.0/24 for Loopback0
    172.16.0.0/16 for FastEthernet0/0
      Summarizing with metric 128256
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      02:15:23
    192.168.12.2          90      02:15:23
    172.16.12.2           90      02:15:45
  Distance: internal 90 external 170

R1#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.2            Fa0/0             12 02:15:25   30   200  0  15
R1#show ip route eigrp
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 02:15:23, Null0

R2

R2#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Automatic address summarization:
    192.168.12.0/24 for FastEthernet1/0
    172.16.0.0/16 for FastEthernet0/0
      Summarizing with metric 28160
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:00:25
    192.168.12.1          90      00:00:25
    172.16.23.3           90      00:00:29
  Distance: internal 90 external 170

R2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.12.1            Fa0/0             12 00:00:30   55   330  0  11
0   172.16.23.3             Fa1/0             13 00:00:34   60   360  0  10
R2#show ip route eigrp
     172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
D       172.16.0.0/16 is a summary, 00:00:25, Null0
D       172.16.3.96/29 [90/156160] via 172.16.23.3, 00:00:29, FastEthernet1/0

R3

R3#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.23.2           90      00:02:08
  Distance: internal 90 external 170

R3#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.23.2             Fa0/0             12 00:02:09  228  1368  0  6
R3#show ip route eigrp
D    192.168.12.0/24 [90/30720] via 172.16.23.2, 00:02:08, FastEthernet0/0

問題

  • ホスト間の通信ができない理由は何ですか。
  • ホスト間の通信ができるようにするためには、どのように設定を修正すればよいですか。

解答

ホスト間の通信ができない理由は何ですか。

不連続サブネットのアドレッシングで、自動集約が行われているためルーティングテーブルに必要なルート情報が正しく登録されていない。

ホスト間の通信ができるようにするためには、どのように設定を修正すれば
よいですか。

R1/R2/R3

router eigrp 1
 no auto-summary

ワンポイント

  • RIPv2/EIGRPでは、デフォルトで自動集約が有効になっている
  • 不連続サブネットのアドレッシングでは、メジャーネットワーク境界で自動集約を無効化しなければいけない

解説

不連続サブネットのアドレッシングでディスタンスベクタ系ルーティングプロトコルを利用する場合の設定ミスです。RIPv2/EIGRPといったディスタンスベクタ系のルーティングプロトコルは、デフォルトで自動集約が有効化されています。メジャーネットワーク境界で、クラスフルアドレスに自動的に集約して、ルート情報をアドバタイズします。

今回考えているネットワーク構成では、R1およびR2がメジャーネットワーク境界となっています。R1は自動集約により、Host1の172.16.1.96/29のルート情報を172.16.0.0/16に集約してR2へアドバタイズします。また、R2は172.16.23.0/26と172.16.3.96/29を172.16.0.0/16に集約してR1へアドバタイズします。その結果、R1、R2で必要なルート情報を学習することができません。これがホスト間の通信ができない原因です。

図 R1、R2でのルート情報のアドバタイズ
図 R1、R2でのルート情報のアドバタイズ

不連続サブネットのアドレッシングでは、自動集約を無効化しなければいけません。各ルータで以下の設定によって、自動集約を無効化します。

R1/R2/R3

router eigrp 1
 no auto-summary

自動集約の無効化は、メジャーネットワーク境界のR1とR2だけで十分です。R3での自動集約の無効化は、今回のネットワーク構成では不要です。

自動集約を無効化したあと、各ルータのルーティングテーブルを確認すると、次のようになります。

R1 show ip route

R1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.23.0/26 [90/30720] via 192.168.12.2, 00:00:13, FastEthernet0/0
C       172.16.1.96/29 is directly connected, Loopback0
D       172.16.3.96/29 [90/158720] via 192.168.12.2, 00:00:13, FastEthernet0/0

R2 show ip route

R2#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.23.0/26 is directly connected, FastEthernet1/0
D       172.16.1.96/29 [90/156160] via 192.168.12.1, 00:00:41, FastEthernet0/0
D       172.16.3.96/29 [90/156160] via 172.16.23.3, 00:25:56, FastEthernet1/0

R3 show ip route

R3#show ip route 
~省略~

Gateway of last resort is not set

D    192.168.12.0/24 [90/30720] via 172.16.23.2, 00:26:24, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.23.0/26 is directly connected, FastEthernet0/0
D       172.16.1.96/29 [90/158720] via 172.16.23.2, 00:01:09, FastEthernet0/0
C       172.16.3.96/29 is directly connected, Loopback0

R1~R3のルーティングテーブルに必要なルート情報が正しく登録されるようになったのでホスト間の通信を行うことができます。

ホスト間の通信確認

R1#ping 172.16.3.100 source 172.16.1.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.100, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.100 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/15/24 ms

関連記事