概要

シンプルなネットワーク構成で、ルート集約とEIGRPスタブについての基本的な設定と確認を行います。

ネットワーク構成

図 EIGRPのルート集約とスタブの設定例 ネットワーク構成
図 EIGRPのルート集約とスタブの設定例 ネットワーク構成

設定条件

  • R3でインターネットに接続するためにデフォルトルートをスタティックで設定します。また、EIGRPでデフォルトルートをアドバタイズします。
  • R2はR1に対してEIGRPクエリーを送信しないようにします。
  • R2からR1へEIGRPドメインのルートを集約してアドバタイズします。

確認条件

  • R1~R3でルーティングテーブルにデフォルトルートが存在していること
  • R1をEIGRPスタブとして認識していること
  • R1のルーティングテーブルに10.1.4.0/24~10.1.7.0/24を集約した10.1.4.0/22が存在していること

初期設定

以下の設定は設定済みとします。

  • ホスト名
  • IPアドレス
  • ISPのルーティング
  • EIGRP
    各ルータのインタフェースはネットワーク構成のとおりEIGRPが有効化されている
  • 自動集約の無効化

設定

Step1:デフォルトルートの設定と再配送

R3でISPをネクストホップとするデフォルトルートをスタティックで設定します。そして、デフォルトルートをEIGRPドメインにアドバタイズするために、スタティックルートを再配送します。

R3

router eigrp 1
 redistribute static
!
ip route 0.0.0.0 0.0.0.0 100.1.1.10

Step2:デフォルトルートの確認

R3からアドバタイズされているデフォルトルートを確認します。R3でshow ip eigrp topologyでEIGRPルートとしてデフォルトルートが生成されていることを確認します。また、show ip routeでR1、R2のルーティングテーブルにデフォルトルートが存在することを確認します。

R3 show ip eigrp topology

R3#show ip eigrp topology 0.0.0.0/0
IP-EIGRP (AS 1): Topology entry for 0.0.0.0/0
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  100.1.1.10, from Rstatic, Send flag is 0x0
      Composite metric is (281600/0), Route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
      External data:
        Originating router is 100.1.1.3 (this system)
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)
        Exterior flag is set

R1 show ip route

R1#show ip route 
~省略~

Gateway of last resort is 10.1.0.2 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 6 subnets
C       10.1.1.0 is directly connected, Ethernet0/0
C       10.1.0.0 is directly connected, Serial1/0
D       10.1.7.0 [90/2297856] via 10.1.0.2, 05:08:43, Serial1/0
D       10.1.6.0 [90/2297856] via 10.1.0.2, 05:08:43, Serial1/0
D       10.1.5.0 [90/2297856] via 10.1.0.2, 05:08:43, Serial1/0
D       10.1.4.0 [90/2195456] via 10.1.0.2, 05:08:43, Serial1/0
D*EX 0.0.0.0/0 [170/2221056] via 10.1.0.2, 00:02:43, Serial1/0

R2 show ip route

R2#show ip route 
~省略~

Gateway of last resort is 10.1.4.3 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 6 subnets
D       10.1.1.0 [90/2195456] via 10.1.0.1, 05:09:29, Serial1/0
C       10.1.0.0 is directly connected, Serial1/0
C       10.1.7.0 is directly connected, Loopback0
C       10.1.6.0 is directly connected, Loopback0
C       10.1.5.0 is directly connected, Loopback0
C       10.1.4.0 is directly connected, Ethernet0/0
D*EX 0.0.0.0/0 [170/307200] via 10.1.4.3, 00:03:29, Ethernet0/0

図 デフォルトルートのアドバタイズ
図 デフォルトルートのアドバタイズ

Step3:EIGRPスタブの設定

R2からR1へEIGRPクエリーを送信しないようにするためには、R1をスタブとして設定します。

R1

router eigrp 1
 eigrp stub connected summary

Step4:EIGRPスタブの確認

R2でshow ip eigrp neighbor detailコマンドでR1がスタブであることを確認します。

R2 show ip eigrp neighbor detail

R2#show ip eigrp neighbors detail 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.0.1                Se1/0             12 00:01:12   15   200  0  18
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 1
   Stub Peer Advertising ( CONNECTED SUMMARY ) Routes
   Suppressing queries
1   10.1.4.3                Et0/0             14 05:15:22  659  3954  0  8
   Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 1

図 EIGRPスタブの設定
図 EIGRPスタブの設定

Step5:集約ルートの生成

R2で集約ルートを生成して、Serial1/0から送信します。10.1.4.0/24~10.1.7.0/24の4つのルートを集約して、10.1.4.0/22の集約ルートを生成します。

R2

interface Serial1/0
 ip summary-address eigrp 1 10.1.4.0 255.255.252.0 5

Step7:集約ルートの確認

R2でshow ip eigrp topologyコマンドで集約ルートを生成していることを確認します。また、R1のルーティングテーブルに10.1.4.0/22が存在していることを確認します。

R2 show ip eigrp topology

R2#show ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(10.1.5.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 0.0.0.0/0, 1 successors, FD is 307200
        via 10.1.4.3 (307200/281600), Ethernet0/0
P 10.1.1.0/24, 1 successors, FD is 2195456
        via 10.1.0.1 (2195456/281600), Serial1/0
P 10.1.0.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/0
P 10.1.7.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 10.1.6.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 10.1.5.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 10.1.4.0/22, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 10.1.4.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0

R1 show ip route

R1#show ip route 
~省略~

Gateway of last resort is 10.1.0.2 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.1.1.0/24 is directly connected, Ethernet0/0
C       10.1.0.0/24 is directly connected, Serial1/0
D       10.1.4.0/22 [90/2297856] via 10.1.0.2, 00:02:30, Serial1/0
D*EX 0.0.0.0/0 [170/2221056] via 10.1.0.2, 00:06:51, Serial1/0

図 集約ルートの生成
図 集約ルートの生成


最終的な設定の抜粋

R1

hostname R1
!
interface Ethernet0/0
 ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 10.1.0.1 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 no auto-summary
 eigrp stub connected summary

R2

hostname R2
!
interface Loopback0
 ip address 10.1.6.2 255.255.255.0 secondary
 ip address 10.1.7.2 255.255.255.0 secondary
 ip address 10.1.5.2 255.255.255.0
!
interface Ethernet0/0
 ip address 10.1.4.2 255.255.255.0
!
interface Serial1/0
 ip address 10.1.0.2 255.255.255.0
 ip summary-address eigrp 1 10.1.4.0 255.255.252.0 5
!
router eigrp 1
 network 10.0.0.0
 no auto-summary

R3

hostname R3
!
interface Ethernet0/0
 ip address 10.1.4.3 255.255.255.0
!
interface Ethernet0/1
 ip address 100.1.1.3 255.255.255.0
!
router eigrp 1
 redistribute static
 network 10.0.0.0
 no auto-summary

ISP

hostname ISP
!
interface Loopback0
 ip address 150.1.1.10 255.255.255.0
!
interface Ethernet0/0
 ip address 100.1.1.10 255.255.255.0
!
ip route 10.0.0.0 255.0.0.0 100.1.1.3