ネットワーク構成

図 不連続サブネットにおけるEIGRPの設定 ネットワーク構成
図 不連続サブネットにおけるEIGRPの設定 ネットワーク構成

設定条件

  • 不連続サブネットのアドレス構成となっているR1、R2間で正しくルーティングできるように設定します。

不連続サブネットについて、以下の記事で解説しています。


確認条件

  • R1、R2間で正しくルーティングできることを確認します。

初期設定

以下の設定は設定済みとします。

  • ホスト名
  • IPアドレス
  • EIGRP
    各ルータのインタフェースはネットワーク構成のとおりEIGRPが有効化されている。それ以外の設定はデフォルト

設定

【Step1:ルーティングテーブルの確認】

R1、R2でルーティングテーブルを確認します。

R1 show ip route

R1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.1.1.0/24 is directly connected, Ethernet0/0
D       10.0.0.0/8 is a summary, 00:00:54, Null0

R2 show ip route

R2#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.2.2.0/24 is directly connected, Ethernet0/0
D       10.0.0.0/8 is a summary, 00:00:07, Null0

R1、R2のルーティングテーブルにはお互いのLAN側のルートが登録されていません。そのため、LAN間の通信ができません。また、Null0向けの10.0.0.0/8のルートがルーティングテーブルに登録されています。

R1とR2のルーティングテーブルにお互いのLAN側のルートが登録されていない原因は、不連続サブネットのアドレッシングと自動集約です。R1もR2も自動集約された10.0.0.0/8をアドバタイズします。そのため、ルーティングテーブルにお互いのLAN側のルート情報が登録されません。

図 R1/R2のEIGRPルートのアドバタイズ
図 R1/R2のEIGRPルートのアドバタイズ

【Step2:自動集約の無効化】

不連続サブネットのアドレッシングで、EIGRPのルーティングを行うためには自動集約を無効化します。

R1/R2 自動集約の無効化

router eigrp 1
 no auto-summary

【Step3:ルーティングテーブルと通信の確認】

自動集約を無効化したあと、ルーティングテーブルを確認します。

R1 show ip route

R1#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2195456] via 192.168.12.2, 00:00:56, Serial1/0
C       10.1.1.0 is directly connected, Ethernet0/0

R2 show ip route

R2#show ip route 
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.2.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/2195456] via 192.168.12.1, 00:00:15, Serial1/0

図 自動集約無効時のEIGRPルートのアドバタイズ
図 自動集約無効時のEIGRPルートのアドバタイズ

自動集約を無効化したので、R1はR2にLAN側の10.1.1.0/24をアドバタイズします。そして、R2はR1にLAN側の10.2.2.0/24をアドバタイズします。R1、R2でお互いのLAN側のルートをルーティングテーブルに登録できるようになったので、通信も可能です。

R1 ping

R1#ping 10.2.2.2 source 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/24 ms

最終的な設定の抜粋

R1

hostname R1
!
interface Ethernet0/0
 ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 network 192.168.12.0
 no auto-summary

R2

hostname R2
!
interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 network 192.168.12.0
 no auto-summary

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索