EIGRPでのデフォルトルート生成

デフォルトルートをEIGRPルートとして生成して、他のルータにアドバタイズするためには、以下のようにいくつかの方法があります。

  • スタティックルートのデフォルトルートをEIGRPへ再配送
  • ルート集約
  • ip default-networkコマンド

以降で、ルート集約によって、EIGRPでデフォルトルートを生成する設定例を解説します。

ルート集約によるデフォルトルートの生成

【ネットワーク構成】

図 ネットワーク構成
図 ネットワーク構成

【条件】

  • R2がR3へデフォルトルートをEIGRPでアドバタイズして、すべてのインタフェースの接続性を確保できるようにします。
  • デフォルトルートの生成はルート集約で行います。

【初期設定】

R1 初期設定

interface Loopback0
 ip address 172.16.2.1 255.255.255.0 secondary
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 192.168.12.2

R2 初期設定

interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
router eigrp 100
 network 192.168.23.0
 no auto-summary

R3 初期設定

interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router eigrp 100
 network 192.168.3.0
 network 192.168.23.0
 no auto-summary

【Step1:R3へルートをアドバタイズ】

R2からR3へ1つもルートをアドバタイズしていなければ、集約ルートを生成できません。R2で192.168.12.0/24もEIGRPプロセスに含んで、R3へルートをアドバタイズできるようにします。また、R1へEIGRPパケットを送信しないように、E0/0をパッシブインタフェースに指定します。

R2

router eigrp 100
 network 192.168.12.0
 passive-interface Ethernet0/0

【Step2:集約ルートとしてデフォルトルートを生成】

R2のE0/1で集約ルートの生成を行います。192.168.12.0/24のルートを集約して0.0.0.0/0をR3へアドバタイズするようにします。

R2

interface Ethernet0/1
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5

【Step3:デフォルトルートの確認】

R3のルーティングテーブルを見て、R2からデフォルトルートがアドバタイズされていることを確認します。

R3 show ip route

R3#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
D*   0.0.0.0/0 [90/307200] via 192.168.23.2, 00:01:06, Ethernet0/0

【Step4:通信確認】

R3からR1へpingを実行してみると、応答が返ってこないことがわかります。

R3

R3#ping 172.16.1.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
U.U.U
Success rate is 0 percent (0/5)
R3#ping 172.16.2.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
U.U.U
Success rate is 0 percent (0/5)

R3からR1へのPingが失敗するのはR2のルーティングテーブルに必要なルート情報が存在しないからです。R3はデフォルトルートを利用してR1宛てのパケットをR2へ転送します。しかし、R2のルーティングテーブルにR1へルーティングするためのルート情報が存在しないので、パケットは破棄されます。

【Step5:デフォルトルートの設定】

R2でR1へルーティングするためのルート情報として、デフォルトルートをスタティックルートとして設定します。

R2 デフォルトルートの設定

ip route 0.0.0.0 0.0.0.0 192.168.12.1

【Step6:通信確認】

再度、R3からR1へpingを実行すると正常に応答が返ってくることが確認できます。

R3

R3#ping 172.16.1.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/24 ms
R3#ping 172.16.2.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/16 ms

関連記事