概要

EIGRPによる基本的なルーティングを行う演習です。フレームリレーのNBMA環境の設定を扱っています。フレームリレーはもうレガシーなWANサービスですが、DMVPNのmGREトンネルでEIGRPを利用するときに参考になります。

ネットワーク構成

図 EIGRP ネットワーク構成
図 EIGRP ネットワーク構成

設定条件

  1. 図 EIGRPネットワーク構成の通りに各ルータでEIGRPの設定を行なってください。なお、フレームリレーにはブロードキャスト/マルチキャストパケットを送信できないようにしています。また、インタフェースに設定されているIPアドレスのサブネットマスクでルートをアドバタイズできるようにします。
  2. フレームリレーのインタフェースでは、EIGRPパケットが利用する帯域幅が25%になるようにしてください。また、ネイバーの障害検出を10秒以内にできるようにしてください。
  3. フレームリレー上でMD5のネイバー認証を行います。パスワードは任意の文字列で設定してください。
  4. R3はR6にEIGRPクエリーを送信しないようにしてください。
  5. R4でデフォルトルートをEIGRPでアドバタイズし、インターネットにアクセスできるようにします。
  6. ネットワーク構成上のすべてのIPアドレスに接続性があることを確認してください。

初期設定

以下の内容は設定済みです。

  • ホスト名
  • IPアドレス
  • フレームリレー接続
    • R1/R2/R3でbroadcastオプションなしでframe-relay mapの設定
  • スタティックルート
    • R4でデフォルトルートをスタティックで設定
  • NAT
    • R4で192.168.X.XをE1/1のIPアドレス100.0.0.4に変換

R1 Initical Configuration(Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.2 120 
 frame-relay map ip 192.168.123.3 130 
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.1 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 Initical Configuration(Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 210 
 frame-relay map ip 192.168.123.3 210
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 Initical Configuration(Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.3 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 310 
 frame-relay map ip 192.168.123.2 310
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.3 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.4 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/1
 ip address 100.0.0.4 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.0.0.10
!
ip nat inside source list 1 interface Ethernet1/1 overload
!
access-list 1 permit 192.168.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R5 Initical Configuration(Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.5 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.5 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 Initical Configuration(Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.6 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.6 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

ISP Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 100.0.0.10 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

設定と確認

Step1:EIGRPの有効化

各ルータでEIGRPを有効化します。

R1 EIGRPの有効化

router eigrp 1
 network 192.168.0.0
 network 192.168.14.0
 network 192.168.123.0
 no auto-summary

R2 EIGRPの有効化

router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 network 192.168.123.0
 no auto-summary

R3 EIGRPの有効化

router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 network 192.168.123.0
 no auto-summary

R4 EIGRPの有効化

router eigrp 1
 network 192.168.0.0
 network 192.168.14.0
 no auto-summary

R5 EIGRPの有効化

router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 no auto-summary

R6 EIGRPの有効化

router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 no auto-summary

Step2:EIGRPの確認

Step1のEIGRPの設定を確認するために、次のコマンドを利用します。

  • show ip protocols
  • show ip eigrp interfaces
  • show ip eigrp neighbor

R1では次のような表示です。

R1 EIGRPの確認

R1#show ip protocols 
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.0.0
    192.168.14.0
    192.168.123.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:02:27
    192.168.14.4          90      00:01:03
  Distance: internal 90 external 170

R1#show ip eigrp interfaces        
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo0                0        0/0         0       0/1            0           0
Se0/0              0        0/0         0       0/1            0           0
Et1/0              1        0/0        46       0/2           50           0
R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.14.4            Et1/0             10 00:02:14   46   276  0  3

Step3:フレームリレー上のネイバーの指定

フレームリレー上のR1-R2間、R1-R3間でEIGRPネイバーを確立できていません。この演習のフレームリレーにはマルチキャストパケットを送信できないようにしています。そのため、マルチキャスト224.0.0.10のHelloパケットがフレームリレーへ送信されていないからです。

マルチキャストパケットを転送できないフレームリレーネットワーク上でEIGRPネイバーを確立するために、neighborコマンドでネイバーのIPアドレスを指定します。これにより、ユニキャストでEIGRP Helloパケットを送信します。

R1 ネイバーの指定

router eigrp 1
 neighbor 192.168.123.2 Serial0/0
 neighbor 192.168.123.3 Serial0/0

R2 ネイバーの指定

router eigrp 1
 neighbor 192.168.123.1 Serial0/0

R3 ネイバーの指定

router eigrp 1
 neighbor 192.168.123.1 Serial0/0

ネイバーを指定すれば、R1-R2間、R1-R3間のEIGRPネイバーを確立することができます。R1でのネイバーの状態は次のようになります。

R1 show ip eigrp neighbors

R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   192.168.123.3           Se0/0            143 00:00:38 1040  5000  0  13
1   192.168.123.2           Se0/0            143 00:00:39   33   200  0  12
0   192.168.14.4            Et1/0             12 00:11:14   44   264  0  3

Step4:ルーティングテーブルの確認

ルーティングテーブルに必要なルート情報が登録されていることを確認します。R1~R3のルーティングテーブルは次のようになります。

R1 show ip route eigrp

R1#show ip route eigrp 
D    192.168.25.0/24 [90/2195456] via 192.168.123.2, 00:02:36, Serial0/0
D    192.168.36.0/24 [90/2195456] via 192.168.123.3, 00:02:34, Serial0/0
     192.168.0.0/32 is subnetted, 6 subnets
D       192.168.0.2 [90/2297856] via 192.168.123.2, 00:02:36, Serial0/0
D       192.168.0.3 [90/2297856] via 192.168.123.3, 00:02:34, Serial0/0
D       192.168.0.4 [90/409600] via 192.168.14.4, 00:13:09, Ethernet1/0
D       192.168.0.5 [90/2323456] via 192.168.123.2, 00:00:11, Serial0/0
D       192.168.0.6 [90/2323456] via 192.168.123.3, 00:02:34, Serial0/0

R2 show ip route eigrp

R2#show ip route eigrp 
D    192.168.14.0/24 [90/2195456] via 192.168.123.1, 00:06:08, Serial0/0
     192.168.0.0/32 is subnetted, 4 subnets
D       192.168.0.1 [90/2297856] via 192.168.123.1, 00:06:08, Serial0/0
D       192.168.0.4 [90/2323456] via 192.168.123.1, 00:06:08, Serial0/0
D       192.168.0.5 [90/409600] via 192.168.25.5, 00:03:44, Ethernet1/0

R3 show ip route eigrp

R3#show ip route eigrp 
D    192.168.14.0/24 [90/2195456] via 192.168.123.1, 00:06:23, Serial0/0
     192.168.0.0/32 is subnetted, 4 subnets
D       192.168.0.1 [90/2297856] via 192.168.123.1, 00:06:23, Serial0/0
D       192.168.0.4 [90/2323456] via 192.168.123.1, 00:06:23, Serial0/0
D       192.168.0.6 [90/409600] via 192.168.36.6, 00:16:38, Ethernet1/0

スポークルータのR2のルーティングテーブルには、R3配下のルートが存在しません。同様に、R3のルーティングテーブルにはR2配下のルートが存在しません。

Step5:スプリットホライズンの無効化

スポークルータ間でのルートの送受信ができていなのは、スプリットホライズンによるものです。R1 Serial0/0でスプリットホライズンを無効化します。

R1 スプリットホライズンの無効化

interface Serial0/0
 no ip split-horizon eigrp 1

スプリットホライズンを無効化すると、R2とR3のルーティングテーブルに必要なルート情報が登録されるようになったことがわかります。

R2 show ip route eigrp

R2#show ip route eigrp 
D    192.168.14.0/24 [90/2195456] via 192.168.123.1, 00:11:09, Serial0/0
D    192.168.36.0/24 [90/2707456] via 192.168.123.1, 00:00:36, Serial0/0
     192.168.0.0/32 is subnetted, 6 subnets
D       192.168.0.1 [90/2297856] via 192.168.123.1, 00:11:09, Serial0/0
D       192.168.0.3 [90/2809856] via 192.168.123.1, 00:00:36, Serial0/0
D       192.168.0.4 [90/2323456] via 192.168.123.1, 00:11:09, Serial0/0
D       192.168.0.5 [90/409600] via 192.168.25.5, 00:00:36, Ethernet1/0
D       192.168.0.6 [90/2835456] via 192.168.123.1, 00:00:36, Serial0/0

R3 show ip route eigrp

R3#show ip route eigrp 
D    192.168.14.0/24 [90/2195456] via 192.168.123.1, 00:11:21, Serial0/0
D    192.168.25.0/24 [90/2707456] via 192.168.123.1, 00:00:50, Serial0/0
     192.168.0.0/32 is subnetted, 6 subnets
D       192.168.0.1 [90/2297856] via 192.168.123.1, 00:11:21, Serial0/0
D       192.168.0.2 [90/2809856] via 192.168.123.1, 00:00:51, Serial0/0
D       192.168.0.4 [90/2323456] via 192.168.123.1, 00:11:21, Serial0/0
D       192.168.0.5 [90/2835456] via 192.168.123.1, 00:00:50, Serial0/0
D       192.168.0.6 [90/409600] via 192.168.36.6, 00:00:50, Ethernet1/0

図 スプリットホライズンの無効化
図 スプリットホライズンの無効化

Step6:ネイバー認証の設定

フレームリレー上でネイバー認証を行います。EIGRPのネイバー認証では、パスワードの設定としてキーチェインを利用します。R1/R2/R3でネイバー認証のための設定コマンドは同じです。

R1/R2/R3 ネイバー認証の設定

key chain EIGRP
 key 1
   key-string cisco
!
interface Serial0/0
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP

Step7:ネイバー認証の確認

ネイバー認証の確認のために、次のshowコマンドを実行します。

  • show ip eigrp interfaces detail
  • show key chain
  • show ip eigrp neighbors

R1では、次のような表示です。

R1 ネイバー認証の確認

R1#show ip eigrp interfaces detail serial 0/0
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              2        0/0        21       0/15         231           0
  Hello interval is 60 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 14/22
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 8
  Retransmissions sent: 1  Out-of-sequence rcvd: 1
  Authentication mode is md5,  key-chain is "EIGRP"
  Use unicast
R1#show key chain 
Key-chain EIGRP:
    key 1 -- text "cisco"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]
R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   192.168.123.3           Se0/0              9 00:00:34   57   342  0  28
1   192.168.123.2           Se0/0              8 00:00:43   32   200  0  40
0   192.168.14.4            Et1/0             12 00:44:24   33   200  0  11

Step8:タイマと帯域幅の設定

フレームリレー上でネイバー障害の検出を10秒以内にするために、ホールドタイマを10秒にします。それに合わせてHelloインターバルを3秒にします。また、Serial0/0でEIGRPパケットが利用する帯域幅を25%とします。

なお、EIGRPでは、OSPFとは異なりネイバー間でHelloインターバルとホールドタイマが不一致でも問題ありません。不一致の場合は、最小値が採用されます。ただし、通常は、タイマの変更は関連するすべてのルータで設定します。

R1/R2/R3 タイマと帯域幅の設定

interface Serial0/0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10

Step9:EIGRPスタブの設定

R6へEIGRPクエリーを送信しないようにするために、R6でEIGRPスタブの設定を行います。R6からアドバタイズするEIGRPルートとしては、デフォルトのconnectedとsummaryとします。

R6 EIGRPスタブの設定

router eigrp 1
 eigrp stub connected summary

R3でshow ip eigrp neighbors detailコマンドを見ると、R6がスタブでありクエリーを送信しないことが確認できます。

R3 show ip eigrp neighbors detail

R3#show ip eigrp neighbors detail ethernet 1/0
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.36.6            Et1/0             11 00:00:44   24   200  0  15
   Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 1
   Stub Peer Advertising ( CONNECTED SUMMARY ) Routes
   Suppressing queries

Step10:デフォルトルートのアドバタイズ

R4でEIGRPによってデフォルトルートをアドバタイズするために、スタティックルートをEIGRPに再配送します。

R4 デフォルトルートのアドバタイズ

router eigrp 1
 redistribute static

再配送後にEIGRPトポロジテーブルを確認すると、次のように0.0.0.0/0がEIGRPルートとなっていることがわかります。

R4 show ip eigrp topology

R4#show ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(192.168.0.4)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 0.0.0.0/0, 1 successors, FD is 281600
        via Rstatic (281600/0)
P 192.168.123.0/24, 1 successors, FD is 2195456
        via 192.168.14.1 (2195456/2169856), Ethernet1/0
P 192.168.36.0/24, 1 successors, FD is 2221056
        via 192.168.14.1 (2221056/2195456), Ethernet1/0
P 192.168.14.0/24, 1 successors, FD is 281600
        via Connected, Ethernet1/0
P 192.168.0.1/32, 1 successors, FD is 409600
        via 192.168.14.1 (409600/128256), Ethernet1/0
P 192.168.0.2/32, 1 successors, FD is 2323456
        via 192.168.14.1 (2323456/2297856), Ethernet1/0
P 192.168.0.3/32, 1 successors, FD is 2323456
        via 192.168.14.1 (2323456/2297856), Ethernet1/0
P 192.168.0.4/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 192.168.0.5/32, 1 successors, FD is 2349056
        via 192.168.14.1 (2349056/2323456), Ethernet1/0
P 192.168.0.6/32, 1 successors, FD is 2349056
        via 192.168.14.1 (2349056/2323456), Ethernet1/0
P 192.168.25.0/24, 1 successors, FD is 2221056
        via 192.168.14.1 (2221056/2195456), Ethernet1/0

R4で生成されたデフォルトルートがR1へとアドバタイズされています。R1のルーティングテーブルにEIGRPのルートとしてデフォルトルートが登録されています。

R1 show ip route eigrp

R1#show ip route eigrp 
D    192.168.25.0/24 [90/2195456] via 192.168.123.2, 00:08:41, Serial0/0
D    192.168.36.0/24 [90/2195456] via 192.168.123.3, 00:08:32, Serial0/0
     192.168.0.0/32 is subnetted, 6 subnets
D       192.168.0.2 [90/2297856] via 192.168.123.2, 00:08:41, Serial0/0
D       192.168.0.3 [90/2297856] via 192.168.123.3, 00:08:32, Serial0/0
D       192.168.0.4 [90/409600] via 192.168.14.4, 00:52:20, Ethernet1/0
D       192.168.0.5 [90/2323456] via 192.168.123.2, 00:08:41, Serial0/0
D       192.168.0.6 [90/2323456] via 192.168.123.3, 00:05:10, Serial0/0
D*EX 0.0.0.0/0 [170/307200] via 192.168.14.4, 00:00:53, Ethernet1/0

Step11:通信確認

pingによって通信の確認を行います。

R1 Ping

R1#ping 100.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/32/36 ms
R1#ping 192.168.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/28 ms
R1#ping 192.168.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/44 ms
R1#ping 192.168.0.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/24/32 ms
R1#ping 192.168.0.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/35/56 ms
R1#ping 192.168.0.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/40 ms

演習完了の設定ファイル

R1 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 serial restart-delay 0
 frame-relay map ip 192.168.123.2 120
 frame-relay map ip 192.168.123.3 130
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.1 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.14.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.3 Serial0/0
 neighbor 192.168.123.2 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 210
 frame-relay map ip 192.168.123.3 210
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.1 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.3 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 310
 frame-relay map ip 192.168.123.2 310
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.3 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.1 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.4 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/1
 ip address 100.0.0.4 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 redistribute static
 network 192.168.0.0
 network 192.168.14.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.0.0.10
!
ip nat inside source list 1 interface Ethernet1/1 overload
!
access-list 1 permit 192.168.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R5 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.5 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.5 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.6 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.6 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 no auto-summary
 eigrp stub connected summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

ISR Completed Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 100.0.0.10 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

関連記事

関連記事