ネットワーク構成

図 EIGRPセカンダリアドレスのアドバタイズ ネットワーク構成

設定概要

各ルータのEIGRPに関連する設定は次のとおりです。

R1

interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.21.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.14.1 255.255.255.0
 encapsulation ppp
!
router eigrp 1
 network 192.168.12.0
 network 192.168.14.0
 network 192.168.21.0
 no auto-summary

R2

interface Loopback0
 ip address 192.168.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.21.2 255.255.255.0
!
interface Ethernet0/2
 ip address 192.168.23.2 255.255.255.0
!
router eigrp 1
 network 192.168.2.0
 network 192.168.12.0
 network 192.168.21.0
 network 192.168.23.0
 no auto-summary

R3

interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.3.3 255.255.255.0 secondary
 ip address 192.168.34.3 255.255.255.0
!
router eigrp 1
 network 192.168.23.0
 network 192.168.34.0
 no auto-summary

R4

interface Ethernet0/0
 ip address 192.168.34.4 255.255.255.0
!
interface Serial1/0
 ip address 192.168.14.4 255.255.255.0
 encapsulation ppp
!
router eigrp 1
 network 192.168.14.0
 network 192.168.34.0
 no auto-summary

問題

R4から192.168.3.3に対するTracerouteの結果が次のように表示されるようにしてください。

R4#traceroute 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.3.3

  1 192.168.34.3 20 msec *  16 msec

解答

R3

interface Ethernet0/1
 no ip split-horizon eigrp 1
!
router eigrp 1
 network 192.168.3.0

ワンポイント

  • セカンダリアドレスをアドバタイズするためには、別途、networkコマンドが必要
  • スプリットホライズンによって、ルートの出力インタフェースにはアドバタイズしない

解説

R4からR3のE0/1に設定しているセカンダリアドレス192.168.3.3へのTracerouteが条件のようになるためには、以下のことが必要です。

  • R3のE0/1から192.168.3.0/24のルートをEIGRPでアドバタイズすること

R3の下記のように、network 192.168.34.0コマンドによってE0/1でEIGRPが有効になっています。

R3

R3#show run | section router eigrp
router eigrp 1
 network 192.168.23.0
 network 192.168.34.0
 no auto-summary
R3#show ip eigrp interfaces
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et0/0              1        0/0        28       0/2           96           0
Et0/1              1        0/0        35       0/2          140           0

ところが、EIGRPのルートとして扱うのはプライマリのIPアドレスに対応しているネットワークアドレスのみです。EIGRPトポロジテーブルは次のようになっています。

R3

R3#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.34.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.34.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/1
P 192.168.14.4/32, 1 successors, FD is 2221056
        via 192.168.23.2 (2221056/2195456), Ethernet0/0
P 192.168.12.0/24, 1 successors, FD is 307200
        via 192.168.23.2 (307200/281600), Ethernet0/0
P 192.168.14.0/24, 1 successors, FD is 2195456
        via 192.168.34.4 (2195456/2169856), Ethernet0/1
P 192.168.14.1/32, 1 successors, FD is 2195456
        via 192.168.34.4 (2195456/2169856), Ethernet0/1
P 192.168.2.0/24, 1 successors, FD is 409600
        via 192.168.23.2 (409600/128256), Ethernet0/0
P 192.168.21.0/24, 1 successors, FD is 307200
        via 192.168.23.2 (307200/281600), Ethernet0/0
P 192.168.23.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0

R3のE0/1のセカンダリアドレスのルート192.168.3.0/24をEIGRPルートとして生成するためには、別途、以下のnetworkコマンドが必要です。

R3

router eigrp 1
 network 192.168.3.0

すると、192.168.3.0/24のルートがEIGRPトポロジテーブルに登録されて、他のネイバーへとアドバタイズされるようになります。

R3

R3#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.34.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.34.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/1
P 192.168.14.4/32, 1 successors, FD is 2221056
        via 192.168.23.2 (2221056/2195456), Ethernet0/0
P 192.168.12.0/24, 1 successors, FD is 307200
        via 192.168.23.2 (307200/281600), Ethernet0/0
P 192.168.14.0/24, 1 successors, FD is 2195456
        via 192.168.34.4 (2195456/2169856), Ethernet0/1
P 192.168.14.1/32, 1 successors, FD is 2195456
        via 192.168.34.4 (2195456/2169856), Ethernet0/1
P 192.168.2.0/24, 1 successors, FD is 409600
        via 192.168.23.2 (409600/128256), Ethernet0/0
P 192.168.3.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/1
P 192.168.21.0/24, 1 successors, FD is 307200
        via 192.168.23.2 (307200/281600), Ethernet0/0
P 192.168.23.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0

ただし、R3はE0/1から192.168.3.0/24のルートをアドバタイズしません。これはスプリットホライズンによるためです。スプリットホライズンは、「ルートを受信したインタフェースから送り返さない」というように説明されることが多いのですが、より正確には、「ルートの出力インタフェースからルートをアドバタイズしない」ということです。

192.168.3.0/24の出力インタフェースはE0/1であるため、スプリットホライズンによって、R3はE0/1から192.168.3.0/24のルートをアドバタイズしません。その結果、R4のルーティングテーブルには192.168.3.0/24のルートは以下のように登録されて、192.168.3.3へのTracerouteの結果は条件通りになりません。

R4

R4#show ip route 192.168.3.0
Routing entry for 192.168.3.0/24
  Known via "eigrp 1", distance 90, metric 2246656, type internal
  Redistributing via eigrp 1
  Last update from 192.168.14.1 on Serial1/0, 00:06:26 ago
  Routing Descriptor Blocks:
  * 192.168.14.1, from 192.168.14.1, 00:06:26 ago, via Serial1/0
      Route metric is 2246656, traffic share count is 1
      Total delay is 23000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 3

R4#traceroute 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.3.3

  1 192.168.14.1 20 msec 16 msec 20 msec
  2 192.168.21.2 40 msec 44 msec 44 msec
  3 192.168.23.3 60 msec *  64 msec

R4から192.168.3.3へのTracerouteの結果が条件通りになるためには、R3はE0/1から192.168.3.0/24のルートをアドバタイズしなければいけません。そのために、R3 E0/1でのスプリットホライズンを無効化します。

R3

interface Ethernet0/1
 no ip split-horizon eigrp 1

その後、R4のルーティングテーブルと192.168.3.3へのTracerouteは次のようになります。

R4

R4#show ip route 192.168.3.0
Routing entry for 192.168.3.0/24
  Known via "eigrp 1", distance 90, metric 307200, type internal
  Redistributing via eigrp 1
  Last update from 192.168.34.3 on Ethernet0/0, 00:00:38 ago
  Routing Descriptor Blocks:
  * 192.168.34.3, from 192.168.34.3, 00:00:38 ago, via Ethernet0/0
      Route metric is 307200, traffic share count is 1
      Total delay is 2000 microseconds, minimum bandwidth is 10000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

R4#traceroute 192.168.3.3

Type escape sequence to abort.
Tracing the route to 192.168.3.3

  1 192.168.34.3 44 msec *  20 msec

図 EIGRPセカンダリアドレスのアドバタイズ
図 EIGRPセカンダリアドレスのアドバタイズ


関連記事